02 sensors

RuskiRacer

Sergeant
Jul 17, 2019
348
123
0
Ride
2009 e93 335i
Well the mixture control makes sense because I maybe forgot to clear the code once I put the new o2s in. My doc kit was doing pretty good with 02s when I did have it up and running. I geuss my next step here is gonna be sending fcp back pretty much everything I'm gonna send them back fuel injectors, coilpacks ,plugs start fresh and then if I still have an issue. It will hopefully be easier to track down.
 

RuskiRacer

Sergeant
Jul 17, 2019
348
123
0
Ride
2009 e93 335i
Oh Plus they can have there cracked valve cover back to im sure that's not helping me out at all either
 
  • Like
Reactions: aus335iguy

RuskiRacer

Sergeant
Jul 17, 2019
348
123
0
Ride
2009 e93 335i
20201231_104843.jpg
Forgot to post this yesterday. Maybe like 500 miles on these 97506 ngks gapped to.020. Cylinder 6 which is don't have pictured here was the best looking by far.
 

RuskiRacer

Sergeant
Jul 17, 2019
348
123
0
Ride
2009 e93 335i
Yeah at first I didn't really think my plugs could be an issue because I put plugs in before I did my swap and put the single on. And it ran mint, Never seen plugs get so bad so fast. Thankfully I got all my parts through fcp euro so its all going back and hopefully when I get new hardware it just runs how it should.
 

DCook

Sergeant
May 25, 2018
260
125
0
Ride
08 BMW e92
Mine have never gotten that bad. And i beat the shit out of 4 motors. Wonder if you got bad injectors or something along those lines.
 

dmacc

Lurker
Dec 1, 2020
10
1
0
You can monitor the voltage of your 02 sensors just look for large voltage swings between the two, once they go out or start to fail the car can run stupid rich. I think that valve cover leak is definitely contributing as well.
 

Brule

Corporal
Feb 20, 2017
235
206
0
Ride
335i 2007 6spd manual
Its pretty clear your spark plugs are not the problem but the amount of oil on them is the issue.

Get the valve cover and see whats leaking.
 

DCook

Sergeant
May 25, 2018
260
125
0
Ride
08 BMW e92
Just another reason why i wish downpipe o2s for ST was a thing. Would save so much hassle and money. The reason i got rid of my n54.
 

RuskiRacer

Sergeant
Jul 17, 2019
348
123
0
Ride
2009 e93 335i
Lol getting rid of the n54 doesn't sound to bad at the moment. But yes I do have port injection now but not like I have been driving around with it . Think its a good idea I get new index 12s as well ? I was gonna get the new valve cover ,spark plugs and coilpacks but I could also get the injectors I may as well. 02 sensors are now new so I think I eliminated that issue.
 

DCook

Sergeant
May 25, 2018
260
125
0
Ride
08 BMW e92
If the new o2 fixed the issue i would see how it does before dumping more money or dealing with warranties, just toss in new plugs. Im also a cheap ass.
 

RuskiRacer

Sergeant
Jul 17, 2019
348
123
0
Ride
2009 e93 335i
Yeah I think I'll probably start with just plugs and coils since I have my backup set of coils in, kinda just want fresh coils to eliminate that as being a potential issue. And yeah trust me fcp can be difficult to deal with they sent me one o2 sensor at first then I had to wait another week on the other one they forgot to send
 

RuskiRacer

Sergeant
Jul 17, 2019
348
123
0
Ride
2009 e93 335i
20210108_165607.jpg
Ok guys got a new load of parts in. Gonna try and tow my car to my uncles shop. Just to cold to work on jackstands in MN this time of the year. If this doesn't fix my issues with my car idling like a rotary not sure what will. Car had good compression too before I started the manual swap so compression is not a issue.
 

dmacc

Lurker
Dec 1, 2020
10
1
0
View attachment 47960Ok guys got a new load of parts in. Gonna try and tow my car to my uncles shop. Just to cold to work on jackstands in MN this time of the year. If this doesn't fix my issues with my car idling like a rotary not sure what will. Car had good compression too before I started the manual swap so compression is not a issue.
Good luck!
 

RuskiRacer

Sergeant
Jul 17, 2019
348
123
0
Ride
2009 e93 335i
New sparkplugs and coilpacks seemed to do the trick she idled pretty good but I shut her down quickly because I didn't need this leaking everywhere. Has a new gasket but I didn't replace the bolts and this is what I get, wasn't leaking before but I had to mess with it lol.
20210111_135900.jpg
 

DCook

Sergeant
May 25, 2018
260
125
0
Ride
08 BMW e92
Well, did ya learn 99% of the bolts are one time use now? Haha. Glad you got it sorted! Drive it and check plug tightness after a while. I had one loosen up before a roll race once, threw a nasty misfire under heavy load.
 
  • Like
Reactions: RuskiRacer

RuskiRacer

Sergeant
Jul 17, 2019
348
123
0
Ride
2009 e93 335i
Yeah lol I knew they were one time use I was tryna be a cheapass and see if I could get away with it , geuss not . I'm gonna take the plugs out again and actually gap then I kinda just threw them in there to see what would happen and it fired right up and ran smoothly I only let it idle about 20 seconds because of the oil leak. I'm gonna swap my old cold climate oil filter housing on for now until my new bolts and oil cooler delete plate come . I'll make sure to double check plug tightness after I take her for a spin.
 

RuskiRacer

Sergeant
Jul 17, 2019
348
123
0
Ride
2009 e93 335i
Screenshot_20210112-190516_JB4 Mobile.jpg
I attempted to take the car for a little spin but I kept getting the 2c24 mainly. I got the fuel mixture control codes when I let it sit for a bit. Weird thing is my mhd wifi flasher all of a sudden doesn't work any more either. I'm pretty sure 2c24 is having the 02s mis matched so I can swap them
Screenshot_20210112-114713_JB4 Mobile.jpg
 

DCook

Sergeant
May 25, 2018
260
125
0
Ride
08 BMW e92
Yeah it appears so. Just swap the plug-ins and should be good. Unless you toasted o2 sensors again lol