02 sensors

RuskiRacer

Sergeant
Jul 17, 2019
357
128
0
Ride
2009 e93 335i
Does it matter if I use a 535 rear upstream 02 sensor on my 335 single turbo only difference I can see is the 535 is 100 mm shorter and 40 dollars cheaper.
Screenshot_20201223-010119_Firefox.jpg
 

b4llistic

Corporal
Nov 22, 2018
119
89
0
Ride
BMW N54
EDIT: Thanks your finding and reading my post. Unfortunately, Spoolstreet is no longer a neutral platform where we can have honest discussions on subjects and products freely.
For this reason I have deleted all information I posted on the forums.
 
Last edited:

RuskiRacer

Sergeant
Jul 17, 2019
357
128
0
Ride
2009 e93 335i
I don’t see how if it’s the same sensor he’s cutting the wrong corners ... am I missing something here

I don’t see how if it’s the same sensor he’s cutting the wrong corners ... am I missing something here?
Yeah my understanding is that they are both for the rear turbo bank 2 . One is 1100 mm on length(535) the other 1200mm in length (335). Not trying to cut corners just tryna save a couple bucks since this car has been draining my wallet and hasn't moved off of jackstands for a month.
 
  • Like
Reactions: aus335iguy

E92-Ghandi

Corporal
Feb 25, 2018
105
34
0
Ride
2010 335i e92 DCT
You can use any Ls4.9 O2 sensor. As long as the cable is long enough.
Try some gm cars they are cheaper.
Do you think these will work on DOC race manifold? can they handle the heat? i change o2 sensors every month lol using bosch!
 

RuskiRacer

Sergeant
Jul 17, 2019
357
128
0
Ride
2009 e93 335i
I was using Bosch sensors on my doc race manifold they were holding up till I did my swap. not sure every manifold is a little different
 

RuskiRacer

Sergeant
Jul 17, 2019
357
128
0
Ride
2009 e93 335i
Any help guys ? Zero misfires or anything like that. Brand new Bosch 02 sensors. Can it be my coilpacks? Thats what I'm thinking since they were an issue when my friend had a misfire I let him try them , they made his care run worse.
 

dmacc

Lurker
Dec 1, 2020
10
1
0
Any help guys ? Zero misfires or anything like that. Brand new Bosch 02 sensors. Can it be my coilpacks? Thats what I'm thinking since they were an issue when my friend had a misfire I let him try them , they made his care run worse.
mileage on your plugs? Could be those coilpacks if they haven't been replaced in a while. Upgrading to PR coils saved me a bunch of coil headaches that I used to get with this engine all the time. It sounds like a spark issue. What cylinders are misfiring?
 

RuskiRacer

Sergeant
Jul 17, 2019
357
128
0
Ride
2009 e93 335i
I pulled the plugs out this morning to see what they look like there not good at all for having less than 500 miles on them but regardless I don't think thats my issue. The only difference from this new car i built to my last car is I have a jb4 and port injection now. I unplugged cylinder 2 coilpack to see how it would run and there's no difference. I unplug cylinder 1 and the car dies . Not really sure whats going on , I guess I'm gonna buy another mhd license for this new vin number of mine and rip out the jb4. Literally have zero clue left what to do. Terry at bms says I should take it to a good mechanic lol. I'd like to know what this other good mechanic would do. I've tried multiple sets of new pencil style coils nothing changes I don't think my issue is in the hardware itself everything is brand new and seems to work on other peoples cars when I try it on theres.
 

dmacc

Lurker
Dec 1, 2020
10
1
0
I pulled the plugs out this morning to see what they look like there not good at all for having less than 500 miles on them but regardless I don't think thats my issue. The only difference from this new car i built to my last car is I have a jb4 and port injection now. I unplugged cylinder 2 coilpack to see how it would run and there's no difference. I unplug cylinder 1 and the car dies . Not really sure whats going on , I guess I'm gonna buy another mhd license for this new vin number of mine and rip out the jb4. Literally have zero clue left what to do. Terry at bms says I should take it to a good mechanic lol. I'd like to know what this other good mechanic would do. I've tried multiple sets of new pencil style coils nothing changes I don't think my issue is in the hardware itself everything is brand new and seems to work on other peoples cars when I try it on theres.
Ahh I see, were the plugs wet from fuel by chance? How many cylinders are misfiring?
 

RuskiRacer

Sergeant
Jul 17, 2019
357
128
0
Ride
2009 e93 335i
I don't know what cylinders are actually misfiring because I don't get any misfire codes. Cylinder 1 seemed to be a little wet which is kinda odd since there brand new index 12s from fcp euro but its not out of the question one could be bad. Cylinder 2 and 3 had like a slight amount of oil.
 

RuskiRacer

Sergeant
Jul 17, 2019
357
128
0
Ride
2009 e93 335i
Here is the weird thing though I can unplug cylinder 2 coilpack it will run exactly the same I unplug cylinder 1 the car dies. Not sure what the correlation there is I can send all my sparkplugs,coilpacks,injectors back to fcp and start from scratch I geuss..otherwise I will probably just part the car out its been to much of a money pit headache chasing one issue after another.
 

RuskiRacer

Sergeant
Jul 17, 2019
357
128
0
Ride
2009 e93 335i
20201231_175141.jpg
This is on my valve cover the back tab broke off, could this be giving me issues?
 

dmacc

Lurker
Dec 1, 2020
10
1
0
If your valve cover is leaking oil it could definitely contribute to those issues, depending on how much it's leaking.
 

DCook

Sergeant
May 25, 2018
260
125
0
Ride
08 BMW e92
Mixture control is definitely an o2 sensor. Ive been through 8 sensors on my doc kit. A combination of bad o2 and fouled plugs wont help if pulling #2 and it not changing anything will definitely do it. Thata what sucks about single turbos, they eat o2 for breakfast unfortunately