Jb4 32_6 firmware update meth problems

AK135i

Corporal
Dec 13, 2016
117
32
0
27
Anchorage, Alaska
Ride
2010 135i
Since I've downloaded the latest firmeware my meth flow has been acting up. At first it was slow to reach 100% which it always hits, now today it was hitting at best 50%, i did three short pulls not even revving it out, around 4000-5000 rpm. Then the car seemed to shudder at light loads in 5th and 6th gear. I get home and the car will start 2stepping by its self with the clutch out when revved to the set rpm, and now it has a very rough idle to the point it's making my flywheel rattle the car sounds like it has a dead cylinder and has a GT-R like exhaust note, I figure its the flywheel because the sound lessens or goes away when the clutch it pressed. Anyways, mods are meth with a 43 additive (using 100% denatured alcohol, full tank), dp's, intakes, G5 ISO, and mhd bef 42,000 miles using 90 octane, I was on the race flash. I tried to purge the meth system and it will not climb over 75% car was on battery charger also. All plugs look clean, no codes either. I've attached my csv logs from yesterday when the car was running good and the first log where I noticed the meth flow drop. any help where to start would be nice. I also just installed a RB external pcv with the mishimotto catch can, if that makes a difference.
 

Attachments

  • 2017-03-19 00_46_37.csv
    9.4 KB · Views: 299
  • 2017-03-20 14_22_05.csv
    6.7 KB · Views: 295
Last edited:

AK135i

Corporal
Dec 13, 2016
117
32
0
27
Anchorage, Alaska
Ride
2010 135i
update: I reflashed the previous firmware 32_5 and the meth problems and the 2 step problems seemed to vanished, rough idle it still there so i reset adaptations and no luck, so ill try switching plugs around Still no codes or misfires. I also unchecked the cold start noise delete though mhd and that seemed to help as well. Ive has this problem in the past with the cold start delete, i figured it was a coincidence where the idle and throttle would start acting up with the mhd setting, i figured with warmer temps i could try that again.
 

AK135i

Corporal
Dec 13, 2016
117
32
0
27
Anchorage, Alaska
Ride
2010 135i
Did you read the notes on the 32_6 release? The scaling has changed along with several other items you should review.
I did read the notes. It's not normal to be hitting 40-50% meth flow. It said to expect less flow, I had the firmeware for 3 days and it decided to do it out of nowhere. I was still hitting 100% even after the update.
 

Snelson3003

Sergeant
Nov 7, 2016
325
199
0
Denver
www.nelsonracingwheel.com
Ride
2010 BMW 135i
You know what, same here but on the Port Inejction side of things. - Same thing with the FW but instead of meth my fields use for PI.

I switched back to the old FW 32-5 and will test to see. Who knows maybe you are onto something!
 

AK135i

Corporal
Dec 13, 2016
117
32
0
27
Anchorage, Alaska
Ride
2010 135i
You know what, same here but on the Port Inejction side of things. - Same thing with the FW but instead of meth my fields use for PI.

I switched back to the old FW 32-5 and will test to see. Who knows maybe you are onto something!
I switched back to 32_5 and instantly first prime I hit 100% flow
 

Snelson3003

Sergeant
Nov 7, 2016
325
199
0
Denver
www.nelsonracingwheel.com
Ride
2010 BMW 135i
Similar experience. Went back to old FW version and it appears my PI kicks on sooner with greater flow.

My FOL dropped by 5 points too which tells me it's not a graphing issue but rather a change in the overall control. Or perhaps it's only a coincidence... But I'm sticking with my 32_5 FW.
 

[email protected]

Sergeant
Platinum Vendor
Jan 23, 2017
460
371
25
This is a good example of people making changes without regard for what their actual data is telling them. Normally to their long term detriment.

Per the firmware notes the FSB analog input voltage scaling was adjusted on v32.6 for improved accuracy. If you are hitting only 40% meth flow on the new v32.6 firmware then the solution is to fix your physical meth flow. Not roll back to a firmware with less aggressive scaling. Furthermore there are also minor changes to the PI signal back and any major changes there should be looked at in detail.

If either of you wind up needing specific assistance as always post a JB4 log along with your mods and fuel used to n54tech's support forum.

PS.

1) When purging meth the line must be removed from the nozzle and during this process you will not get an accurate flow reading.

2) 2STEP is set to trigger at 50% gas pedal input when reported gear is 0 and road speed less than 5kmh. Not really following what your issue is there. If the car is not moving and you are pressing the gas pedal down 50% or more the 2STEP will try to engage with both firmware versions.
 
Last edited:

AK135i

Corporal
Dec 13, 2016
117
32
0
27
Anchorage, Alaska
Ride
2010 135i
This is a good example of people making changes without regard for what their actual data is telling them. Normally to their long term detriment.

Per the firmware notes the FSB analog input voltage scaling was adjusted on v32.6 for improved accuracy. If you are hitting only 40% meth flow on the new v32.6 firmware then the solution is to fix your physical meth flow. Not roll back to a firmware with less aggressive scaling. Furthermore there are also minor changes to the PI signal back and any major changes there should be looked at in detail.

If either of you wind up needing specific assistance as always post a JB4 log along with your mods and fuel used to n54tech's support forum.

PS.

1) When purging meth the line must be removed from the nozzle and during this process you will not get an accurate flow reading.

2) 2STEP is set to trigger at 50% gas pedal input when reported gear is 0 and road speed less than 5kmh. Not really following what your issue is there. If the car is not moving and you are pressing the gas pedal down 50% or more the 2STEP will try to engage with both firmware versions.


I primed my meth pump (nozzle out in a bottle) for 30 minutes and could not reach over 75% flow. As soon as I switched firmware first prime I hit 100%, and it had a full tank. So I'm positive the FW had an effect in that regards and it's nothing to do with my physical parts. And I did read the notes, I knew it was going to be hitting less. But not at 50%, I wasn't expecting that much of a drop, along with it, it was very slow to reach max flow. As for the 2 step, can't say much for that, I havent touch my settings or opened my dme up for months. 2 step kept engaging with the clutch out at any pedal % as long as it reached the set rom value until I switched back to the previous firmware.

I should have posted in n54tech first but I'll try and rule out everything to make sure there weren't any other factors involved to make another help thread
 

08_335i

Sergeant
Nov 3, 2016
372
217
0
28
Ride
2008 ST 335i
I primed my meth pump (nozzle out in a bottle) for 30 minutes and could not reach over 75% flow. As soon as I switched firmware first prime I hit 100%, and it had a full tank. So I'm positive the FW had an effect in that regards and it's nothing to do with my physical parts. And I did read the notes, I knew it was going to be hitting less. But not at 50%, I wasn't expecting that much of a drop, along with it, it was very slow to reach max flow. As for the 2 step, can't say much for that, I havent touch my settings or opened my dme up for months. 2 step kept engaging with the clutch out at any pedal % as long as it reached the set rom value until I switched back to the previous firmware.

I should have posted in n54tech first but I'll try and rule out everything to make sure there weren't any other factors involved to make another help thread

What he stated, and also stated in the notes of 32.6, is that your reading WILL show lower then previously due to the new form\function. Run your test for 30 seconds on the old firmware, see how many cups of methanol you produce into your bucket. Put the new firmware on, do the same test, and see what your results are..
 

AK135i

Corporal
Dec 13, 2016
117
32
0
27
Anchorage, Alaska
Ride
2010 135i
What he stated, and also stated in the notes of 32.6, is that your reading WILL show lower then previously due to the new form\function. Run your test for 30 seconds on the old firmware, see how many cups of methanol you produce into your bucket. Put the new firmware on, do the same test, and see what your results are..
I guess so. Just because it says that it WILL read lower, doesn't mean I want to take that chance hitting a max of 40-50% meth flow. It didn't say how low it would read. I went from 100% to 50% to me that's a red flag. I'll switch back and see if the problem occurs. Then I'll do a meth prime and measure how much fluid comes out with either firmeware and report back. If the new firmware still puts out the same amout of fluid with a lower reading, wouldn't I set the meth flow scaling to 40 or 50%?
 

08_335i

Sergeant
Nov 3, 2016
372
217
0
28
Ride
2008 ST 335i
I guess so. Just because it says that it WILL read lower, doesn't mean I want to take that chance hitting a max of 40-50% meth flow. It didn't say how low it would read. I went from 100% to 50% to me that's a red flag. I'll switch back and see if the problem occurs. Then I'll do a meth prime and measure how much fluid comes out with either firmeware and report back. If the new firmware still puts out the same amout of fluid with a lower reading, wouldn't I set the meth flow scaling to 40 or 50%?

I'd do a prime and find out if the flows are the same\similar still, and go from there.
 

AK135i

Corporal
Dec 13, 2016
117
32
0
27
Anchorage, Alaska
Ride
2010 135i
This is a good example of people making changes without regard for what their actual data is telling them. Normally to their long term detriment.

Per the firmware notes the FSB analog input voltage scaling was adjusted on v32.6 for improved accuracy. If you are hitting only 40% meth flow on the new v32.6 firmware then the solution is to fix your physical meth flow. Not roll back to a firmware with less aggressive scaling. Furthermore there are also minor changes to the PI signal back and any major changes there should be looked at in detail.

If either of you wind up needing specific assistance as always post a JB4 log along with your mods and fuel used to n54tech's support forum.

PS.

1) When purging meth the line must be removed from the nozzle and during this process you will not get an accurate flow reading.

2) 2STEP is set to trigger at 50% gas pedal input when reported gear is 0 and road speed less than 5kmh. Not really following what your issue is there. If the car is not moving and you are pressing the gas pedal down 50% or more the 2STEP will try to engage with both firmware versions.


Any idea why my idle would be to rough, it still sounds like it's running on 5 cylinders.
 

[email protected]

Sergeant
Platinum Vendor
Jan 23, 2017
460
371
25
I primed my meth pump (nozzle out in a bottle) for 30 minutes and could not reach over 75% flow. As soon as I switched firmware first prime I hit 100%, and it had a full tank. So I'm positive the FW had an effect in that regards and it's nothing to do with my physical parts. And I did read the notes, I knew it was going to be hitting less. But not at 50%, I wasn't expecting that much of a drop, along with it, it was very slow to reach max flow. As for the 2 step, can't say much for that, I havent touch my settings or opened my dme up for months. 2 step kept engaging with the clutch out at any pedal % as long as it reached the set rom value until I switched back to the previous firmware.

I should have posted in n54tech first but I'll try and rule out everything to make sure there weren't any other factors involved to make another help thread

If you were priming for 30 minutes you probably ran the tank empty a few times. :) You normally purge for a few seconds until there is a steady stream of fluid coming out. If a value of 50 is as much as your pump/setup will put out at 100% dutycycle then so be it. Pumps get old over time. You could verify the pumps internal pressure relief is set a turn or two tighter than stock.

If not moving the 2step should engage any time the car isn't moving. Older firmware had a bug that required the clutch to be pressed in, which prevented automatic trans cars from using it as a noise maker.

Generally speaking any post asking for specific tuning help without a log is a waste of time 19 times out of 20.
 

AK135i

Corporal
Dec 13, 2016
117
32
0
27
Anchorage, Alaska
Ride
2010 135i
If you were priming for 30 minutes you probably ran the tank empty a few times. :) You normally purge for a few seconds until there is a steady stream of fluid coming out. If a value of 50 is as much as your pump/setup will put out at 100% dutycycle then so be it. Pumps get old over time. You could verify the pumps internal pressure relief is set a turn or two tighter than stock.

If not moving the 2step should engage any time the car isn't moving. Older firmware had a bug that required the clutch to be pressed in, which prevented automatic trans cars from using it as a noise maker.

Generally speaking any post asking for specific tuning help without a log is a waste of time 19 times out of 20.


I had the tank full at 2.3 gallon and was using a 1 gallon tank to spray also had on a berry tender to the battery wouldn't die while priming . So at best my tank was half empty, and there are 2 csv logs attached to my first post on top I have the log where I hit 50% flow. Thanks for taking time to help anyways.
 

[email protected]

Sergeant
Platinum Vendor
Jan 23, 2017
460
371
25
Given the differences in the logs I'd guess something has changed between them, like pump sucking air and needing to be purged, maybe a grounding issue, or pump just wearing out.
 

AK135i

Corporal
Dec 13, 2016
117
32
0
27
Anchorage, Alaska
Ride
2010 135i
Given the differences in the logs I'd guess something has changed between them, like pump sucking air and needing to be purged, maybe a grounding issue, or pump just wearing out.
Ill take your expert advise, only thing I could assume is a dying pump, because everything else checked out. The idle Is still very rough and has a very uneven exhaust note, sounds like a v6, with no codes, all plugs are clean, ill guess ill start swapping around coil packs.
 

[email protected]

Sergeant
Platinum Vendor
Jan 23, 2017
460
371
25
I don't know what your meth settings would have to do with your idle, unless you managed to purge in to the chargepipe somehow by mistake, and need to burn off methanol in the intake piping.
 

Snelson3003

Sergeant
Nov 7, 2016
325
199
0
Denver
www.nelsonracingwheel.com
Ride
2010 BMW 135i
See I knew Terry the man himself would chime in! :)

I'm for consistency sake, using the old FW for the time being. Will upgrade the FW once I get my car dialed in and my tuner says it's good to do.

To me it appears to be slower to come on that prior, but if Terry says otherwise im inclined to trust him as hes been the authority for some time now.

Thanks for the clarification Terry! :)