Whats that sound?

pysical

Sergeant
Jun 16, 2017
471
108
0
Ride
2009 335xi E90

Things I have tried:
Unplugging evap connector
Removing serpentine belt
probe all over with a stethoscope but can't really pinpoint it

The sound is weird as it comes and goes and it doesn't follow RPM. When I hit the pedal any amount the sound is gone. I recently put injector cleaner in the car and had afr issues. So I am wondering if while the car sat for a month with this stuff in it, if it possibly messed up injectors and they are making noise that echos throughout.
 

Slowagon54

Corporal
Aug 21, 2020
174
71
0
How does your logs look like? Stupid question, but did you check the oil level?

Dont think the cleaner can do any damage to the engine/injectors.
 

pysical

Sergeant
Jun 16, 2017
471
108
0
Ride
2009 335xi E90
How does your logs look like? Stupid question, but did you check the oil level?

Dont think the cleaner can do any damage to the engine/injectors.
Logs are fine, oil is fresh. The cleaner did cause AFR issues. Once I put new gas in the trims went closer together. Even [email protected] was amazed at it. It was Liqui Moly brand so I figured it would be good.

As far as the sound in the video, I was listening to older videos that I had of my car while listening to waste gate rattle back in the day. In between the revs I could hear the same noise. So this was 4 years ago, completely different motor from the block up. The only thing that is the same between then and now is the transmission, clutch, and flywheel. I thought I had already tried listening to it while having the clutch pedal pushed in but I forget stuff to easily so I will have to try it again and use a stethoscope down there.