Surging while cruising at 1900 RPM

pysical

Sergeant
Jun 16, 2017
352
76
0
Ride
2009 335xi E90
Car has developed a weird surge at certain RPMs in certain gears. The one I captured was 3rd gear at about 1900 RPM. I have had it happen in 4th and 2nd but it is at different gears. I hold the pedal as still as possible with my foot at 1900 rpm and it feels like I am moving forward and backward similar to how you would feel if you pushed on gas then let off, pushed on gas then let off, etc. I captured a log of it and trying to see if anyone has any ideas.

https://datazap.me/u/pysical/surge-2900-rpm?log=0&data=3-22

EDIT: 1900 RPM NOT 2900 RPM.
 

boostE92d

Corporal
Jan 9, 2018
147
86
0
Houston TX
Ride
12 335is
What's your maintenance history? Valve clean, plugs, boost solenoids, vacuum lines, etc. Bump for smarter people to answer, I'm intrigued.
 

N54QC

Corporal
Aug 17, 2017
127
67
0
Ride
07 E90 335i
I had the same problem last year and it went away after a few months and then it started happening just recently again. There was several discussions on n54tech including threads I started with logs about it and never got an defined answer other than it might be a hardware issue. Mine seems to happen with a steady throttle, whether with cruise control, holding a firm speed, or slight decel. If I push the pedal a little, it goes away. Bazaar issue that I've yet to see an answer to.
 

pysical

Sergeant
Jun 16, 2017
352
76
0
Ride
2009 335xi E90
What's your maintenance history? Valve clean, plugs, boost solenoids, vacuum lines, etc. Bump for smarter people to answer, I'm intrigued.

Valve job, plugs, boost solenoids, vacuum lines, etc are all fresh with less than 3k on them.
 

boostE92d

Corporal
Jan 9, 2018
147
86
0
Houston TX
Ride
12 335is
Have you tried changing the version or level of tune? Assuming you are MHD. I have heard of people having problems with some levels of some versions.
 

Arhoads335i

Private
Jul 14, 2017
40
15
0
Ride
335i
Upgraded BOV line? Mine does the same at 80 on the highway. Some people say a throttle reset works. Just got my car back today from the recall so I haven’t seen if it still does it
 

N54QC

Corporal
Aug 17, 2017
127
67
0
Ride
07 E90 335i
Upgraded BOV line? Mine does the same at 80 on the highway. Some people say a throttle reset works. Just got my car back today from the recall so I haven’t seen if it still does it
Resetting adaptation works for a little bit but the symptom comes back sooner or later in my experience. When I reset adaptations per MHD, the symptoms came back within a couple days. But when I reset with the BT tool, I can't remember how long before the issue came back. But it was sinficantly longer than using MHD, not sure the reason.
 

Brule

Corporal
Feb 20, 2017
240
218
0
Ride
335i 2007 6spd manual
I had it for 2 years with 2 sets of turbos.
I recoded the injectors and it was gone.
Numbers were out on coding.
 
  • Like
Reactions: doublespaces

pysical

Sergeant
Jun 16, 2017
352
76
0
Ride
2009 335xi E90
Upgraded BOV line? Mine does the same at 80 on the highway. Some people say a throttle reset works. Just got my car back today from the recall so I haven’t seen if it still does it

I have a upgraded BOV line. I can try a throttle reset.

Resetting adaptation works for a little bit but the symptom comes back sooner or later in my experience. When I reset adaptations per MHD, the symptoms came back within a couple days. But when I reset with the BT tool, I can't remember how long before the issue came back. But it was sinficantly longer than using MHD, not sure the reason.

This is the first time I have ever had it. Maybe it is just some sort of fluke. I will try reset adaptations and see how that goes.

I had it for 2 years with 2 sets of turbos.
I recoded the injectors and it was gone.
Numbers were out on coding.

Injectors are good unless they reset for some reason which I doubt they did. Could always take a look though.
 

chrisdfv

Corporal
Aug 29, 2017
267
213
0
Ride
E90 335i
I had this issue for the longest time. On jb4, and flash only. It only recently went away after I had to replace the throttle body. I don't think it was hardware related, but I did reset the throttle a ton of times while attempting to diagnose if I had a software issue or bad throttle body. I had previously tried to reset the throttle previous times to try to fix the surging with no luck.
I also did this procedure and not just resetting in the MHD app, when I replaced the throttle.

1. Insert key, foot off the brake, foot off the gas.
2. press start button.
3. Press on gas pedal all the way down for 30 seconds.
4. While foot on pedal at 30 second mark press start button, release gas.
5. Leave key in, wait a full 2 min to start, press brake hit start button and drive.
6. Instant power.

I'm not sure if the new hardware, or the reset fixed it but it's been a few weeks where I can finally cruise down the highway without the surging!
The reset is free so you can see if that works for you.
 

pysical

Sergeant
Jun 16, 2017
352
76
0
Ride
2009 335xi E90
Resetting adaptation works for a little bit but the symptom comes back sooner or later in my experience. When I reset adaptations per MHD, the symptoms came back within a couple days. But when I reset with the BT tool, I can't remember how long before the issue came back. But it was sinficantly longer than using MHD, not sure the reason.

I did this today and it fixed the issue. I am going to use this post as a reference to see how long it takes until it comes back. My car also set for about 1.5 months just a couple weeks before I started driving it again. Maybe that had something to do with it and maybe I never noticed it until recently. Anyways, thanks for the suggestion!
 
  • Like
Reactions: Ace718 and Xm-n54

Slowvert135i

Corporal
Oct 24, 2017
112
43
0
Shelton, ct
Ride
08 135i e88
I had the same issue when i was on jb4. Car surged like hell on the highway and would then throw hpfp codes. Come to find my jb4 board had caught fire inside of the case i removed it to have the dealer check the car and replace the hpfp but the car and pump were fine... Flashed mhd and had no issues since.
 
  • Funny
Reactions: veer90

13tx-IS

Lurker
Apr 17, 2017
19
13
0
Ride
2013 335IS
Dont reset throttle adapts using a cable. it will almost always caused the jumpy idle and immediate code.

Use accelerator pedal method.
 

N54QC

Corporal
Aug 17, 2017
127
67
0
Ride
07 E90 335i
Dont reset throttle adapts using a cable. it will almost always caused the jumpy idle and immediate code.

Use accelerator pedal method.
You usually have to wait a couple minutes or something to start the car after the adaptation reset with a cable, if not the throttle surges at idle.
 

doublespaces

Administrator
Oct 18, 2016
9,050
4,158
0
AZ
Ride
2009 E93 335i
You usually have to wait a couple minutes or something to start the car after the adaptation reset with a cable, if not the throttle surges at idle.

Yeah, when you key on the car it has to go through an adjustment or something. MHD shows text stating this when you do the reset.
 

13tx-IS

Lurker
Apr 17, 2017
19
13
0
Ride
2013 335IS
I have never seen it work with a cable (even when turned off for several mins) and always seen it work flawless by youtube vid. And that was even pre mhd - using a BAVtech cable.