Motiv Flex Fuel Installation Guide

fmorelli

Major General
Staff member
Aug 11, 2017
3,167
2,884
0
54
Virginia
www.morelliguitars.com
Ride
E89 Z4 35i, F10 535d
Not sure how it works on the e90 as the DME box is in a different place. We ran the lines in and out of the DME box on the Z4 just like the factory does through the rubber umbilical tubes. The grounds for the DME box go to a post on the firewall. We ran our ground through the umbilical tube to that location. if that's not a happy ground a lot of stuff is not going to be happy.

Filippo

IMG_20180629_151805.jpg
 

NoGuru

Lieutenant
Jan 9, 2018
907
371
0
Just North of Detroit
Ride
BMW 335is
I had some similar voltage and content fluctuations and I moved my ground to one of the shock tower nuts. I scraped away the paint on the body tho to endure a good connection. No issue since.
Just tried this and no change.

I might try and solder a 18ga wire to both places that jumper cables connect and wire that into the FF.
 

boosted.n54

New Member
Oct 28, 2019
2
0
0
Ride
2008 BMW 335xi
When’s the last time you guys replaced your negative ground terminal cable? I’m going to replace mine today with a new oem one and see if it makes any difference.
 

NoGuru

Lieutenant
Jan 9, 2018
907
371
0
Just North of Detroit
Ride
BMW 335is
When’s the last time you guys replaced your negative ground terminal cable? I’m going to replace mine today with a new oem one and see if it makes any difference.
Never. I don't consider that a maintenance item :) Although I could see it going bad over time, especially in hard weather. I would think if it was corroding enough, I would have other issues, and not just the FF system.

The only thing in my system that has not changed is the sensor. Anyone have a link to an authentic Continental sensor? The Amazon ones have a high probability to be counterfeits.
 
May 15, 2018
20
6
0
Ride
08 335xi E92
Never. I don't consider that a maintenance item :) Although I could see it going bad over time, especially in hard weather. I would think if it was corroding enough, I would have other issues, and not just the FF system.

The only thing in my system that has not changed is the sensor. Anyone have a link to an authentic Continental sensor? The Amazon ones have a high probability to be counterfeits.

The ethnol content sensor p/n is 13577379 You can order one on rockauto. I wouldn't trust amazon or eBay really either lots of counterfeits.
 
  • Like
Reactions: NoGuru
May 15, 2018
20
6
0
Ride
08 335xi E92
I have some good news fellas, yesterday I replaced the wire harness going to the the flex fuel module and also replaced the negative ground terminal cable on the car tool. Couple days ago I replaced only the motive flex fuel module box only, but it still didn't fix the voltage/ethanol content spiking issue on wide open throttle. I did not change my ground location at all either. I strongly believe that changing the flex fuel module, installing a new wire harness and checking over your work very carefully following directions step by step, making sure the correct colored wires are going where they need to be according to the pictures posted earlier on this thread.
 
  • Like
Reactions: Jeffman and NoGuru

JOEinSD

Private
Mar 31, 2017
40
16
0
Ride
N54 335i
I reached out to Motiv and they agreed to send a new FF module and harness to me to try out. Unfortunately the new hardware never made it onto the car. We got rear-ended 2 days before the hardware arrived and the car is likely totaled. 😔 Good luck to you guys trying to get this figured out.
 
  • Wow
Reactions: doublespaces

NoGuru

Lieutenant
Jan 9, 2018
907
371
0
Just North of Detroit
Ride
BMW 335is
I reached out to Motiv and they agreed to send a new FF module and harness to me to try out. Unfortunately the new hardware never made it onto the car. We got rear-ended 2 days before the hardware arrived and the car is likely totaled. 😔 Good luck to you guys trying to get this figured out.
That sucks!

I replaced the Continental FF sensor just to rule that out and no change.
 

doublespaces

General of the Army
Oct 18, 2016
8,939
4,144
0
AZ
Ride
2009 E93 335i
I think the question I have: What makes that ground dirty and how does it get fixed?
 

Milan

Sergeant
Dec 24, 2016
389
219
0
jebi se
Ride
your mom
For anyone self tuning out there, how are we supposed to target load once switching to the flex fuel bin/xdf? Am I supposed to make use of the by gear functionality?

Edit: Yes
 
Last edited:

Prolifik123

Lurker
Nov 6, 2020
16
1
0
I ordered the motiv flex module with short line kit recently. After installing it today I have the exact same problem as @NoGuru.....

-I have green in 16 small black connector
-orange in 25 large black connector
-Yellow in 10 piggy backed into oem yellow.
-Red wire to the orange 12v source on green connector
Grounded multiple different sources.

My car has the same codes and idles exactly the same as in the video link below.

After removing the green (16) and orange (25) the codes stay away and car runs normally......

E A voltage is 4.5v
Car has 0% ethanol in tank which is correct.


I have purchased flex fuel pack, ethanol map pack and flashes stage 2+ 98 OTS map.


Any help?Screenshot_20201106-195850.jpg
 
Last edited:

Cruizinmax

Specialist
Jul 18, 2018
82
49
0
Ride
09 335i
I ordered the motiv flex module with short line kit recently. After installing it today I have the exact same problem as @NoGuru.....

-I have green in 16 small black connector
-orange in 25 large black connector
-Yellow in 10 piggy backed into oem yellow.
-Red wire to the orange 12v source on green connector
Grounded multiple different sources.

My car has the same codes and idles exactly the same as in the video link below.

After removing the green (16) and orange (25) the codes stay away and car runs normally......

E A voltage is 4.5v
Car has 0% ethanol in tank which is correct.


I have purchased flex fuel pack, ethanol map pack and flashes stage 2+ 98 OTS map.


Any help?View attachment 45924
Did you select the flex fuel option in the flash options? Unless something has changed your last flashed file should say "FF" at the end of it.
 

Prolifik123

Lurker
Nov 6, 2020
16
1
0
Did you select the flex fuel option in the flash options? Unless something has changed your last flashed file should say "FF" at the end of it.
Yes i did try that also, ( the picture of the codes was when i attempted to try flashing to stock and back to stage2+)
When the green and orange wires are disconected from the DME the car works as normal.




My FlexFuel issue was never resolved but the issue with the surging idle was a bad throttle body. Replaced it and the surging stopped.
when i disconnect the green and orange wires from the motiv box this "surging"stops and the car behaves normal