Misfire problem, Bank one Fuel trim

MOSFETS Forever

New Member
May 27, 2018
7
3
0
Ride
N54 335xi
Fellow N54 friends, I would like input and ideas. I'm new to the form and this problem is driving me insane. My car is currently experiencing a mixture control problem on bank 1 ONLY. Under boost stft will go to -32%, even under light acceleration. It is also Throwing corresponding misfire codes for bank one.

Here is what is done to my car:

MSD80, 335xi
Custom Motiv Flex fuel tune from [email protected]
VRSF factory side inlets
AEM LPFP pushing 75 + psi
Duel cone intake
ECS tuning charge pipe and BOV
ECS tuning Oil catch can
Pushing 22 psi under optimal conditions, E60 ish
95k miles
stock turbos
stock Down pipes
Stock inter-cooler
Stock everything else


Here is what I have done:

Changed injectors and replaced seals on injectors with proper tools
Checked injectors for leaks
New NGK spark plugs (I tried .022 and .018 gap)
New Delphi ignition coils
Replaced all Mosfets
Cleaned and inspected intake manifold
Plugged fuel tank vent port on TB
New intake and TB gaskets
Plugged intake ports in valve cover.
New valve cover gasket
Cleaned map sensor
Replaced both upstream oxygen sensors.
Compression check, 180 psi +- 5psi on all cylinders

When the problem started, It was like a switch was flipped and then it ran like crap since.
I have attached data logs using mhd covering this problem for those willing to review them. I've communicated with Chris [email protected] about this, but hes a busy guy.
I'm running out of ideas. I'm going to pull the turbo inlet on bank one and check the turbine, but I have no smoke or water coming out the exhaust.
The car idles fine, but almost makes a sound like it has a huge vacuum leak under any driving condition. Thoughtful input is appreciated
 

Attachments

  • 2018-05-25 16_21_28 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    80.8 KB · Views: 222
  • 2018-05-25 16_17_26 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    92.8 KB · Views: 194
  • 2018-05-25 16_07_53 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    58.1 KB · Views: 192
  • 2018-05-25 16_04_51 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    15.2 KB · Views: 187
  • 2018-05-08 14_13_16 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    29.1 KB · Views: 180
  • 2018-05-01 17_39_50 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    33.5 KB · Views: 199
  • 2018-04-29 16_19_56 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    15.1 KB · Views: 189
  • 2018-04-29 16_19_22 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    5 KB · Views: 178
  • 2018-04-29 16_19_32 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    8.9 KB · Views: 167
  • 2018-04-29 16_18_50 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    9.6 KB · Views: 203
  • 2018-04-29 16_17_23 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    7.2 KB · Views: 186
  • 2018-04-29 16_04_16 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    154.5 KB · Views: 216
  • 2018-04-29 15_44_01 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    16.1 KB · Views: 203
  • 2018-04-27 19_55_16 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    10.6 KB · Views: 172
  • 2018-04-27 19_49_33 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    69.7 KB · Views: 179
  • 2018-04-22 12_56_36 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    17.3 KB · Views: 181
  • 2018-04-22 12_51_35 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    76.1 KB · Views: 159
  • 2018-04-22 12_52_59 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    129 KB · Views: 202
  • 2018-04-22 12_47_10 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    233.2 KB · Views: 212
  • 2018-04-21 07_01_17 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    38.3 KB · Views: 212
  • 2018-04-21 06_57_51 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    230.8 KB · Views: 203
  • 2018-04-21 06_54_39 I8A0S V2.00_Motiv_FlexFuel_Ross_OEM_FBO.bin.csv
    118.9 KB · Views: 194

blisstik

Corporal
Mar 27, 2018
152
64
0
Ride
E92 MOTIV750 (Sold)
Swap injectors 1/2/3 with 4/5/6. You'll have to recode them but you can see if the trims switch to bank 2
 

MOSFETS Forever

New Member
May 27, 2018
7
3
0
Ride
N54 335xi
Swap injectors 1/2/3 with 4/5/6. You'll have to recode them but you can see if the trims switch to bank 2
I have already done this. I moved bank 1 to bank 2, replaced the entire set, and then moved that set around as well. I also installed new injector seals and decouplers. Injectors were coded with INPA. The problem appears to remain on bank one only.
 

blisstik

Corporal
Mar 27, 2018
152
64
0
Ride
E92 MOTIV750 (Sold)
I'm sure you tried swapping your plugs and coils too. Maybe check the fuel rail for cracks? Also, I would load all your logs to Datazap and link them here. It'll be easier for us to look into them.

Have you tried going back to previous version tune? Turned off burble and all that.
 

dyezak

Major
May 4, 2017
1,768
1,515
0
Plano TX
Ride
335is
Motiv is one of the best tuners available.

But this is a case study in factoring in your tuner's availability and responsiveness. The best tuner in the world does you no good if they never look at your car.

Not a knock on Motiv...they have limited availability for a reason.
 

MOSFETS Forever

New Member
May 27, 2018
7
3
0
Ride
N54 335xi
Rail pressure is fine. Reads anywhere from 700 psi to 3200 psi. I have not smelled any fuel or seen any leaks.
Spark plugs and ignition coils are all brand new, they don't even have 20 miles on then. Sourced them from FCP Euro. No misfire is noticeably present at idle.

Here are some logs on Datazap.

https://datazap.me/u/mosfets-forever/log-1527515068?log=0&data=3-25

https://datazap.me/u/mosfets-forever/log-1527514967?log=0&data=3-25

https://datazap.me/u/mosfets-forever/log-1527514914?log=0&data=3-25
 

Cornfed54

Specialist
Feb 6, 2018
80
31
0
Ride
E92 335
Total shot in the dark, but have you tried filling up with 93 and flashing back to original stock .bin to rule out anything wierd with flex fuel? Otherwise, I’d say significant boost/ vac leak but it seems like you have looked over everything thoroughly to rule that out. Any chance that one or more of the intake mani gaskets are blown/ missing? I’ve seen them cause your same symptoms, hope you get this figured out soon, problems like these can drive a guy nuts.
 

MOSFETS Forever

New Member
May 27, 2018
7
3
0
Ride
N54 335xi
Total shot in the dark, but have you tried filling up with 93 and flashing back to original stock .bin to rule out anything wierd with flex fuel? Otherwise, I’d say significant boost/ vac leak but it seems like you have looked over everything thoroughly to rule that out. Any chance that one or more of the intake mani gaskets are blown/ missing? I’ve seen them cause your same symptoms, hope you get this figured out soon, problems like these can drive a guy nuts.
I'm starting to lean towards a boost leak problem. I pulled the fan out to check the forward turbo (which checked out fine, it almost seemed new) and noticed that the charge pipe going into the intercooler was partially dislodged. I pulled the hose out and didn't see an o-ring to seal the pipe, so I'm going to see if I can find it and match the size for one local, or else I'll order a new one. Probably going to remove the factory intercooler and inspect and clean it. I'll post with updates.
 

Cornfed54

Specialist
Feb 6, 2018
80
31
0
Ride
E92 335
That would be great if that’s it, fingers crossed. The only thing that seems odd is that typically both banks would be thrown way off since it’s a full system leak, not at the intake Mani where one or more cyl in a bank could have a leak, causing one bank to be thrown off. Do your trims seem to be business as usual on the other bank? Do you have any old logs to compare by chance? Sorry if you posted them already and I didn’t catch it.
 

MOSFETS Forever

New Member
May 27, 2018
7
3
0
Ride
N54 335xi
So here's an update for those following.

In chasing down a potential boost leak, I removed the intercooler and cleaned the seals and the intercooler itself. I then smoke tested the entire intake system only to find no leak at all.

My thoughts then turned to a possible problem with the MSD 80 computer. They are known to have several weaknesses, I had already replaced the MOSFETS twice. So I got help from Motiv and upgraded to MSD 81 only to have the exact same fault. At this point I was completely stumped. I talked with the guys at Motiv some more and decided that it had to either be a bad turbo or a bad catalytic converter.

Today I dropped the subframe and removed the down pipes. Both of the stock turbos looked clean as a whistle. No signs of wearing out, oil leaks or water leaks. And both turbine shafts feel solid and the waste gates are good as well. Then my inspection turned to the cats... oh those damn cats...

Remember that the fault was a bank one mixture control issue only. Well the cat for bank one no longer exists. The element is literally gone. Not a single trace of it remains. I suspect that the secondary catalytic converter looks like a sand box. I'll have to wait until this weekend to find that out. The bank two cat is still in tact but it is showing signs of wear as well. I just placed an order for the VRSF xi down pipes. I'm just ready to have my car back.

I have never seen a catalytic converter fail like this before. I'll let the picture do the talking.
2013-09-14_17-57-06_193.jpg

Flashlight shining from the other side.

36273257_1995358437150127_4704450749310959616_n.jpg

Just an empty can.

36273442_1995358817150089_1783916972791037952_n.jpg

36274042_1995358387150132_1593644814862123008_n.jpg

camera shot with no flash, and a light from the other end.
36277468_1995358810483423_1835675000904876032_n.jpg


36325848_1995358550483449_6967495843939090432_n.jpg


36384633_1995358873816750_5034769374011981824_n.jpg
 
Last edited:
  • Funny
Reactions: doublespaces

SlowE93

Lieutenant
Jul 2, 2017
726
271
0
Ride
E93
Ok this begs the question - why did you not get post-cat ODB-II codes? This car should have thrown codes like a Christmas tree.

Filippo
Im going to guess here....custom tune and lambda codes shut down due to MANY people running catless dps to avoid CEL.

Thoughts ?
 

MOSFETS Forever

New Member
May 27, 2018
7
3
0
Ride
N54 335xi
Ok this begs the question - why did you not get post-cat ODB-II codes? This car should have thrown codes like a Christmas tree.

Filippo
That is a fantastic question. I would also think that I would get a catalyst inefficiency code for bank 1. But I am running the Flex Fuel system from Motiv, and I have a custom tune for the system from Motiv as well. I would guess that they coded out some emissions controls as part of the tune. But no matter, as I have new DP's coming and I ordered the O2 simulators to go with it.

I really just want to remove the secondary catalysts and see how much of the primary is left in there. I'll probably just bypass them for now, but down the road I would like to have some form of high flow cat on the system just to control the un-burnt fuel smell that will come with removing the cats.

I'll post pictures and update when I take the secondaries off.
 
  • Informative
Reactions: doublespaces

fmorelli

Major General
Staff member
Aug 11, 2017
3,274
3,020
0
54
Virginia
www.morelliguitars.com
Ride
E89 Z4 35i, F10 535d
That merits a quick email to Chris - I'd want to know if something was coded out as you say.

BTW I'm pleased with my setup - I have the VRSF catless downpipes. I then built my exhaust with hi-flow 49-state CARB cats in the mid-pipe, extended my post-cat 02 sensor loom with Deutsche connectors, and have a Vibrant 02 J bung for the 02 sensors at the mid-pipe. Nothing is coded out on my car, and it runs clean. The mid-pipe cats help tame the exhaust sound as well. By the way the mid pipe cats are not particularly expensive.

Good luck. Hope this solves your issue ...

Filippo
 
  • Informative
Reactions: Optigrab

MOSFETS Forever

New Member
May 27, 2018
7
3
0
Ride
N54 335xi
Had a chance to cut the secondary catalytic converters off this morning. And as expected I found the bank one primary converter sitting in the secondary converter.

This is your catalytic converter. . .

36411837_1997882920231012_543334159175647232_n.jpg


This is your catalytic converter on drugs.

36340446_1997883173564320_6925083226574684160_n.jpg



36340462_1998005123552125_268288589593313280_n.jpg



36434357_1998004196885551_8690360079955787776_n.jpg



36333491_1998002376885733_5599450096174366720_n.jpg
 
  • Informative
Reactions: doublespaces

fmorelli

Major General
Staff member
Aug 11, 2017
3,274
3,020
0
54
Virginia
www.morelliguitars.com
Ride
E89 Z4 35i, F10 535d
I doubt that's a problem. :tonguewink:

Your issue was not the hole in the first cat but rather the plug up in the second cat. Wow, wonder how common this is?

Filippo
 

doublespaces

Administrator
Oct 18, 2016
8,958
4,157
0
AZ
Ride
2009 E93 335i
This is actually pretty interesting. Did you run 2 step at all? Maybe you had some major backfires that caused this.