F3X Yet another PCV chirp thread, pls help

J4CK_335i

New Member
Oct 5, 2022
4
0
0
Hey SpoolStreet,

I have a 2012 F30 335i, I purchased it with a jb4 and an upgraded aluminum? chargepipe. However, I cannot find a name on the pipe anywhere hence the question mark. I have been having issues with my crank/pcv system for the past while. I did purchase a car-shield third party warranty contract around the time I got the car. I have taken the car to two different places so far. The first of which was a reputable indy near me who suggested a smoke test and for me to take the car to a tuner, or "speed-shop". After doing my research, I chose APM tuned over in Villa Park, IL with the preface of PCV issues. So far, we have removed the jb4 which I was told was causing the 28A0 code. I opted to switch over to a custom tune from them, and since then I have been code-free. I received the car back after the new tune, and I was still having PCV issues and rough idles at stoplights/most starts. I took the car back, and we replaced the valve-cover through my warranty. It was a difficult and time consuming process but we got it done nonetheless. The chirp and rough crank have returned, and the car seems to be running lean on most starts. I have not driven it other than to replicate the noise. The chirp/squeal seems to be much quieter, however still present. I am also a little concerned about the loud beep and "clock ticking" noise you can hear at the beginning of the second clip in this video. I have scoured every forum, thread (including the one with 39 pages and ending with both crank seal replacements), reddit post, service bulletin, and youtube video related to this problem and I am at my wallet and wits end with this issue. I would need my friend's tablet to provide logs.

Crank Seal Chrip?

Symptoms:
Chirp
Rough crank/Engine shaking side to side for 3 seconds or so
28A0: Throttle valve opening angle absolute pressure intake pipe comparison pressure too high
Jerky/sensitive throttle response
Running lean on start ups

Parts removed/installed:
Jb4
OEM coils and plugs (bosch) (delphi)
Valvecover (Warranty purchased this and shipped it to APM, authenticity of it being OEM is unknown.)
I believe the eccentric shaft sensor has a lifetime warranty.


Please help!! :cry::cry::cry:
 
Last edited:

doublespaces

Administrator
Oct 18, 2016
9,272
4,282
0
AZ
Ride
2009 E93 335i
Hey SpoolStreet,

I have a 2012 F30 335i, I purchased it with a jb4 and an upgraded aluminum? chargepipe. However, I cannot find a name on the pipe anywhere hence the question mark. I have been having issues with my crank/pcv system for the past while. I did purchase a car-shield third party warranty contract around the time I got the car. I have taken the car to two different places so far. The first of which was a reputable indy near me who suggested a smoke test and for me to take the car to a tuner, or "speed-shop". After doing my research, I chose APM tuned over in Villa Park, IL with the preface of PCV issues. So far, we have removed the jb4 which I was told was causing the 28A0 code. I opted to switch over to a custom tune from them, and since then I have been code-free. I received the car back after the new tune, and I was still having PCV issues and rough idles at stoplights/most starts. I took the car back, and we replaced the valve-cover through my warranty. It was a difficult and time consuming process but we got it done nonetheless. The chirp and rough crank have returned, and the car seems to be running lean on most starts. I have not driven it other than to replicate the noise. The chirp/squeal seems to be much quieter, however still present. I am also a little concerned about the loud beep and "clock ticking" noise you can hear at the beginning of the second clip in this video. I have scoured every forum, thread (including the one with 39 pages and ending with both crank seal replacements), reddit post, service bulletin, and youtube video related to this problem and I am at my wallet and wits end with this issue. I would need my friend's tablet to provide logs.

Crank Seal Chrip?

Symptoms:
Chirp
Rough crank/Engine shaking side to side for 3 seconds or so
28A0: Throttle valve opening angle absolute pressure intake pipe comparison pressure too high
Jerky/sensitive throttle response
Running lean on start ups

Parts removed/installed:
Jb4
OEM coils and plugs (bosch) (delphi)
Valvecover (Warranty purchased this and shipped it to APM, authenticity of it being OEM is unknown.)
I believe the eccentric shaft sensor has a lifetime warranty.


Please help!! :cry::cry::cry:
Have you tried to replace the throttle body? Maybe there is a way you can test it.

On the N54 I believe there is a pcv and fuel evap line connected to it, so if you've got something wonky with your throttle body or the pcv related valves in that area, could be a place to start.

Sorry I can't help much with the N55.

Getting a log would probably be a place to start. You can upload it to this site in the Datalogs section.
 

J4CK_335i

New Member
Oct 5, 2022
4
0
0
You may be onto something, as I believe the loud beep and clunk at the start of the second clip is the throttle body. I will try the pedal reset tomorrow and see if it works for me. I have sent my tuner the videos just waiting to hear back. Been chasing this cold start shudder fix for a while :neutral:
 

J4CK_335i

New Member
Oct 5, 2022
4
0
0
Update ):
CA577D22-0267-4D71-9E0A-CB4FE9427AEE.jpg

along with;
135B11: Valvetronic servomotor activation, volt phase: line disconnection
135808: Valvetronic servomotor position sensors: short circuit or line disconnection
120308: Charging pressure control, plausibility pressure too low
480134 ICM: direction of travel cannot be determined


I would appreciate any help in this situation, going to be replacing valvetronic motor.

I've brought the car to APM twice, both times they've told me it's "running great" with "no codes". Didn't believe me when I said my PCV was leaking, either. Granted working with 3rd party warranty isn't easy. I shouldn't be getting straight up lied to. They even said my car should be fine to drive (which I have not been doing) before I sent the codes (bc of squeal from seals).

Should I take my car somewhere else? They recommended new stock plugs on their tune, I'm not sure if they're gapped at all. Really concerned at this point.