When the chinese K+Dcan cable beats my BG Pro cable...

KClemente

Corporal
Nov 26, 2019
124
69
0
Ride
E90 335i
I really don't want to post this because its such a dumb issue with many hours wasted but essentially, my BG Pro cable does not connect to any cars operating on the DCan line. My personal car, 07 335i has pin 7 (K-line) in the OBD port occupied (pins 6+14 empty). Any other 08+ car with pins 6+14 occupied does not play nice with EDIABAS causing INPA not to find any signal.

My chinese cable that I bought 5+ years ago has been working without any fault whatsoever. And yes, I reinstalled the FTDI drivers and changed com ports/latency. I'm not computer illiterate by any means and I have quadruple checked every single possibility including the .ini files.

Has anyone else had an issue with BimmerGeek's Pro cable before? I know each cable has their proprietary custom firmware in what I presume is handwritten.

Edit: i tested out the button (not left/right switch like all the pictures of this cable) on my BG cable and it indeed fuse pins 7+8 together when tested via continuity. Button toggled or not toggled doesn't affect connectivity on any cars I tried the cable on
 

lvudric

New Member
Feb 5, 2021
1
0
0
I really don't want to post this because its such a dumb issue with many hours wasted but essentially, my BG Pro cable does not connect to any cars operating on the DCan line. My personal car, 07 335i has pin 7 (K-line) in the OBD port occupied (pins 6+14 empty). Any other 08+ car with pins 6+14 occupied does not play nice with EDIABAS causing INPA not to find any signal.

My chinese cable that I bought 5+ years ago has been working without any fault whatsoever. And yes, I reinstalled the FTDI drivers and changed com ports/latency. I'm not computer illiterate by any means and I have quadruple checked every single possibility including the .ini files.

Has anyone else had an issue with BimmerGeek's Pro cable before? I know each cable has their proprietary custom firmware in what I presume is handwritten.

Edit: i tested out the button (not left/right switch like all the pictures of this cable) on my BG cable and it indeed fuse pins 7+8 together when tested via continuity. Button toggled or not toggled doesn't affect connectivity on any cars I tried the cable on
Same thing. Suddenly Bimmergeeks pro cable cannot connect, but my old cheap chinese cable does connect. I am IT admin at work, so, I tried everything, include complete reinstall my laptop, and BK pro cable don't connect anymore. Possible hardware failure of BK pro cable?
 

KClemente

Corporal
Nov 26, 2019
124
69
0
Ride
E90 335i
Same thing. Suddenly Bimmergeeks pro cable cannot connect, but my old cheap chinese cable does connect. I am IT admin at work, so, I tried everything, include complete reinstall my laptop, and BK pro cable don't connect anymore. Possible hardware failure of BK pro cable?
It's gotta be. My second BG cable now shows a red light when connecting to the obd port and doesn't work anymore. Shame because I need it for S65 MSS60 flashing
 

NoGuru

Lieutenant
Jan 9, 2018
973
409
0
Just North of Detroit
Ride
BMW 335is
Mine failed a few years ago and I contacted them. He remoted in and tested some settings and deemed the cable as bad and sent me a replacement.
 

NoQuarter

Major
Nov 24, 2017
1,605
1,003
0
Indiana, USA
Ride
Z4 35is, 535xi, X5 35i
I used mine a few
months ago and had a terrible time with it.

I have mine marked on the switch which of my cars to use with the switch setting.

In the middle of the unexpected troubleshooting, the dude helping me said to put the switch in the middle like it was always supposed to be there even though I never used it that way prior.

Started working immediately .