MHD flash in BMW X6 e71 N55 engine

Mamugabe

New Member
Jul 5, 2023
7
4
0
Issue for gurus.
I have an X6 e71 with N55 engine.
I am trying to do the flashing and keeps cutting the flash with a "Flashing Stopped" message.
I am using the Bimmer geeks K-Dcan cable, the black pro one.
I talked with MHD and keep saying is an issue with charger, that is not a comunication issue. I tell them i am using a proffesional charger and they keep insisting.
Any advice about this issue?
Thanks in advance.

Charger.jpg
Preparing DME.jpg
Flash stopped.jpg
 

wheela

Lieutenant
Jun 4, 2021
1,127
633
0
Twin Cities, MN
Ride
2015 e84 X1 35i Msport
I'm not too familiar with that charger - I see both 12 volt and 13.8 volt listed on the screen. Do you know which one it's outputting to the car? The power supply I use is much less advanced, but I use the 13.8 volt setting during a long flash (constant voltage). If you're outputting 12 volt, you could try again using 13.8 volt setting - these things are super finicky with voltage.

Also, if it's auto-adjusting voltage to charge a battery (like a battery charger vs. power supply), I don't think you want that. You should have a power supply that outputs a constant voltage level.
 

Attachments

  • Screenshot_20230706_084412_Gallery.jpg
    Screenshot_20230706_084412_Gallery.jpg
    436.6 KB · Views: 4

Mamugabe

New Member
Jul 5, 2023
7
4
0
I'm not too familiar with that charger - I see both 12 volt and 13.8 volt listed on the screen. Do you know which one it's outputting to the car? The power supply I use is much less advanced, but I use the 13.8 volt setting during a long flash (constant voltage). If you're outputting 12 volt, you could try again using 13.8 volt setting - these things are super finicky with voltage.

Also, if it's auto-adjusting voltage to charge a battery (like a battery charger vs. power supply), I don't think you want that. You should have a power supply that outputs a constant voltage level.
Hi Wheela.
The charger iis set in Diagnose mode, it gives constant 13.8v and vary the amps depending on what the car is doing and needing.
I am going to try it in charge mode as you say and lets see how it works.
Thanks for your advise.
 

wheela

Lieutenant
Jun 4, 2021
1,127
633
0
Twin Cities, MN
Ride
2015 e84 X1 35i Msport
Oh, if it's outputting constant 13.8 volt and varying amps accordingly that is the setting you want.
 

Mamugabe

New Member
Jul 5, 2023
7
4
0
Oh, if it's outputting constant 13.8 volt and varying amps accordingly that is the setting you want.
Yes, is the diag mode. Is used for operating modules in the car without energy lows and bad surprises.
That is why i dont know why is stopping the flash.
Anyway, i am going to try in charge mode.