Stutter under load N54

Eurofam

Private
Oct 4, 2020
33
3
0
Hey guys just started having an issue again where under light load (cruising under 2500rpm) the car stutters like a misfire but never gets a cel. Past day it’s gotten worse and stutters under heavy load but still doesn’t throw any codes.
I think it may be my hpfp but not 100% sure I have watched the rail pressure drop sub 5-400 but normally sits around 670-720 I’m not sure if that is Indication it’s going bad or if there’s something else going on.
You may notice the low pressure fuel sensor is not reading because i plugged it in backwards and have not had time to pull the intake manifold again, I just replaced injector #1 and had them all resealed and coded, again I have zero codes but I do have logs and need some other opinions as to what the problem may be or what to look for, any help is greatly
appreciatedhttps://datazap.me/u/eurofam/log-1620020020?log=0&data=3-21
 

Silent11

Specialist
Oct 31, 2018
87
27
0
Ride
2007 Bmw 335i
Hey guys just started having an issue again where under light load (cruising under 2500rpm) the car stutters like a misfire but never gets a cel. Past day it’s gotten worse and stutters under heavy load but still doesn’t throw any codes.
I think it may be my hpfp but not 100% sure I have watched the rail pressure drop sub 5-400 but normally sits around 670-720 I’m not sure if that is Indication it’s going bad or if there’s something else going on.
You may notice the low pressure fuel sensor is not reading because i plugged it in backwards and have not had time to pull the intake manifold again, I just replaced injector #1 and had them all resealed and coded, again I have zero codes but I do have logs and need some other opinions as to what the problem may be or what to look for, any help is greatly
appreciatedhttps://datazap.me/u/eurofam/log-1620020020?log=0&data=3-21
i had a similar issue, under 4000 rpm it was stuttering and hesitating and i've never gotten a ch engine.

Did a walnut blast and at the same time installed my spare throttle body and the car is super smooth !

It had a ton of carbon deposit but im leaning that the throttle body was the fix.

Not 100% sure which one did the trick.