SOLVED Post msd81 conversion codes

RuskiRacer

Sergeant
Jul 17, 2019
430
158
0
Ride
2009 e93 335i
The battery code i know why because I had to jump the battery. I previously had auto trans communication codes from my manual swap got my msd81 coded got rid of one issue and got myself into new problems. Theses o2 sensors worked good on my other car with the msd81, has new index 12s the dme coder asked me for the numbers so I'm sure he registered them. 95706 ngks gapped to .20 , eldor coilpacks.
 

Attachments

  • Screenshot_20201208-163455.jpg
    Screenshot_20201208-163455.jpg
    149.1 KB · Views: 17

RuskiRacer

Sergeant
Jul 17, 2019
430
158
0
Ride
2009 e93 335i
Will do that and I'm gonna take my intake manifold off again and double check all the connections and wiring because the car ran great before the manual swap and putting the single turbo on and new valve cover
 

RuskiRacer

Sergeant
Jul 17, 2019
430
158
0
Ride
2009 e93 335i
Screenshot_20201210-165352.jpg
Screenshot_20201210-164210.jpg
20201210_155713.jpg
OK I got rid of all my dme codes and I still am having a really rough idle and cannot rev it without it wanting to die. I got my msd81 from my old car programmed for this car and it doesn't show it but my spare key that I got coded works. I had o2 sensor codes put different sensors in and solved that along with cps but still have the rough idle and wanting to die. Any help would be appreciated.
 

Reformatt

Private
Oct 28, 2019
26
13
0
50
Houston
Ride
2010 335i E92
I just finished doing a manual swap last week with some other additions. I am embarrassed to say my car sounded the same, I am going with the excuse I was brain dead tired...I had my vanos connectors flipped it ran like poooo to say the least. Double check your connections. After I don’t know how many engine swaps an harness installs it can happen even if you think you know these cars forward an back. Good luck hope you get it sorted.
 

RuskiRacer

Sergeant
Jul 17, 2019
430
158
0
Ride
2009 e93 335i
Thats something i didn't think of but could very well be the same in my case because I did have the motor out of the car. I also was told by my tuner that I have the msd80 timing settings for the jb4 on so I need to switch that i guess ill try both.
 

RuskiRacer

Sergeant
Jul 17, 2019
430
158
0
Ride
2009 e93 335i
Switched the timing settings from msd80 to msd81 on the jb4 user settings and the car runs worse and won't even stay running anymore. Lovely