PID is Adding WGDC While Overboosting

impuls

Specialist
Jan 28, 2018
92
60
0
Ride
'07 335i
Actually my boost control works very well in 3rd and 4th gear, but in 5th (and 6th) WGDC is being added although boost is over target.
Unfortunately didn't log the boost error parameters, but should P and D error be close to zero and WGDC After PID = WGDC Base?

 

impuls

Specialist
Jan 28, 2018
92
60
0
Ride
'07 335i
Ups... I see the same in 3rd and 4th with my latest tune revsion... seems I messed something up...
 

impuls

Specialist
Jan 28, 2018
92
60
0
Ride
'07 335i
All that changed since last revision is the first cell of the WGDC Adder where I replaced 0.32 with 0 by accident.
I also lowered the WGDC Based in some cells as previous revision hat minor throttle closures .

I wonder if there are some long term adaptions causing this mess.
The log I took before driving on the autobahn for 2-3 hours I was able to create a log that looks quite OK.



1596051935295.png


1596052029949.png


 

GreyNBlueE92

Corporal
Oct 3, 2018
215
68
0
24
OH
Ride
2007 E92 335i
In my experience I had better results zeroing out the adder tables and tweaking wgdc base. I believe the car has more control this way because it references boost setpoint and maf, versus just maf in the adder tables.
 

impuls

Specialist
Jan 28, 2018
92
60
0
Ride
'07 335i
In my experience I had better results zeroing out the adder tables and tweaking wgdc base. I believe the car has more control this way because it references boost setpoint and maf, versus just maf in the adder tables.

Actually I am quite happy with my WGDC Base values. Just not happy about the fact that PID is adding WGDC
although P and D error indicates it should be removed.
 
  • Like
Reactions: GreyNBlueE92

impuls

Specialist
Jan 28, 2018
92
60
0
Ride
'07 335i
I reverted back to the previois tune revision that used to run quite well few days ago and still have the same problem.

Only differences I can think of now are that it's several degrees warmer now than it was few days ago and that I was driving fast on the autobahn for couple of hours.

Looking at the logs only difference I see is:
WGDC PID is above WGDC Base now although PID should be pulling WGDC and overboost obvioisly.

Maybe WGDC (ETC) is causing this?
Does it add to the base or to WGDC PID?

Whatever is adding a few degrees of WGDC, guess I will have to adjust p factors to pull enough WGDC to compensate.
Whqts actually the formula to predich added WGDC based on p-factor?

In INPA I also saw an adaption related to boost control maxed, but I am not sure if that if that is xausing problems.

Current log:
 

impuls

Specialist
Jan 28, 2018
92
60
0
Ride
'07 335i
Few days ago, same tune:
 

GreyNBlueE92

Corporal
Oct 3, 2018
215
68
0
24
OH
Ride
2007 E92 335i
In my tune I used z4 35is pid tables, pretty sure that solved it for me. Just be sure to change the xdf if you look values up on a different rom.

I do remember having a similar problem some time ago. Hope that helps
 

P33P33

Private
Apr 3, 2017
48
11
0
Ride
BMW 335i n54 e93
I have recently encountered the same problem but it happened after changing to new hybrid turbos. I'm on i8a0s. My friend has the same turbos and I have made the basically the same tune and he doesn't have the same issue. He's on ije0s.

I have made these notes to wgdc diagram but I had limited information so my notes may not be 100% accurate but maybe it can shed some light for you guys to see what controls wgdc.
 

Attachments

  • WGDC control diagram(1).pdf
    845.4 KB · Views: 66

impuls

Specialist
Jan 28, 2018
92
60
0
Ride
'07 335i
Thanks @P33P33 there is a lot to be learnt from that document:
  1. I am stupid, most of the document is a mystery to me (and I don't have any trouble reading the German text...)
  2. Input for the WGDC Adder (Airflow) is MAF Request and not MAF Request (WGDC), saved me one tune revision to figure that out.
  3. Correction based on WGDC P-Factor is calculated as percentage of WGDC Base with a correction factor (probably the one in the screenshot below?)
    Seems when overboosting the calculation is based on 100% - corrected WGDC Base (WTF? Why?)

In the document you ask what KL_FATLRD_N is, pretty sure it is WGDC D-Factor Multiplier.


1596226068611.png
 

impuls

Specialist
Jan 28, 2018
92
60
0
Ride
'07 335i
Seems when overboosting the calculation is based on 100% - corrected WGDC Base (WTF? Why?)
It does make sense...

Difference to 100% is used when underboosting, P-Factor = 1 should push WGDC to 100%.
When overboosting P-Factor = -1 will pull WGDC to 0%
 

impuls

Specialist
Jan 28, 2018
92
60
0
Ride
'07 335i
@P33P33 do you have some documentation how F_atlad is calculated and where WGDC Correction (ETC) is used? I suspect that is what is pushing my WGDC After PID up.

I also wonder how WGDC Bank x is calculated from WGDC After PID... do you have something about that in your magic document?
 

P33P33

Private
Apr 3, 2017
48
11
0
Ride
BMW 335i n54 e93
I'm sorry I don't have more than that. I asked some info and got only those documents. I wish I had the whole document. @AzNdevil maybe you can help a little here.
 

all4bspinnin

Corporal
Jun 12, 2017
170
92
0
Ride
135i TT
I have recently encountered the same problem but it happened after changing to new hybrid turbos. I'm on i8a0s. My friend has the same turbos and I have made the basically the same tune and he doesn't have the same issue. He's on ije0s.

I have made these notes to wgdc diagram but I had limited information so my notes may not be 100% accurate but maybe it can shed some light for you guys to see what controls wgdc.

These are the two tables you were missing:
 

Attachments

  • Missing Tables.PNG
    Missing Tables.PNG
    35.4 KB · Views: 78

P33P33

Private
Apr 3, 2017
48
11
0
Ride
BMW 335i n54 e93
Thanks for the tables. I think I need to do some more studying to make the document more complete.
 

AzNdevil

Sergeant
Nov 4, 2016
426
181
0
Hong Kong
I reverted back to the previois tune revision that used to run quite well few days ago and still have the same problem.

Only differences I can think of now are that it's several degrees warmer now than it was few days ago and that I was driving fast on the autobahn for couple of hours.

Looking at the logs only difference I see is:
WGDC PID is above WGDC Base now although PID should be pulling WGDC and overboost obvioisly.

Maybe WGDC (ETC) is causing this?
Does it add to the base or to WGDC PID?

Whatever is adding a few degrees of WGDC, guess I will have to adjust p factors to pull enough WGDC to compensate.
Whqts actually the formula to predich added WGDC based on p-factor?

In INPA I also saw an adaption related to boost control maxed, but I am not sure if that if that is xausing problems.

Current log:

i took a quick look and this might be caused by too much wgdc adder....
seems like the car is still adding boost by pid cause you havent reached your load target yet but a second or so later it realizes it added too much so throttle closure happens

i have something similar happen in higher gears and my work around is to use load by gear so it doesnt skyrocket....

Thanks for the tables. I think I need to do some more studying to make the document more complete.

pm me and let me know what else you need...i would like to see your notes as well ;)
ive been pretty busy with real life and sorting things out on my car so i am not on the forums as often