E9X N55 E Chassis PWG Unusual Oil Temps

N55_E92

New Member
Nov 23, 2019
7
1
0
Scottsdale, AZ
Ride
2012 BMW 335i (E92)
Hello, so recently I've been running into the issue of my oil temps running a little warmer then normal. Car runs fine in city but as soon as I get on the freeway my temps start to creep to 250f and sit there. Only remedy I have it turning on my heater and i watch my temps go down to almost 230f. Did a water pump test to see it was spraying into the reservoir which it was.

Could it be my thermostat? I also noticed a OFHG leak that's not terrible and its the only leak but I saw on a forum someone said the oil can contaminate the coolant in the filter housing if there's a leak. My modifications so far are JB4 usually map 5 or 7 on e40 mix, stage 2 lpfp, bms 5 inch intercooler, doc race charge pipe, vrsf j pipe, xhp flashtool stage 3, vrsf catless downpipe.

Anyone got a clue on what's going on? Started about a month ago before I installed the BMS intercooler and nothing changed after install temps wise. Also i cannot log my car, don't have the JB4 app yet and I have a locked DME.

*Edit: I can also get pictures and videos as well for better representation, my suspicion is possibly intercooler? i know its not sufficient for arizona temps but I will be driving when its 60f and raining out and it will still have hot temps while cruising without the heater on
 

Weehe

Specialist
May 21, 2019
84
39
0
Ride
2011 335i
Yeah that is an issue then. I'm guessing you have an oil cooler. Is anything blocking the cooler core?
 

N55_E92

New Member
Nov 23, 2019
7
1
0
Scottsdale, AZ
Ride
2012 BMW 335i (E92)
ANSWER: Well the waterpump went the other day even after all the tests I did, already replaced it and the thermo and running cooler then ever :)
 
  • Like
Reactions: NoQuarter