Help with DCT Swap

taye_335is

New Member
Dec 6, 2022
3
0
0
Hello Im currently in the process of DCT Swapping my 09 135i (build date 2008-09-16) i am running into some issues with the wiring side of things. We're stuck on the DCT Harness to the engine bay. Do we leave the original auto harness in the bay? Or do we just add the DCT Harness into the DME box and repin/plug in the connectors? ex. x6021 and x6031. We've gotten the car running a while back but the car would not shift gears period even if done manually and had some PT-Can codes. Thank you.
 

That4chanhackerguy

Specialist
May 27, 2022
54
8
0
no need to repin in the DME box, this thing boggled me lol there are pins that will not connect to anything as long as you use a DCT tranmission harness its plug for your production date. the reset is gonna be inside the cabin for the GWS thats were all my wiring takes place I have done a few now. follow this diagram and you will be golden. Follow this diagram and you will be golden.
 

Attachments

  • 201156061_4209300515773807_5381100691803273027_n.jpg
    201156061_4209300515773807_5381100691803273027_n.jpg
    209.1 KB · Views: 35

taye_335is

New Member
Dec 6, 2022
3
0
0
no need to repin in the DME box, this thing boggled me lol there are pins that will not connect to anything as long as you use a DCT tranmission harness its plug for your production date. the reset is gonna be inside the cabin for the GWS thats were all my wiring takes place I have done a few now. follow this diagram and you will be golden. Follow this diagram and you will be golden.
Thanks for the help. Ive actually followed this diagram a few days ago and it helped alot. But instead of wiring the 3-4-5 pins on the 10 Pin i've spliced from the EKPM. I am no longer getting PT-Can codes. But I am getting a few codes I believe is because my pops repinned the black and blue connectors in the bay (he followed a diagram from a reputable shop) and is having communication issues i'm trying to get this all sorted out for him. These codes are causing the car to have long cranking and rough idle. i believe since the crankshaft sensor isnt getting signal. The codes for the ENGINE codes i noticed are all related to the same wiring harness area.
Screenshot_20240115_154909.jpg
Screenshot_20240115_154901.jpg