E85 cold start issue (with latest tables)

veer90

Captain
Nov 16, 2016
1,000
762
25
West Nyack, NY
Ride
e90 335i 6MT
So it's 28-35F here in NY and I'm having issues starting the car with the latest cold start tables. From a cold start (parked overnight) there's a 60% chance it will crank, fire, then stall. If I give it throttle and hold rpms around 1,500 for a few seconds it will run on the first crank. If it stalls, second crank will fire right up with no throttle.

Weird part is it worked perfectly for a month and then this issue started randomly with no other changes to the hardware / tune.

Tried bumping the warm up enrichment values, helped slightly. Tried mixing down to ~E70, didn't help.

I'm thinking plugs (NGK 2 steps colder with ~10k miles) or HPFP. Anyone have other ideas?
 

tisdrew

Corporal
Jun 27, 2017
175
87
0
Ride
09 335i 6MT
Long cranks typically indicate HPFP is wearing out and e85 excaerbates this problem. Unsure if it will help but when you turn on the ignition (one button push, clutch untouched), it'll audibly prime/trigger the lpfp, then push clutch in and start as normal. Does that help you?

Let us know if the plugs look fouled.
 
  • Like
Reactions: veer90

chrisdfv

Sergeant
Aug 29, 2017
263
206
0
Ride
E90 335i
This sounds exactly like my car right now. Anything in the low 30s and it will fire, idle briefly(rough) and then stall out. hit the button again and it starts and idles fine. Also running NGK N20(2 steps colder iirc).

I let it sit for 5 days and it took maybe 5 start button pushes(the fire, rough idle, stall out sequence) before it finally idled.

I also bumped up the fuel enrichment table and fuel start tables which may have helped slightly or it was placebo. Haven't tried raising them up further since, I've just be lazy and it hasn't made me late to work yet.
 

veer90

Captain
Nov 16, 2016
1,000
762
25
West Nyack, NY
Ride
e90 335i 6MT
This sounds exactly like my car right now. Anything in the low 30s and it will fire, idle briefly(rough) and then stall out. hit the button again and it starts and idles fine. Also running NGK N20(2 steps colder iirc).

I let it sit for 5 days and it took maybe 5 start button pushes(the fire, rough idle, stall out sequence) before it finally idled.

I also bumped up the fuel enrichment table and fuel start tables which may have helped slightly or it was placebo. Haven't tried raising them up further since, I've just be lazy and it hasn't made me late to work yet.

How much did you change the table by? I figured out today it's probably the fuel (start) table that needs tweaking.

I have V8bait's table and adjusted values up 9% for rows -30.00 to 0.00. Will see how it cranks tomorrow morning
 

chrisdfv

Sergeant
Aug 29, 2017
263
206
0
Ride
E90 335i
How much did you change the table by? I figured out today it's probably the fuel (start) table that needs tweaking.

I have V8bait's table and adjusted values up 9% for rows -30.00 to 0.00. Will see how it cranks tomorrow morning

I don't recall, andI don't have my bin or tuner pro on my work PC. Those fuel tables are in the flexfuel xdf now btw.

I'll play with the fuel start table some more. It's only going to be in the 40s here this weekend.
 

[email protected]

Sergeant
Platinum Vendor
Jan 23, 2017
460
371
25
FWIW we added v8bait's cold start tables to all of our JB4 OTS E85 maps. If anyone from our camp is still having issues on those maps after let me know and we can keep tweaking them for you! :)
 
Last edited:
  • Like
Reactions: V8bait

Jeffman

Captain
Jan 7, 2017
1,470
525
0
It would be great if someone could publish the corresponding TunerPro table in the FlexFuel XDF with a good set of values to use for cold start when using E85 or ethanol blends.
 

chrisdfv

Sergeant
Aug 29, 2017
263
206
0
Ride
E90 335i
It would be great if someone could publish the corresponding TunerPro table in the FlexFuel XDF with a good set of values to use for cold start when using E85 or ethanol blends.

This is what I have in my tables. Running straight E85.
1545099636064.png
 

Attachments

  • Capture.JPG
    Capture.JPG
    103.2 KB · Views: 175
Last edited:
  • Like
Reactions: Jeffman

chrisdfv

Sergeant
Aug 29, 2017
263
206
0
Ride
E90 335i
Those values work well for your car?

My Fuel (Start) table has even more enrichment than yours and it still wasn't able to idle first crank this morning at 35F.

Worked this morning at 38F
Lower 30s is when it will take 2 tries.
 
  • Like
Reactions: veer90

V8bait

Sergeant
Nov 2, 2016
484
743
0
Texas
I tested the ones I posted to -9*F on ethanol testing 90% on one car and at 2*F on a car testing E80, but getting it to fire perfect in one shot is difficult. I had 4 people reporting with external afr verification. Getting it to fire in one or two tries at those temps I consider a win, before I've seen people kill batteries cranking for 1-2 minutes which is not good for a cold engine either. My girlfriend's flexfuel F150 gives a huge headache starting at just 40*F and it's factory flex.

This is what I have in my tables. Running straight E85.
View attachment 21133

What's up with the axis? May need to verify the address is right for warmup enrich.
 
Last edited:
  • Like
Reactions: veer90

chrisdfv

Sergeant
Aug 29, 2017
263
206
0
Ride
E90 335i
What's up with the axis? May need to verify the address is right for warmup enrich.

I didn't realize my non Flex XDF was messed up. The conversion formula was wrong in the parameter info. I'll edit my previous post to avoid confusion.
 

veer90

Captain
Nov 16, 2016
1,000
762
25
West Nyack, NY
Ride
e90 335i 6MT
So I did some pulls and checked my spark plugs. Good rail pressure, HPFP is still strong but the plugs look nasty after a year of high boost and abuse.

Gonna change plugs and revert back to v8bait's old values as provided. I think I found the issue lol
 

chrisdfv

Sergeant
Aug 29, 2017
263
206
0
Ride
E90 335i
So I did some pulls and checked my spark plugs. Good rail pressure, HPFP is still strong but the plugs look nasty after a year of high boost and abuse.

Gonna change plugs and revert back to v8bait's old values as provided. I think I found the issue lol

Nice. Report back if it helps. My plugs are about 9 months old, but I'm going to change them at some point this winter. If this cleans up your starts, I might be inclined to change them sooner.
 

jyamona

Captain
Platinum Vendor
Nov 7, 2016
1,292
1,660
0
Philly
Those values work well for your car?

My Fuel (Start) table has even more enrichment than yours and it still wasn't able to idle first crank this morning at 35F.

You need to edit the warm-up enrichment table as well, that is what is used immediately after start until it enters closed loop. Also, make sure you have cat heating mode aka "cold start" turned off.
 

veer90

Captain
Nov 16, 2016
1,000
762
25
West Nyack, NY
Ride
e90 335i 6MT
You need to edit the warm-up enrichment table as well, that is what is used immediately after start until it enters closed loop. Also, make sure you have cat heating mode aka "cold start" turned off.

Is that the "cold start noise reduction" checkbox in MHD or do I have to change it with Tunerpro?