Discussion about issues encountered whilst converting to M3 Flash and GWS

m_a_itani

Lurker
Mar 18, 2019
23
4
0
Ride
BMW 335i M3 converted
Here’s a further explanation of coding and errors presented, from @LMB335is
I've been doing his coding for him. Removed $2TC, added $2MK, $2MD, defaulted KOMBI, NFRM, JBBF, CIC and did the additional KOMBI coding. Same exact thing Darrick Yezak did and car runs wells, at least as far as I know. So last night we take it back to stock, VO and all modules defaulted to stock to start over and go in stages to try and isolate when the issues occurs. Stock VO, no coding, çar shifts quickly but trans and tach errors. I then just deleted stock dct from VO and added M dct, coded KOMBI and car still shifted well but still had trans and tach errors. Next step was to add MDRIVE to VO, and defaulted KOMBI again, along with JBBF, NFRM, CIC. Now the errors were gone but the shifting issue started again. I've was wondering if the tune might be interfering in some way. My next step was having him flash the DME to stock but I ran out of time last night. He's also getting consistent errors in the EGS of CF21 and CF27. CF21 - EGS/SMG: no message from INSTR.CLUSTER CF27 - EGS: Message from SZL: operation, gearbox selector switch. Wiring, connection, bad contact issue?
Hello mate, did you manage to fix the cf21 error?
 
  • Like
Reactions: bernardo774

Bnks334

Lieutenant
Dec 1, 2016
529
341
0
New York
i have the same question. CF21 Error - Acceleration data incorrect, PT-CAN, from DSC

My car is a E93 335 2010.
I am getting this too on my 135i DCT swap. Car runs and drives fine. I feel like it's coding related but I just compared a bunch of TRC files for JBBF, DSC, KOMBI, GWS and I don't see anything that stands out as coded wrong. Reset DME variants with INPA again with no change.

Code suggests DSC isn't sending the right data but it's a transmission error so maybe the DCT has something wrong with it. Going to pull and double check my DCT harness.
 

bernardo774

New Member
Aug 15, 2022
9
3
0
I am getting this too on my 135i DCT swap. Car runs and drives fine. I feel like it's coding related but I just compared a bunch of TRC files for JBBF, DSC, KOMBI, GWS and I don't see anything that stands out as coded wrong. Reset DME variants with INPA again with no change.

Code suggests DSC isn't sending the right data but it's a transmission error so maybe the DCT has something wrong with it. Going to pull and double check my DCT harness.
Allec resolved this issue in DCT map
 

aus335iguy

Colonel
Nov 18, 2017
2,251
804
0
Down under
Ride
335i DCT 2009
Not sure who that is. I am running the GTS file.

Were you able to use launch control with this error?
Have you guys changed the final drive on your cars ? The GTS tune expects GTS wheel speed relative to revs in any gear
It’s the same with non M
 

bernardo774

New Member
Aug 15, 2022
9
3
0

All Shiftmapss for N54 rev limits, max clutch pressure up to 20psi, 2.56 rear end (stock), lot of stuf by Alec (Osla).

Will do some videos in cruise speed, the gears change like stock.
 

Attachments

  • Imagem do WhatsApp de 2024-02-24 à(s) 11.15.32_97ae07c2.jpg
    Imagem do WhatsApp de 2024-02-24 à(s) 11.15.32_97ae07c2.jpg
    193.1 KB · Views: 4