700HP N54 Single Turbo JB4 Helix Overdrive Issues

phineu

New Member
Aug 19, 2021
8
3
0
Hey Guys,

i drive an 135i N54 with a Docrace Top Mount Kit with a Garrett GTX3576r. I have also an Helix HPFP Overdrive System installed, which is working pretty good whith flash only (i mapped the car by myself). But as i wanted better boost controll then what it possible with a manual boost controller, i decided to get a jb4 to do the job.

But now, when i have the jb4 installed, i am facing rail pressure drops (1200 psi on WOT).

To check if the problem is just present with the JB4 installed, i threw it out and tested again with flash only and there my rail pressure is very stable, even when running more boost.

So here are the facts:

Flash only: 30 psi of boost, rail pressure above 2300 psi, log is attached: https://datazap.me/u/phineu/flash-only-30-psi-helix?log=0&data=3-20-21&solo=3
JB4 installed with Backend Flash: 26 psi of boost, rail pressure drops to 1200 psi, log is attached: https://datazap.me/u/phineu/jb4-back-end-flash-26-psi-helix?log=0&data=1-4

In both maps (flash only, AND JB4 backend flash) i changed the vcv tables as it is mentioned by spool performance:

VCV Tables.png


But for some reason, it seems like with the JB4 installed, the HPFP controll won't work like it should.

Also i tried different settings for the fuel open loop in the JB4 interface, but no effect at all.

Is there maybe a JB4 specific setting which has to be done in the map? Or has someone the solution for this?


Best Regards

Philipp
 

KClemente

Corporal
Nov 26, 2019
213
99
0
Ride
E90 335i
Did you change your fuel pressure target map? Unfortunately with JB4, we can't log fuel pressure target and VCV status.

Back when I had rail pressure issues with my helix, I forgot to change KF_PRAIL_H (Fuel Pressure Target (Homo)) and that's what caused my fp_h to dip and oscillate.
 

phineu

New Member
Aug 19, 2021
8
3
0
Did you change your fuel pressure target map? Unfortunately with JB4, we can't log fuel pressure target and VCV status.

Back when I had rail pressure issues with my helix, I forgot to change KF_PRAIL_H (Fuel Pressure Target (Homo)) and that's what caused my fp_h to dip and oscillate.
Yes, i also changed the fuel pressure target homo table. I changed them to this:

Screenshot_20210831-150625_WhatsApp.jpg


Can you send me a picture of your table?
 

KClemente

Corporal
Nov 26, 2019
213
99
0
Ride
E90 335i
What is your Fuel Open Loop set to on your JB4? I set mine to 0 and enabled the bit that disables the open loop

FOL is a bias applied to the HPFP pressure that tricks the DME into thinking that it's making less pressure than it really is making
 

phineu

New Member
Aug 19, 2021
8
3
0
What is your Fuel Open Loop set to on your JB4? I set mine to 0 and enabled the bit that disables the open loop

FOL is a bias applied to the HPFP pressure that tricks the DME into thinking that it's making less pressure than it really is making
I tested several settings on Fuel Open Loop, from 0 to 100, but it seemed to have no effect.

Where can this bit be enabled to disable the fuel open loop?
 

GreyNBlueE92

Sergeant
Oct 3, 2018
259
88
0
25
OH
Ride
2007 E92 335i
Try and up the flow request to current request at lower voltages as the jb4 likes to under report load depending on settings. Lower the numbers in the table to request more flow at lower amps.
 
  • Like
Reactions: phineu

phineu

New Member
Aug 19, 2021
8
3
0
Try and up the flow request to current request at lower voltages as the jb4 likes to under report load depending on settings. Lower the numbers in the table to request more flow at lower amps.
Thanks man, i will try this at next, do you have a picture of the values for me?
 

phineu

New Member
Aug 19, 2021
8
3
0
Try and up the flow request to current request at lower voltages as the jb4 likes to under report load depending on settings. Lower the numbers in the table to request more flow at lower amps.
I just tried this yesterday, but also no effect at all...
 

RuskiRacer

Captain
Jul 17, 2019
1,132
687
0
Ride
2009 e93 335i
A bit off topic but how’s the helix been holding up for for you and how long you been running it ?
There pretty solid option if you don't wanna buy port and a controller. I got a single turbo at my shop thats been running it for like 20k miles hes selling it and switching to port for more power for his built motor if you wanna buy it
 

Jacobniell

Lurker
Jan 11, 2017
17
1
0
There pretty solid option if you don't wanna buy port and a controller. I got a single turbo at my shop thats been running it for like 20k miles hes selling it and switching to port for more power for his built motor if you wanna buy it
Sorry for asking but what is for sale the single turbo or the Helix?
 

phineu

New Member
Aug 19, 2021
8
3
0
A bit off topic but how’s the helix been holding up for for you and how long you been running it ?
Holds up very well. I am running the helix since march and have now about 8000km on it. I run about 700hp on the crank on pump fuel.
 

Tuppidsay

Corporal
Aug 3, 2017
112
62
0
Seattle, WA
Ride
2008 535i
Id email terry first but as a brute force approach, Maybe find the rail pressure sensor signal wire and bypass the jb4 in the jb4 harness?
 

phineu

New Member
Aug 19, 2021
8
3
0
Id email terry first but as a brute force approach, Maybe find the rail pressure sensor signal wire and bypass the jb4 in the jb4 harness?
allready emailed him, but no answer at all.

the bypass of the cable sounds like an idea 🤔 will think about that, thank you for this idea 👍