5 series help

Pata1

Lurker
Mar 12, 2018
12
2
0
Ride
2010 535i
New to the forum. Just Got a 2010 535i and I've been having issues with it. It has happened 2x now. First time I had the belt fly off pulled over killed the car and it had a pool of oil under it. I have no clue where the oil is coming from. Im guessing from an oil cooler line. The 2nd time drove it the drive belt didn't fly off but it's leaking like a siv, id say at least a quart all over everything. Both times I was going at least 100. The only thing I can think of is that the oil cooler lines have some type of leak and that whenever I reach high speeds the cooler kicks on and shoots oil everywhere. The dealer is taking care of it but trying to get all of this figured out, bc it has been in the shop more than I have driven it at the moment.
 

Cheezy

Lieutenant
Nov 7, 2016
610
223
0
Toledo Ohio
So your motor mount is bad, belt is contacting subframe and shredding. Belt got sucked into front main seal now youre screwed. Dealer will fix it, will cost a shit load.
 

Pata1

Lurker
Mar 12, 2018
12
2
0
Ride
2010 535i
So your motor mount is bad, belt is contacting subframe and shredding. Belt got sucked into front main seal now youre screwed. Dealer will fix it, will cost a shit load.
Nice. Good thing I'm not gonna be paying for it. The 2nd time it did it(today) I didn't throw the belt. Makes sense that it would be that. It only really leaks under WOT from what I can tell.
 

Cheezy

Lieutenant
Nov 7, 2016
610
223
0
Toledo Ohio
The first time did the belt get shredded? Or just come off? Either way its probably a combination of bad motor mount/ power steering pulley/ tensioner.
 

Pata1

Lurker
Mar 12, 2018
12
2
0
Ride
2010 535i
The first time did the belt get shredded? Or just come off? Either way its probably a combination of bad motor mount/ power steering pulley/ tensioner.
Yes the first time it shredded the belt. It didn't shred it this time, I'm thinking bc it's a new belt.
 

Pata1

Lurker
Mar 12, 2018
12
2
0
Ride
2010 535i
So I think I have figured out the root of all my problems and the domino effect that happened. It had an oil cooler leak that dripped on the belt, making the belt come off, shreddng the belt. Which some of the belt got stuck behind the crank breaking the front seal. Hoping it all gets fixed soon. I should have it back on Monday. Might have to change the pcv valve and then I can start on the mods that are sitting in my garage.
 
  • Like
Reactions: Cheezy and DAVE

doublespaces

Administrator
Oct 18, 2016
9,135
4,171
0
AZ
Ride
2009 E93 335i
Yeap the oil leaks are a common cause of this happening. Everyone should make sure to keep their oil lines and fittings away from this serpentine belt if they can.