What Load to Torque tables to use with xHP Stage 3?

  • Login or Register, members don't see Ads!
  • Tip: You can toggle the Dark Theme at the bottom of the page

Jeffman

Captain
Jan 7, 2017
1,340
So I flashed xHP Stage 3 TCU this week and love it! I'm currently running 93 oct stock turbos FBO + catted OEM DP. According to Virtual Dyno my max Torque at the wheels is around 420 ft/lb @ 24 psi. Scaled tune with N20 TMAP. My LTT tables max out around 660 NM and my logs show max 670-690 NM Torque Actual Value. Link below.
http://datazap.me/u/jeffman/xhp-stage-3-93-oct-flat-81f-wgdc-22-no-lean-spool?log=2&data=2-14-24&solo=2&zoom=30-122

Since the xHP Stage 3 TCU Torque limits are much higher how should I modify my Load to Torque tables to better integrate with xHP Stage 3? I guess this leads to a much bigger question ... what are the general guidelines for tuning the ECU and the TCU together?
 

Jeffman

Captain
Jan 7, 2017
1,340
Timing is for 93 Octane. How much more timing would you recommend?

My understanding is that it's best to have the actual / accurate torque reported from the ECU (via the LTT 1-2-3 tables) to the TCU. So for tuned engines like ours the actual Torque is much higher. XHP Stage 3 allows higher Torque values. I may be wrong, but I believe this reasons not to leave the LTT tables stock.
 
Last edited:

[email protected]

Lieutenant
Nov 14, 2016
655
North Wilkesboro
Timing is for 93 Octane. How much more timing would you recommend?

My understanding is that it's best to have the actual / accurate torque reported from the ECU (via the LTT 1-2-3 tables) to the TCU. So for tuned engines like ours the actual Torque is much higher. XHP Stage 3 allows higher Torque values. I may be wrong, but I believe this reasons not to leave the LTT tables stock.
So, overall what's your goal to change here? Balancing the tables out so they all "are on the same page" or to correct your output?

Essentially one would resolve the other but, there's 2 ways to look at this problem.
 

Jeffman

Captain
Jan 7, 2017
1,340
Derek,
Thanks for your interest. I'm looking to get the best tune and driveability as possible for my set-up. I suspect getting the reported torques from the ECU to the TCU to be "right" will help me achieve these goals. For example, I want to make sure the reported Torque is sufficiently high to ensure strong shifting (i.e., high line pressures) when appropriate. But too high ECU reported Torque may give rise to too rough shifting, hence reduced driveability.
 

matreyia

Captain
Apr 19, 2017
1,373
I have the same issue. And I have no idea how or what to do to alter the torque values to mate with my upgraded PD transmission and 450whp. So I cannot use Stage 3 xHP and xHP isn't able or interested in helping the situation. It is frustrating because stock PD shifting programming is silky smooth no matter what RPM and xHP is rough, jerky,lurching, hesitant at high RPMs... I would stay stock but the smoothness of it is destroyed by the slow shift times. Very annoying.

If anyone knows how to set the xHP shift times to accomodate some logs, I would be insanely greatful...as it is now...I have bought stage 1,2,3 and none of them really are useful at all...Either too slow shifting or too unusable in higher RPM.
 

Jeffman

Captain
Jan 7, 2017
1,340
I wish I could help you. But I haven’t tried transmission tuning yet.
 
Last edited:

Rob09msport

Major
Oct 28, 2017
1,850
Monroe CT
I have the same issue. And I have no idea how or what to do to alter the torque values to mate with my upgraded PD transmission and 450whp. So I cannot use Stage 3 xHP and xHP isn't able or interested in helping the situation. It is frustrating because stock PD shifting programming is silky smooth no matter what RPM and xHP is rough, jerky,lurching, hesitant at high RPMs... I would stay stock but the smoothness of it is destroyed by the slow shift times. Very annoying.

If anyone knows how to set the xHP shift times to accomodate some logs, I would be insanely greatful...as it is now...I have bought stage 1,2,3 and none of them really are useful at all...Either too slow shifting or too unusable in higher RPM.
Honestly you have to have a hardware issue that's why tuning your dme has been a challenge and same with your TCU. Do you use linear throttle ?
Also I would do full rewrite of every module in car someone messed up sonething and it's causing you multiple issues you have replaced alot of stuff which is good but makes it hard to track down where it went wrong.
 
Last edited:

matreyia

Captain
Apr 19, 2017
1,373
Honestly you have to have a hardware issue that's why tuning your dme has been a challenge and same with your TCU. Do you use linear throttle ?
Engine is new, transmission is a Propulsive Dynamics Unit with refreshed valvebody...
Runs and shifts like new if using stock flash or OTS MHD flashes no matter what stage... but xHP be suckin balls. Basically useless for me. I can understand more violent and rough shifting...but this is not that...this is totally abnormal and feels like it is damaging things. Your car should never ever feel like it is pushing backwards, then hesitate, then go forwards when shifting under high boost.

It's understandable if under high boost the car go BANG! when shifting as along as it actually shifts and goes forward...NOT feel like it goes backwards, then forwards. And Clemens at xHP was either not interested or could not figure it out. In any case, it's a moot point to talk to them... I feel it is both tuning related and xHP related. As I said...OTS maximum MHD maps...no problems shifting or running WOT in stock transmission flash... but once I change to xHP it goes to shit.

I should say that xHP stage one is usable but too slow for my tastes.
stage 2 is faster and BARELY usable under WOT...
stage 3...faggettaboutit.... no way José.

I really don't want the transmission to have torque limitations set by any stage.
 

Rob09msport

Major
Oct 28, 2017
1,850
Monroe CT
Engine is new, transmission is a Propulsive Dynamics Unit with refreshed valvebody...
Runs and shifts like new if using stock flash or OTS MHD flashes no matter what stage... but xHP be suckin balls. Basically useless for me. I can understand more violent and rough shifting...but this is not that...this is totally abnormal and feels like it is damaging things. Your car should never ever feel like it is pushing backwards, then hesitate, then go forwards when shifting under high boost.

It's understandable if under high boost the car go BANG! when shifting as along as it actually shifts and goes forward...NOT feel like it goes backwards, then forwards. And Clemens at xHP was either not interested or could not figure it out. In any case, it's a moot point to talk to them... I feel it is both tuning related and xHP related. As I said...OTS maximum MHD maps...no problems shifting or running WOT in stock transmission flash... but once I change to xHP it goes to shit.

I should say that xHP stage one is usable but too slow for my tastes.
stage 2 is faster and BARELY usable under WOT...
stage 3...faggettaboutit.... no way José.

I really don't want the transmission to have torque limitations set by any stage.
Just cause all is new doesnt mean all is right it actually opens up more possibility for one person to make mistake.
I really think you have best intentions but in one post you say your car is perfect and then you have issues with a product that has to be the tuner or company or dealers fault. Then meanwhile you are saying your still having codes after you changed your Ekmp module. I am not attacking you. I just am pointing out that I think you need to get back to the basics and iron out issues, then add one piece at a time so you point finger in right direction could be at self or something else but it better then a different assumption every wk. Plus how can people help of you say everything new and perfect ,instead of being defensive try to be subjective.
 
Last edited:

matreyia

Captain
Apr 19, 2017
1,373
Just cause all is new doesnt mean all is right it actually opens up more possibility for one person to make mistake.
I really think you have best intentions but in one post you say your car is perfect and then you have issues with a product that has to be the tuner or company or dealers fault. Then meanwhile you are saying your still having codes after you changed your Ekmp module. I am not attacking you. I just am pointing out that I think you need to get back to the basics and iron out issues, then add one piece at a time so you point finger in right direction could be at self or something else but it better then a different assumption every wk. Plus how can people help of you say everything new and perfect ,instead of being defensive try to be subjective.

1. New epkm 3
2. New engine
3. New vanos solenoids
4. New tmap 3.5 bar
5. New belt
6. New pulley
7. New r8 coils
8. New BL harness
9. New VB sonnax updates
10. PD trans
11. New nkg plugs
12. Walnut blast
14. Upgraded csf radiator
15. New h2o pum po and thermo
16. New stainless steel oil filter
17. Motul oil
18. Motiv flexfuel kit fully functional.
19. All hoses, inlets outlets, charge pipes upgraded. Every single vacuum hose.
20. All coolant hoses new.
21. Tial bov fully functional.

MHD OTS maps fully functional with no problems shifting on stock trans flash and stage 1 xHP and Alpina.
MHD OTS maps fully functional but shifts like shit on xHP wot stage 2 and 3.

So you are not attacking me, great.
Tell me what you think considering all the above. All items were replaced in succession due to xHP and there is literal nothing else to replace... so you tell me.

Not one error. Not even the old lpfp plausibilty error.

My opinion is that xHP is not good with PD units or I have a fake PD unit. It sure as hell ain't anything related to the above replaced parts.
 

P33P33

Private
Apr 3, 2017
41
MHD OTS maps fully functional with no problems shifting on stock trans flash and stage 1 xHP and Alpina.
MHD OTS maps fully functional but shifts like shit on xHP wot stage 2 and 3.

My opinion is that xHP is not good with PD units or I have a fake PD unit. It sure as hell ain't anything related to the above replaced parts.
Which one do you have MSD80 or 81? MSD80 is only able to send 536nm to TCU and all the actual torque above that is unknown to TCU. I have that problem and it makes XHP stage 3 a little bit jerky(stock trans). I have talked about this issue with XHP and they have verified this too(not the behavior, just the hardware limitations). They suggested me to upgrade to MSD81. I haven't done that so I can't be sure this will help the situation.
I have also played with L2T tables and it seems that lowering these tables will make the shifts smoother but at the same time little slower or sluggish.
 
  • 1Like
  • 1Informative
Reactions: matreyia and Optigrab

Rob09msport

Major
Oct 28, 2017
1,850
Monroe CT
1. New epkm 3
2. New engine
3. New vanos solenoids
4. New tmap 3.5 bar
5. New belt
6. New pulley
7. New r8 coils
8. New BL harness
9. New VB sonnax updates
10. PD trans
11. New nkg plugs
12. Walnut blast
14. Upgraded csf radiator
15. New h2o pum po and thermo
16. New stainless steel oil filter
17. Motul oil
18. Motiv flexfuel kit fully functional.
19. All hoses, inlets outlets, charge pipes upgraded. Every single vacuum hose.
20. All coolant hoses new.
21. Tial bov fully functional.

MHD OTS maps fully functional with no problems shifting on stock trans flash and stage 1 xHP and Alpina.
MHD OTS maps fully functional but shifts like shit on xHP wot stage 2 and 3.

So you are not attacking me, great.
Tell me what you think considering all the above. All items were replaced in succession due to xHP and there is literal nothing else to replace... so you tell me.

Not one error. Not even the old lpfp plausibilty error.

My opinion is that xHP is not good with PD units or I have a fake PD unit. It sure as hell ain't anything related to the above replaced parts.
I first hand know how frustrating it is I have same upgrades except new block and go nuts when i have issue especially cause i never cheap out. I am just saying it seems you have gremlins. Dealer had issue with programming your car for steering wheel , tuners has issue, xhp has issue, your ekp brand new has issue. Their are many more as well point being if something is wrong to begin with then finding prob is hard especially when so many hands have been in their. Every upgrade listed is an opportunity for sonething to go wrong be it a wire snagged and grounding or who knows. You seem like good person who is trying to make perfect build but I just wish you would not be so quick to assume it's the products fault and you can't say everything was perfect before said item when you have multiple threads going about issues with car, it's not fair to vendors.

Have you tried doing full rewrite , just code every module in car ?
 

matreyia

Captain
Apr 19, 2017
1,373
I first hand know how frustrating it is I have same upgrades except new block and go nuts when i have issue especially cause i never cheap out. I am just saying it seems you have gremlins. Dealer had issue with programming your car for steering wheel , tuners has issue, xhp has issue, your ekp brand new has issue. Their are many more as well point being if something is wrong to begin with then finding prob is hard especially when so many hands have been in their. Every upgrade listed is an opportunity for sonething to go wrong be it a wire snagged and grounding or who knows. You seem like good person who is trying to make perfect build but I just wish you would not be so quick to assume it's the products fault and you can't say everything was perfect before said item when you have multiple threads going about issues with car, it's not fair to vendors.

Have you tried doing full rewrite , just code every module in car ?

I don't think you are reading correctly. There is nothing wrong with the car. All items have been replaced, coded and fixed and runs and shifts fine on stock and ots mhd maps...zero errors. The only thing that does not jive is xHP stage 2 and 3. Stage one is ok. Again...if i flash wedge custom...doesn't run correct. Twisted custom is better but still not perfect. Stock wedge mhd stage 2+ ots runs fine. And xhp s1 runs fine. So yeah it is definitely a tune and xhp issue. Don't sit there and tell me that in light of that obvious evidence that it ain't. There is literally no other factor now. Only the tune and xhp causes issues. I can drive like a maniac with zero issues all day on ots stage 2+...the minute I flash custom it goes south. Settings are off obviously.

And yes...every single module has been recoded.
 
Last edited:

matreyia

Captain
Apr 19, 2017
1,373
Which one do you have MSD80 or 81? MSD80 is only able to send 536nm to TCU and all the actual torque above that is unknown to TCU. I have that problem and it makes XHP stage 3 a little bit jerky(stock trans). I have talked about this issue with XHP and they have verified this too(not the behavior, just the hardware limitations). They suggested me to upgrade to MSD81. I haven't done that so I can't be sure this will help the situation.
I have also played with L2T tables and it seems that lowering these tables will make the shifts smoother but at the same time little slower or sluggish.
I have the msd81.
 

jyamona

Captain
Platinum Vendor
Nov 7, 2016
1,069
Philly
@Jeffman, the benefit of xHP stg3 is that you can report actual torque to the TCU, and not have to worry about artificially capping reported torque lower in the L2T tables to avoid hitting the tq lim.
 
  • 1Informative
Reactions: Jeffman

Jeffman

Captain
Jan 7, 2017
1,340
@Jeffman, the benefit of xHP stg3 is that you can report actual torque to the TCU, and not have to worry about artificially capping reported torque lower in the L2T tables to avoid hitting the tq lim.
Good advice to remember. I’ll have to take a careful look at my FlexFuel L2T tables when I’m tuning again. I just finally installed my PR coils and new plugs, and handling some maintenance items. Curiously, I’m still getting very same timing pulls on multiple cylinders above 4000 rpm. Could timing pulls be related to the L2T table not being dialed in correctly?
 

matreyia

Captain
Apr 19, 2017
1,373
Which one do you have MSD80 or 81? MSD80 is only able to send 536nm to TCU and all the actual torque above that is unknown to TCU. I have that problem and it makes XHP stage 3 a little bit jerky(stock trans). I have talked about this issue with XHP and they have verified this too(not the behavior, just the hardware limitations). They suggested me to upgrade to MSD81. I haven't done that so I can't be sure this will help the situation.
I have also played with L2T tables and it seems that lowering these tables will make the shifts smoother but at the same time little slower or sluggish.
Actually, that is incorrect. I found out that I actually do not have the MSD81, but rather the MSD80 unit and was logging on a dyno with Twisted Tuning and I maxed out at wheel 677nm. using stage 3xhp. on the PD transmission. All FBO, with inlets. Stock turbos.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top