Underboosting

Jpotter

Private
Oct 8, 2017
37
18
0
Ride
2007 335i
I've been trying to track down my 30ff code for some time now. It occurs at wot every time. The 30ff is the only code that pops up with it but one time I noticed a code was stored in the same. I can't remember what code it was but exhaust vanos solenoid mechanically stuck. I can't get this code to come back. I was gonna clean them before replacing but like I said they don't come back. I have a bt cable and just purchased mhd for datalogging. I have the csv file here hoping some people might be able to point me in the right direction. This was a 4th gear pull onto the freeway. Pull is later on in the log.
 

Attachments

  • 2017-10-06 17_53_07_7611397_.csv
    85.7 KB · Views: 185

R.G.

Lieutenant
Nov 17, 2016
669
325
0
Henderson, NV
Ride
E92 335, F10 M5
You're not underboosting by much. Looks like tune needs some adjustment is all I can see. Will bump this up for you see if anyone else spots anything. Is this an off the shelf map? Looks like a bootleg modified stock map.

Create a datazap account if you do not have one and upload it for more views.
 

dyezak

Major
May 4, 2017
1,768
1,515
0
Plano TX
Ride
335is
Looks like a stock tune...any recent tuning changes?

Something to keep in mind, the tune never changes, it doesn't depreciate, it doesn't degrade with age or miles. So if you haven't messed with the tune, and this 30FF code is new...it's probably physical. Boost leaks occur over time. Brittle seals, cracked plastic, loose clamps, etc. And the turbo wastegates actuators wear out too on these cars, you'll would be hearing rattle. If you haven't been modifying the DME tune then it's time to do a boost leak test and check the wastegate actuation. There are tens if not hundreds of videos on YouTube to walk you through this if you have never done it before.
 

Jpotter

Private
Oct 8, 2017
37
18
0
Ride
2007 335i
Its the factory tune. Not tuned yet. The water pump went bad after a month of ownership but i thought it was the head gasket. Due to burning coolant. Rebuilt everything and replaced all the seals. Turned out the ofh gasket was bad thats why coolant and oil were mixing. After getting the car together the 30ff showed up. Yesterday i cleaned the vanos solenoids and swapped them. I cant get it to replicate the 30ff at wot. Im sure its a temp fix untill i can buy new ones. Also my wg rattle was getting bad so i tightend the actuator a little bit to help the rattle. I plan on some new turbos and im thinking mmps but i only want about 400 maybe 450. As of right now the only thing the car has is mmp 2" inlets and outlets. Charge pipe should be next after i replace the worn clutch with the dmfw and 335is clutch
 

dyezak

Major
May 4, 2017
1,768
1,515
0
Plano TX
Ride
335is
Ok, then you definately have a physical/mechanical problem. Watch these 4 videos...click around after they are finished on youtube and watch some more. You want a good foundational understanding of boost leaks, vacuum leaks, and wastegate function. Then you'll want to go find your leak! If you hit a hurdle you can't figure out come ping this thread and explain what's going on and we will walk you through it.




 
  • Like
  • Informative
Reactions: Xm-n54 and R.G.

Jpotter

Private
Oct 8, 2017
37
18
0
Ride
2007 335i
Will do i tested the intake side and replaced inlet cause it was coming off. Now the codes not coming back ill log again so you can compare. Car feels a little more responsive