Single Turbo build questions, help!

HunterSTE90

New Member
Jul 2, 2021
2
0
0
Hazel Green,WI
Ride
09 335xi
So I have recently been building my 2009 335xi e90 and have a few questions that I'm a bit stumped on and just want to make sure I do it right! Installing doc race top mount kit which went really well, bmp front facing manifold, and motiv reflex to control boost and port injection. To start, I just installed a 3port Mac solenoid to control boost. Since there was obviously 2 previous solenoids am I good to just plug my Mac solenoid into one of the two connectors and just leave the other with nothing hooked in or do I need to wire them together or something else? There was then two vacuum lines that ran from under the intake manifold towards the front of engine that use to I believe Tee into the lines going to solenoids. (see pictures) Can I eliminate these lines, just run one over to Tee in and eliminate other or just run one to intake manifold or what? In the bottom of my intake manifold there are 4 places where I can install plugs or ports (see in picture) I am using one for hobbs switch and one for BOV boost reference line, do I just plug the other two or should I have something running to them? Are both tmap sensors on charge pipe and intake manifold suppose to be 3.5 bar with adapter or just one?does anyone know what the two springs in the wastegates that come installed in thedoc race kit are? I believe one was orange and other was green but I could not find a Spring rate on them to save my life. If you can answer any of these questions I greatly appreciate it, thanks! Sorry if this has been gone over and I just can't find it.
Ps, if you know what the connector in picture 3 is for let me know,, I thought it was off an inlet pipe or something to do with my pcv that is now deleted so I don't think it has to go to anything but im not 100% sure.
 

Attachments

  • 20210703_125722.jpg
    20210703_125722.jpg
    432.4 KB · Views: 63
  • 20210703_125750.jpg
    20210703_125750.jpg
    507.3 KB · Views: 64
  • 20210703_125825.jpg
    20210703_125825.jpg
    477.3 KB · Views: 62
  • 20210703_125947.jpg
    20210703_125947.jpg
    316.8 KB · Views: 64
Last edited:

doublespaces

Administrator
Oct 18, 2016
9,229
4,234
0
AZ
Ride
2009 E93 335i
Wow, I've never seen this happen but the site just ate my reply. You probably got an email with most of the details, feel free to copy it back here for me. But the answer to the last question is that wire goes to your heater element which is a 45 degree tube that was part of your inlets. It is no longer needed so coil it up and tuck it away.
 

HunterSTE90

New Member
Jul 2, 2021
2
0
0
Hazel Green,WI
Ride
09 335xi
That's weird! I didn't get the email for the first message you sent with all the information but I appreciate the help and response. At this point the only thing I'm still not sure on is where the vacuum lines that hook up to what I believe is a slightly larger brake booster line have to run to now. Can I run just one to my intake manifold or does it need to be ran and tied in somewhere else? Also can I just leave other solenoid plug unplugged and be okay?
Thanks
 

Cole17171

New Member
Nov 29, 2021
2
0
0
Hey so what did you do about the boost solenoids? Did you just use one and leave the other unplugged and is there a specific one to use?
 

r0nd3L

Private
Dec 2, 2019
26
11
0
Ride
135i
That's weird! I didn't get the email for the first message you sent with all the information but I appreciate the help and response. At this point the only thing I'm still not sure on is where the vacuum lines that hook up to what I believe is a slightly larger brake booster line have to run to now. Can I run just one to my intake manifold or does it need to be ran and tied in somewhere else? Also can I just leave other solenoid plug unplugged and be okay?
Thanks

You want to make sure vacuum pump, not the intake manifold, provides vacuum to the booster. On my car, I simply capped off 2 small vacuum nipples that used to route lines to the solenoids and retained hard plastic pipes. I have seen people replace ugly plastic lines with something else, so you have other options if you are picky.
 

r0nd3L

Private
Dec 2, 2019
26
11
0
Ride
135i
Hey so what did you do about the boost solenoids? Did you just use one and leave the other unplugged and is there a specific one to use?

On my Motiv BoostBox setup, one connector is simply left unplugged. I bet Reflex is similar, but might want to check with the vendor.