o2 Sensor Codes

pysical

Sergeant
Jun 16, 2017
345
73
0
Ride
2009 335xi E90
I get these randomly if I go WOT. Causes the car to run like crap until I stop and clear it out.

2C3D - DME: Oxygen sensor before catalytic converter: Line fault.
2C3E - DME: Oxygen sensor 2 before catalytic converter: Line fault.
2C7B - DME: Oxygen sensor after catalytic converter: Signal.
2C7C - DME: Oxygen sensor 2 after catalytic converter: Signal.
2CAA - DME: Oxygen sensor before catalytic converter: Temperature.
2CAB - DME: Oxygen sensor 2 before catalytic converter: Temperature.


Anyone know what the issue could be? They are all new 6 month old o2 sensors. I thought about testing with INPA but I don't know what I would be looking for.
 

veer90

Captain
Nov 16, 2016
1,000
762
25
West Nyack, NY
Ride
e90 335i 6MT
Inspect the wiring harnesses for both pre-cat O2s. If the wiring checks out then the sensors are done.

I'd guess you left the wires too close to the manifolds and it burned up the insulation. Happened to me once
 

pysical

Sergeant
Jun 16, 2017
345
73
0
Ride
2009 335xi E90
Inspect the wiring harnesses for both pre-cat O2s. If the wiring checks out then the sensors are done.

I'd guess you left the wires too close to the manifolds and it burned up the insulation. Happened to me once

The wires are far from the manifold. But I did get new ones that will be here tomorrow.

Logged a mini pull. The Motiv ECA jacked up and said 4.95v constant and 49.8%. And STFTs were 34%+.

Then did one on the way home and ECA was working correctly and STFTs went to -34%...

Hopefully the new o2 sensors fix this.
 

BreakMyBillfold

Specialist
Nov 18, 2016
81
34
0
AZ
You're replacing both precat and postcat sensors? I did my precats ones thinking the postcats ones were only for checking cat presence and not for tuning, but my mixture 2 codes persisted until I replaced the postcat one too.
 

pysical

Sergeant
Jun 16, 2017
345
73
0
Ride
2009 335xi E90
You're replacing both precat and postcat sensors? I did my precats ones thinking the postcats ones were only for checking cat presence and not for tuning, but my mixture 2 codes persisted until I replaced the postcat one too.

My o2 sensors are warranted. If these pre cost sensors do nothing then I will do the post cat ones. I also have some used ones I can try to see if anything changes.
 
May 15, 2018
20
6
0
Ride
08 335xi E92
My o2 sensors are warranted. If these pre cost sensors do nothing then I will do the post cat ones. I also have some used ones I can try to see if anything changes.
Which o2 sensors ended up being the ones causing the signal codes? I am having a very similar issue.
 

boosted.n54

New Member
Oct 28, 2019
2
0
0
Ride
2008 BMW 335xi
I am also throwing 2c78 post cat bank 2 o2 sensor code consistently even though I have replaced all of my oxygen sensors. It comes on immediately after just a couple of minutes of driving and it has me stumped on what is causing this code to pop up.

Here is a datalog: https://datazap.me/u/rnmevo9/2nd-revision-e45?log=0&data=3-20
Do You have catless downpipes and custom tune by chance ? What mods and setup you have.
 

RNM

Specialist
Jun 3, 2019
94
79
0
Do You have catless downpipes and custom tune by chance ? What mods and setup you have.

Yes to both questions. Here is a list of modifications:

RB GF 17t turbos
RB external pcv valve
RB outlets
Mhd custom tuned by BQ on e45
BMS stock location inlets
Vrsf downpipes and street exhaust
Vrsf charge pipe with raceport bov
Psp 900 intercooler
Psp external oil cooler
Relocated 335d coolant tank
Fuel it stage 2 lpfp 525 pump
EOSpeed bpm4 lpfp controller
Index 12 injectors
Precision raceworks fuel filter assembly
Spool hpfp overdrive