N54 idle surging and no start unless jumped

Matthewhernandezz

New Member
Apr 1, 2021
2
0
0
what’s up guys my 335i recently just stopped turning on and only turns on if jumped. When it starts up the idles surge between 1k-1500 rpms I’ve replaced the throttle body,checked fuses, any intake leaks. still nothing. Took to 2 different mechanic and no one knows the problem. Water was also in the battery tray fyi
 

NoQuarter

Major
Nov 24, 2017
1,596
993
0
Indiana, USA
Ride
Z4 35is, 535xi, X5 35i
Focus on the need to jump start it.

New battery and it still requires a jump.
intake leaks, etc are not going to help here I don't think.
 

RuskiRacer

Sergeant
Jul 17, 2019
428
157
0
Ride
2009 e93 335i
Are you sure your inlets are fully seated onto the turbos with no cracks in the piping ? A new battery and still needs to be jumped is very concerning. Do you have any exposed wiring that may be causing a parasitic drain?
 

bob20124

New Member
Oct 4, 2018
5
0
0
Ride
2011 Z4 35I
Bad battery ground? Are you jumping under the hood at recommended terminals?
 

Tedbuildiy

Corporal
Jan 9, 2020
209
40
0
Ride
335i
what’s up guys my 335i recently just stopped turning on and only turns on if jumped. When it starts up the idles surge between 1k-1500 rpms I’ve replaced the throttle body,checked fuses, any intake leaks. still nothing. Took to 2 different mechanic and no one knows the problem. Water was also in the battery tray fyi
So you have to start somewhere.

if it doesn’t crank at all without being jumped and the battery is charged, what can cause that?
Faulty key ? Can’t be that as you say it can be jumped with leads

could it be a fuel related issue?

camshaft sensors can cause peculiar errors...

Do you have any software to see if you can pull some codes from the DME ?