N54 big single turbo runs very lean and misfires

Hutch222

Lurker
Jan 12, 2023
14
0
0
Have a 2009 BMW 335XI with 60k miles. Car ran fine, and had no issues. I decided to go with a big single turbo kit and all supporting mods. I do not have port injection, I am just running Index 12 injectors with a bucket less dual in-tank fuel pump. We are working on an E40 tune right now but every time the car gets into boost it misfires on cylinder 3 and 5. According to the log the car is running extremely lean but fuel pressure looks good. Plugs and coils are brand new (using NKG one step colder). Oxygen sensors are brand new. Valve cover gasket, oil filter gaskets, oil has all been replaced very recently. Really don't understand what is going on here. We are now in the works of putting on an N20 map sensor and if that doesn't work supposedly the DME might be bad?? Really want to figure out the issue without pouring money into places not needed. Let me know if you guys have any ideas! thank you.

Here is the most recent log.

 

Hutch222

Lurker
Jan 12, 2023
14
0
0
Rear o2's, how old are they ?

I had the exact same issue on our single.
Upstream oxygen sensors were just replaced but there is no rear oxygen sensors anymore. The exhaust and turbo kit was all fabricated at a shop and they were deleted.

I will go log fuel mode now and see what I can get. Thank you.
 

carabuser

Lieutenant
Oct 2, 2019
852
1
745
0
UK
Ride
Z4 35i & 335i
Upstream oxygen sensors were just replaced but there is no rear oxygen sensors anymore. The exhaust and turbo kit was all fabricated at a shop and they were deleted.

I will go log fuel mode now and see what I can get. Thank you.
You need 1 primary and 1 secondary sensor as a minimum. You can't just remove both secondaries.
 

Hutch222

Lurker
Jan 12, 2023
14
0
0
Removing the sec o2's is your problem.

We run 2 primary and two secondary on our single to avoid exactly this.
hmm okay let me see what I can figure out on this. Thank you.

Here is a log with fuel mode. It is a short log because it misfired quickly and I am trying to be careful with how lean its running.

 

carabuser

Lieutenant
Oct 2, 2019
852
1
745
0
UK
Ride
Z4 35i & 335i
Fuel mode 15 is emergency mode, normally you'd need to log extra parameters but it's most likely as a result of the missing secondaries so no point looking any further.
 
  • Like
Reactions: martymil

Hutch222

Lurker
Jan 12, 2023
14
0
0
@martymil @carabuser So what I am told by the tuner is that the rear oxygen sensors quote "Post cat o2 sensors do not matter at all". so we just have the two upstream oxygen sensors (1-3 and 4-6) that are connected to the manifold.

But the tuner also told me it seems like those two oxygen sensors are bad or the plug-ins are swapped. which isn't the case because they are brand new now and a code comes up if I swap them.

I personally see how the oxygen sensors would be a problem because they monitor your air fuel ratio and that is the big issue right now. But based on what the shop and tuner tell me those post cat oxygen sensors are irrelevant and the two sensors I have are fresh.

Not trying to disagree with you guys just trying to get an understanding. Is there anything else that could be the cause of this or does the oxygen sensors seem to be the real issue here?
 

martymil

Major General
Sep 6, 2017
3,331
1,906
0
Down Under
Ride
S65 1m
You need all the o2's using mhd period, this is your problem and if your tuner is telling you otherwise i'd be seeking a new one.

Unless your a beta tester for mhd as they are working on using a single o2 but you would need to speak to them as no one has privy knowledge or would share it until release.
 

carabuser

Lieutenant
Oct 2, 2019
852
1
745
0
UK
Ride
Z4 35i & 335i
@martymil @carabuser So what I am told by the tuner is that the rear oxygen sensors quote "Post cat o2 sensors do not matter at all". so we just have the two upstream oxygen sensors (1-3 and 4-6) that are connected to the manifold.

But the tuner also told me it seems like those two oxygen sensors are bad or the plug-ins are swapped. which isn't the case because they are brand new now and a code comes up if I swap them.

I personally see how the oxygen sensors would be a problem because they monitor your air fuel ratio and that is the big issue right now. But based on what the shop and tuner tell me those post cat oxygen sensors are irrelevant and the two sensors I have are fresh.

Not trying to disagree with you guys just trying to get an understanding. Is there anything else that could be the cause of this or does the oxygen sensors seem to be the real issue here?
Get a new tuner, they are incompetent.
I understand the shop not knowing better as some vehicles don't require the secondaries but anyone tuning the engine should know better.

For a single turbo car you should use MHD's new flash option for single bank operation. It'll simplify things greatly.
 

Hutch222

Lurker
Jan 12, 2023
14
0
0
Okay thank you guys for the help! It is much appreciated.

Once I get everything sorted out ill post an update on here.
 

martymil

Major General
Sep 6, 2017
3,331
1,906
0
Down Under
Ride
S65 1m
This is the latest in beta testing I believe and a minimum requirement

jj.jpg
 

martymil

Major General
Sep 6, 2017
3,331
1,906
0
Down Under
Ride
S65 1m
What ever you do dont start pulling o2's as a single bank conversion needs the beta apk from mhd and a host of rewiring on the dme with cutom firmware to run this.
 
  • Like
Reactions: Hutch222

carabuser

Lieutenant
Oct 2, 2019
852
1
745
0
UK
Ride
Z4 35i & 335i
What ever you do dont start pulling o2's as a single bank conversion needs the beta apk from mhd and a host of rewiring on the dme with cutom firmware to run this.
I think you just need to unplug the bank 2 sensors, no custom wiring.

The firmware is also not special. AFAIK it's just calibration changes to tell the DME you only want to control on 1 bank.
 

Snertz

Specialist
Nov 7, 2016
63
51
0
NY
Ride
2011 1M
Good news, as of today the official release is out and available in the app store, no need to manually install the beta apk.

Per Jake the wiring changes are needed only if you want it to control 3 port mac. Single bank o2 requires only moving bank 1 primary to post turbo, removing both bank 2 sensors, and flash time option.
 
Last edited:

martymil

Major General
Sep 6, 2017
3,331
1,906
0
Down Under
Ride
S65 1m
You are correct, the way it was explained to me it was needed to do these changes to wire in the o2's and that's why we opted not to go down this route.

We still won't convert to single bank as I like to see exactly which bank is playing up especially when an injector takes a dump, it makes diagnosing the problem so much faster.
 

carabuser

Lieutenant
Oct 2, 2019
852
1
745
0
UK
Ride
Z4 35i & 335i
I would expect a single turbo to run much better with the change to single bank control. Trying to trim two individual bank of injectors based on a sensor that is reading the combined fuel ratios of both banks is sketchy.

External boost control (for the MAC) and O2 sensor issues were the only thing I didn't really like about single turbo setups. Hopefully now we'll see some good kits come out with updated sensor locations.
 
  • Agree
Reactions: Torgus