N54 bank 1 runs lean and rich

Slowagon54

Corporal
Aug 21, 2020
110
44
0
No. Linear throttle will do nothing for you. Good luck and keep us posted. Dont go WOT until issue solved.
 

Templedakota

Lurker
May 25, 2021
20
2
0
Guys, are my do my logs show that my turbo is blown? I haven’t upgraded to MSD81 yet. But I want to make sure before I start dropping more money.
 

Slowagon54

Corporal
Aug 21, 2020
110
44
0
Flashed the ECU and nothing new. Car still acts the same way. First minute the car has full power. After a min, hesitation, misfiring and lack of power. I’m pretty sure I need ECU. Anyone have recommendations for MSD81 swap? I see Colorado has it for $600.
Do you have a log with the MHD tune on it?
 

Templedakota

Lurker
May 25, 2021
20
2
0
Nope. Just stage 0. Stock tune. There are several logs on this thread. Starting to think a turbo is blown or ECU is bad. Would a blown turbo cause 1 bank to misfire? -34 fuel trim on bank 1? Iv just about given up on this car guys. I need someone that knows what they are looking at to look at my logs.
 

Slowagon54

Corporal
Aug 21, 2020
110
44
0
Logs will not tell what part exactly is broken. It can indicate different things and you need to rule out what makes sense the most. If you have flashed the car with MHD Stage 1 show us the log please.
 
  • Agree
Reactions: SLOWESTN54

wheela

New Member
Jun 4, 2021
6
6
0
Twin Cities, MN
Ride
2015 e84 X1 35i Msport
Nope. Just stage 0. Stock tune. There are several logs on this thread. Starting to think a turbo is blown or ECU is bad. Would a blown turbo cause 1 bank to misfire? -34 fuel trim on bank 1? Iv just about given up on this car guys. I need someone that knows what they are looking at to look at my logs.
Hmm... if the rotating assembly in the turbo froze up, then the turbine would be a restriction in the exhaust path. If exhaust can't get out efficiently, charge air can't get in efficiently. Maybe that could mess up your trims??? But that charge air should still be getting metered, so that probably doesn't make much sense. Plus it doesn't explain that you still feel full power before it warms up.
 
  • Agree
Reactions: SlowE93

dpaul

New Member
Jan 8, 2019
8
2
0
Ride
2009 E90 335xi, 2011 E93 M3
If I understand correctly, you describe these various problems as sometimes present, sometimes not. You note the engine runs fine at first then drivability issues of several types appear, plus you have a changing set of fault codes that most recently included a series of PT-CAN bus communication errors involving the DME. The intermittent nature of these things is not typical for a failed turbo or a failed DME but could indicate an electric connector problem. In any case, I cannot come up with a reasonable hypothesis for how a turbo problem could result in this constellation of issues.

Since the problems occurred after driving through deep water, have you checked the DME the box for water entry? Have you removed the DME connectors and looked for corrosion?
 
  • Like
Reactions: wheela

Templedakota

Lurker
May 25, 2021
20
2
0
After a couple months, I finally figured out the issue… clogged bank 1 secondary cat. I did a secondary cat delete and now the car runs better then it has ever. This is my first time driving the car since I put on the catless down pipes. Damn, it honestly feels like she gained 50 hp. Still haven’t tuned the car yet. Only issue now is that she smokes like a chimney. I think I’ll deal with the smoke until the turbos completely give.