Technical MOTIV BoostBox and N54B30TO

BQTuning

Corporal
Jul 18, 2017
174
139
0
www.bqtuning.com
Ride
E89 Z4 35i 6MT M Sport
If you are wondering what is N54B30TO, this is the N54 engine coding for the 1M, 335is and Z435is model cars that come with factory overboost and more power. This post is not in question of the N54B30 cars running the Motiv Boostbox, only specific to the 1M, 335is, and 335is

Has anyone ran into issues with overboosting ? I managed to resolve the overboosting issue, but came to "experience" adding just 1.00% WGDC value it added like 7 PSI at peak boost which is bizarre to me.

Couple of other tuners locally struggled with this also, so the car was brought to me to resolve more so to get the DCT to work properly.
 

Blue335is

Specialist
Dec 12, 2016
58
23
0
Im really interested to hear feed back on this. I think phil is running the motiv boostbox on his 335is. I think ken tuned the car.
 

V8bait

Sergeant
Nov 2, 2016
484
743
0
Texas
Any logs of the issue specifically? Adding 1% wgdc to the base shouldn't add that much boost so it definitely sounds like something is going on. What version of the boostbox? I've had much better results with the v3 personally.
 

BQTuning

Corporal
Jul 18, 2017
174
139
0
www.bqtuning.com
Ride
E89 Z4 35i 6MT M Sport
Any logs of the issue specifically? Adding 1% wgdc to the base shouldn't add that much boost so it definitely sounds like something is going on. What version of the boostbox? I've had much better results with the v3 personally.

I would assume the latest Boostbox. It was delivered couple months ago directly from MOTIV. The car went into the shop to get a fuel line fixed that was leaking so not able to visually check the version atm.

This is at 10.00% WGDC straight across for peak boost at 4k RPM+ with no adder. The maf req was not scaled all the way out which resulted in the overshoot when going into 4th. That part is understood.

https://datazap.me/u/bqtuning/log-1516258276?log=1&data=3-4-5-21-24-28&zoom=37-114


This is at 11.00% WGDC straight across for peak boost at 4k RPM+ with no adder.

https://datazap.me/u/bqtuning/log-1516258276?log=0&data=3-4-5-21-24-28&zoom=34-71

I could leave things at 10.00% and just increase boost with VANOS with smaller increments when increasing WGDC% to settle with
 
Last edited:

V8bait

Sergeant
Nov 2, 2016
484
743
0
Texas
You're only logging wgdc % and it's at like 65% in one at 4,000 for like 16psi and like 70% in the other for like 20psi, seems a bit drastic for only 5% difference I agree. But it's also telling me the signal isn't inverted, and seems like PID is doing a lot of the work with only 1% change to base. I tend to only log WGDC base and WGDC after PID on boostbox cars, especially the v3 ones since WGDC % gets inverted (has to be enabled in the tune with them).

The older boostbox versions were inconsistent for me. Some worked great, others would work then turn off or have other odd responses. I wouldn't blame INA0S, I'd check the boostbox first. FWIW I haven't had any issues with the v3 but you have to set the inverse flag to use them.
 
  • Informative
Reactions: dyezak

BQTuning

Corporal
Jul 18, 2017
174
139
0
www.bqtuning.com
Ride
E89 Z4 35i 6MT M Sport
I do have both wgdc banks checked as inverted in the xdf if this is what your referencing as the signal not being inverted ? The WGDC % I thought was showing like this cause the wgdc signal is inverted. So seeing 20% would be 80% when not inverted.
 

V8bait

Sergeant
Nov 2, 2016
484
743
0
Texas
I do have both wgdc banks checked as inverted in the xdf if this is what your referencing as the signal not being inverted ? The WGDC % I thought was showing like this cause the wgdc signal is inverted. So seeing 20% would be 80% when not inverted.

That is confusing then as the one with 65% would be 35%, and the one with 70% would be 30%, but yet it has higher boost by about 4psi or whatever. With the inverted flag I treat wgdc after pid as my total % with adders zero'd, it's easier to read that way for me at least.

Also if it's not for sure a v3 then maybe that's the issue right there, I believe only the v3 uses inverted signal.

Edited because I'm bad at maths
 
Last edited:
  • Like
Reactions: BQTuning

AntoanS4

Private
Aug 30, 2017
32
6
0
Ride
2011 335is
Any logs of the issue specifically? Adding 1% wgdc to the base shouldn't add that much boost so it definitely sounds like something is going on. What version of the boostbox? I've had much better results with the v3 personally.
How would you know which version is? Does it said somewhere or has a part#?
 

Twisted Tuning

Lieutenant
Platinum Vendor
Oct 25, 2016
962
877
0
New York
www.twistedtuning.com
Ride
N54 and N55 Cars
If the BB is more than a couple months old. It's probably not the V3. But there's a chance.


I personally havent had any issues with the BB except for the first version. But no issues since.
 

Twisted Tuning

Lieutenant
Platinum Vendor
Oct 25, 2016
962
877
0
New York
www.twistedtuning.com
Ride
N54 and N55 Cars
@V8bait @Twisted Tuning

The 335is car(s) that you tuned on the BB v3 do you know if they were native INA0S_IS before coming to MHD or they were updated via MHD to INA0S from a previous BIN/ROM ?


That, I'm actually unsure of. I've honestly never asked that of customers unless there was a specific weird issue we were troubleshooting.
 

V8bait

Sergeant
Nov 2, 2016
484
743
0
Texas
@V8bait @Twisted Tuning

The 335is car(s) that you tuned on the BB v3 do you know if they were native INA0S_IS before coming to MHD or they were updated via MHD to INA0S from a previous BIN/ROM ?

I've only tuned one boostbox on INA0S with the new box, and I have no clue. I would presume it had IN since it was a 2013 but I base that assumption on nothing.
 

BQTuning

Corporal
Jul 18, 2017
174
139
0
www.bqtuning.com
Ride
E89 Z4 35i 6MT M Sport
3 more 335is with Single Turbo popped up having the same issue. I dont know who tuned them, but two of them I know of are local to me. I haven't ran into any issue personally with I8A0S and IJE0S cars with the boostbox but when it come to INA0S cars overboosting issues are starting to become more common ? Anyone hearing anything else about this ?
 
Last edited:
  • Informative
Reactions: Torgus

jyamona

Captain
Platinum Vendor
Nov 7, 2016
1,292
1,660
0
Philly
Do you have access to an oscilloscope? I would really like to see the signal scoped pre and post BB on one of these INA cars with the issue. I do know the routines for boost control are pretty different in INA/IKM vs. I8/IJ.
 

BQTuning

Corporal
Jul 18, 2017
174
139
0
www.bqtuning.com
Ride
E89 Z4 35i 6MT M Sport
Do you have access to an oscilloscope? I would really like to see the signal scoped pre and post BB on one of these INA cars with the issue. I do know the routines for boost control are pretty different in INA/IKM vs. I8/IJ.

I got another ST 335is being dropped off to me this week. Will have it for the weekend. What oscilloscope do you recommend I should get for this thats cheap ? I dont have one on hand so need to get one.

Interesting you mention this though. A discussion came up last night about the signal/frequency pre BB on B30TO cars is difference from base B30 cars.