Mfactory exploded… Again

fmorelli

Lieutenant General
Staff member
Aug 11, 2017
3,650
3,448
0
56
Virginia
Ride
E89 Z4 35i, F10 535d
What happened to Michael @MFactory? He's the guy to speak with. Sounds like a bad batch came through. There have been a few issues here and there but mostly the diffs seem to be fine. I have one also.
 

Dread

New Member
May 28, 2022
5
0
0
What happened to Michael @MFactory? He's the guy to speak with. Sounds like a bad batch came through. There have been a few issues here and there but mostly the diffs seem to be fine. I have one also.
Again the way things are setup you don’t get to speak with anyone from Mfactory. Synchrotech is the point of contact. I’m here wondering dang could it be the dif brace that causes it to break but I know plenty ppl running dif braces. My car has fueling issues so not like I’m making a million horses here. And yea I’m higher than stock compression but I’m still not making 900tq in first gear…
 

SlowE93

Captain
Jul 2, 2017
1,390
1
762
0
Ride
E93
Again the way things are setup you don’t get to speak with anyone from Mfactory. Synchrotech is the point of contact. I’m here wondering dang could it be the dif brace that causes it to break but I know plenty ppl running dif braces. My car has fueling issues so not like I’m making a million horses here. And yea I’m higher than stock compression but I’m still not making 900tq in first gear…
You can get with Michael as @fmorelli pointed out. Have not talked/emailed with him since my axle broke and he replaced for me (he seems to be a good guy).
As far as torque, who knows what you are actually putting down in 1st🤷🏾‍♂️.
Also I do not know what actually caused your failure but, the Mfactory LSD is a unit they install using factory ring and pinion....also I know you said you filled with oil but how long did that sit before taking the pic ?
Looks kinda dry to me. Not much residue on the shattered parts..