Major timing corrections, super knock & misfires

Msport335

Specialist
Jun 7, 2018
97
24
0
Help me understand what's happening here.... N54 , 6AT, PS2, e50/meth tune.

Getting major timing corrections up to -8 deg and its random cylinders but noticing mainly 2 & 5. Ran the same tune 2 years ago with minimal to no correction so its definitely not in the tune either and I definitely have enough octane and meth to support 28psi & 12deg timing advance. aside from the major corrections I have been getting super knock and sometimes random misfires.

all parts s are new which include coded injectors, 2 step colder pugs gapped to .018, eldor coils etc...

I'm getting the impression it may be something causing a vibration at higher rpm causing the knock sensors to trip... crank pulley looks good and balanced while spinning. a few ppl have mentioned motor mounts....is this possible? and how can I guarantee that's the issue without throwing parts at it?
 

Msport335

Specialist
Jun 7, 2018
97
24
0
its been ongoing since the beginning of the season which I thought was bad fuel at first but the octane is definitely there to support the tune. This made me go ahead and change all the parts that one would think to change (thank god for FCP). anyhow, here's a log

 

Slowagon54

Specialist
Aug 21, 2020
53
13
0
Your STFT's are off and your rail pressure dips at the same time. And thats where it starts to knock and pull timing. Who is your tuner?

How about your fuel mods? Shotgun or Helix installed? And how about the LPFP setup?
 

Msport335

Specialist
Jun 7, 2018
97
24
0
No shotgun or helix...just DI with 2x 1000cc aem meth nozzles in charge pipe and stage 1 inline lpfp. Ran this setup for years without issue
 

Slowagon54

Specialist
Aug 21, 2020
53
13
0
Well, thats interesting. E50 on 28 psi and well over 12 degrees of timing indicates a high power output. This, with only a stage 1 inline pump is new to me. But never said its not possible.

If you ask me, it must related to the fuel delivery itself. STFT's are far away from each other... means one bank needs more fuel then the other to reach AFR target. Strange, but AFR itself is good to me. You should not see more than 10% of a differnece in STFT's as far as i know. Might be a simple airleak as well. You could try to re-tight the plugs, maybe they are loose.
 

Msport335

Specialist
Jun 7, 2018
97
24
0
Plugs are torqued to 18ft/lbs and are always nice and tight when I remove to check
 

typedRew

Sergeant
Feb 25, 2019
404
213
0
Ride
2009 335i xDrive
your short terms are all over the map, if this setup is an old setup, id go through that meth system

maybe your pump is tired, or nozzles are clogged, but its definitely not keeping up with fuel demand. maybe one nozzle is working and the other one is clogged or becoming so

Well, thats interesting. E50 on 28 psi and well over 12 degrees of timing indicates a high power output. This, with only a stage 1 inline pump is new to me. But never said its not possible.

2000+ cc of meth is a lot of fuel, im curious if the low system is just tired of supplying before the meth comes on and needs updated

edit: looking at the log,low side is fine, nevermind
 
Last edited:

Msport335

Specialist
Jun 7, 2018
97
24
0
yeah the low side even though its only a stg1 inline with new oem bucket has held up for many years. Just last week I removed the meth nozzles and they looked super clean....even tested the pump pressure and spray pattern out of the car and all looked good.... like I said before, I've been running the same setup for years without issue (although not the most ideal fueling setup, its simple and its worked). Dynojet was 665whp on the ps2 high flows a couple years ago. lpfp has never tanked.
I'm at a loss but still have the feeling its some sort of vibration happening maybe from motor mounts or driveshaft guibo..I don't know....I don't feel any sort of vibration while driving though.

i've also tried a straight e40 tune without meth and still get the corrections
 
Last edited:

typedRew

Sergeant
Feb 25, 2019
404
213
0
Ride
2009 335i xDrive
yeah the low side even though its only a stg1 inline with new oem bucket has held up for many years. Just last week I removed the meth nozzles and they looked super clean....even tested the pump pressure and spray pattern out of the car and all looked good.... like I said before, I've been running the same setup for years without issue (although not the most ideal fueling setup, its simple and its worked). Dynojet was 665whp on the ps2 high flows a couple years ago. lpfp has never tanked.
I'm at a loss but still have the feeling its some sort of vibration happening maybe from motor mounts or driveshaft guibo..I don't know....I don't feel any sort of vibration while driving though.

i've also tried a straight e40 tune without meth and still get the corrections
What about your short terms. Can you share that log
 

Msport335

Specialist
Jun 7, 2018
97
24
0
Short terms are in the log posted... there has always been that amount of variation between the banks for the longest time due to the charge pipe meth not having thr best distribution but its never been a concern to me or my tuner.
 

typedRew

Sergeant
Feb 25, 2019
404
213
0
Ride
2009 335i xDrive
Short terms are in the log posted... there has always been that amount of variation between the banks for the longest time due to the charge pipe meth not having thr best distribution but its never been a concern to me or my tuner.
I want to see the one without meth
 

Slowagon54

Specialist
Aug 21, 2020
53
13
0
The vibration is what you should be concerned about the most. If its really there, it could cause false knock... And if its knocking with the knock sensors desensitized it must be something serious. What did your tuner say?
 

Msport335

Specialist
Jun 7, 2018
97
24
0
Its hard to diagnose what the issue really is. At first he thought maybe i needed upgraed coils and the next day he said possibly a bad motor mount. Looking under the car I dont see signs of leaky mounts but when testing the foot brake and gas while in drive I do notice some shift ....but how much engine shift is allowable... and whats it really doing under load at 5k+ rpm
 

Msport335

Specialist
Jun 7, 2018
97
24
0
Strange thing though when testing my 94 octane pump only map I had minimal to no correction at about 20psi and 10deg timing . The e40 map practically running the same boost and timing had correction in the log i posted above
 

MoreBoost

Sergeant
Jul 27, 2017
334
135
0
Ride
335i
You've got meth and therefore fuel distribution issues. That's what the trims is telling you.
Don't run such high boost if cylinders are knocking. Superknock is bad. Very bad. Hopefully cylinders haven't been damaged.
You need a better fueling setup. Large nozzles are not great at atomising and charge pipe delivery is not good for even distribution. Its possible you may even have been spraying too much meth making ignition of the spark difficult.
 
  • Like
Reactions: Brule

Msport335

Specialist
Jun 7, 2018
97
24
0
You've got meth and therefore fuel distribution issues. That's what the trims is telling you.
Don't run such high boost if cylinders are knocking. Superknock is bad. Very bad. Hopefully cylinders haven't been damaged.
You need a better fueling setup. Large nozzles are not great at atomising and charge pipe delivery is not good for even distribution. Its possible you may even have been spraying too much meth making ignition of the spark difficult.
This posed the question as to why I was even getting corrections on the e40 map without meth so I spoke to a local bmw mechanic and he suspected its the hpfp amd it sort of made sense as my high pressure seemed to dip lower recently and is probably not supplying the fuel it needs to ..with or without meth. New hpfp should be here Monday.
 

Mvaccarelli01

Specialist
Apr 18, 2020
93
32
0
you are going from fuel mode -2 to fuel mode- 6 post shift. ask your tuner what this means something is happening with the car.