Technical Fuel Mode 22 and 2k+ Rail Pressure at Idle Issue

Raptor001

New Member
Apr 30, 2022
9
0
0
Anyone know what fuel mode 22 and a surging rail pressure at idle means? Rail pressure oscillates between 680ish to over 2100psi at idle and changes from Fuel mode 2 to 22 when the rail pressure spikes and then changes back to 2 when rail pressure comes back down to normal. Is this an injector issue? My bank 1 afr is also slow to respond when lifting off throttle, i.e., bank 2 afr goes to 234 when lifting off throttle but bank 1 doesn't reach 234 or reaches it much slower than bank 2. Injectors are Index 12 and almost 2 years old. Spark plugs are brand new, coils are b58 coils and 2 years old. HPFP is probably the oldest part on the car and was replaced in 2015. Car is 2009 N54 335xi. Thoughts?
 

carabuser

Lieutenant
Oct 2, 2019
849
1
745
0
UK
Ride
Z4 35i & 335i
No idea. I'd have to look at that triggers for injector adaptation to figure that out and I don't have the time just now.

I'd start by checking the injector calibration values are set in the DME. Then resetting the fuel related adaptations and getting some logs during normal driving.

It does seem like you have an issue in bank 1. Try switching injectors between banks and see if the lazy AFR follows.
 

zomski101

Private
Dec 28, 2019
47
8
0
Ride
335i
I've had the same "issue" for 2+ years now and since I have the helix 3x I can hear the chatter from it when pressures rises to 2100psi. Maybe it occurred before I had the helix but didn't take notice. Happens all the time after highway speed cruising when I come to a stop. It varies how long it stays in fuel mode 22, sometimes it oscillate other times it's pegged at 2100psi+ until i give it gas and/or start moving. Noticed it was in fuel mode 22 longer when I cruise at higher speeds for a long time.

 

zomski101

Private
Dec 28, 2019
47
8
0
Ride
335i
Never was to concerned about this cause I've been through 4 sets of index 12 injectors and have used inpa or protool to code them. Also on my third hpfp, replaced lpfp sensor, multiple other things and this "issue" always occurs after prolonged highway speeds.

 
Last edited:

Raptor001

New Member
Apr 30, 2022
9
0
0
My car seems to go to fuel mode 22 when in park and neutral although I think I've heard it happen when I come to a stop at light and have to wait a while. I can make it go to fuel mode 22 on command when idling for a while in park or neutral. Afrs oscillate a little when the fuel mode switches but I don't think this is causing my surging at low loads. Not even sure its injector issue at this point or just normal. The injectors can really start to chatter alot at a higher pitch when the fuel rail spikes in fuel mode 22.
 

carabuser

Lieutenant
Oct 2, 2019
849
1
745
0
UK
Ride
Z4 35i & 335i
So this sounds like another problem related to the Helix system.
They spent a lot of time on the hardware but neglected the software implementation.
 

1DCTN54 Matt

New Member
Aug 31, 2021
4
0
0
Ride
135i DCT swap pure hi flo
Don't know, I don't have helix as I'm PI.
hey what’s your IG im having same issue im thinking bad 02’s or too much boost on this hpfp and shot out.. wanna know what your outcome is. also i just serviced injectors and did plugs.. no leaks and car yanks fine 25-23psi like no issues
 

Jern54

Sergeant
Oct 18, 2019
287
1
166
0
Netherlands
Ride
E91 N54 335i
I experience the same on my car. Once I give a bit throttle, pressure is dropping again for a few seconds.
Fuel mode 22 is most of the time a result when the mixture is too lean on idle.
I experience this when I have E85 in the tank.
On pump gas no issues so far.
 
  • Like
Reactions: 1DCTN54 Matt

1DCTN54 Matt

New Member
Aug 31, 2021
4
0
0
Ride
135i DCT swap pure hi flo
I experience the same on my car. Once I give a bit throttle, pressure is dropping again for a few seconds.
Fuel mode 22 is most of the time a result when the mixture is too lean on idle.
I experience this when I have E85 in the tank.
On pump gas no issues so far.
yeah people years back saying flapper valve or other nonsense haha i mean i had the injectors serviced and flow tested at stryker but who knows how long they can really take a beating.. i’m for sure aimed at 02’s or injectors but 02’s are most likely highs at mileage part on my car. Ken from wedge would love to help… long as i’m tuned by him lmao no one seems to know but has seems to experienced this issue once or twice.
 

mj6234

Corporal
Nov 25, 2020
156
58
0
For those people with Helix, I am sure it is related to software changes needed after putting in the Helix. I tried to document my journey fighting the spikes at idle. I think I have it tamed, but it is exactly what is described above - particularly after highway drives and/or the AC being on.

 

Traf

Sergeant
Aug 3, 2017
341
196
0
Ride
135i
Never was to concerned about this cause I've been through 4 sets of index 12 injectors and have used inpa or protool to code them. Also on my third hpfp, replaced lpfp sensor, multiple other things and this "issue" always occurs after prolonged highway speeds.

How TF did you go through 4 sets of index 12 ? i've been runing my set of index 12 for 55 000km @ 650hp on E85 DI only, including a whole lot of track driving, albeit at lower power levels on the track. So far so good.

Regarding the issue, i've also had it when i first started using a single barrel. It's been gone for a long time now but i never knew exactly what was the issue. Maybe it was solved since i started using a IKM0S rom ? Idk really
 

zomski101

Private
Dec 28, 2019
47
8
0
Ride
335i
How TF did you go through 4 sets of index 12 ? i've been runing my set of index 12 for 55 000km @ 650hp on E85 DI only, including a whole lot of track driving, albeit at lower power levels on the track. So far so good.

Regarding the issue, i've also had it when i first started using a single barrel. It's been gone for a long time now but i never knew exactly what was the issue. Maybe it was solved since i started using a IKM0S rom ? Idk really
Miles and e85 I'm guessing, been tuned on e50 since 54k miles and it's currently at 250k miles. I seem to get 30-50k miles before my stft starts maxing out at high rpms followed by get lean fuel mixture codes a few miles later. Did contact my tuner to increase the fuel scaler but my rail pressure dropped too much, so I just end up replacing the injectors whenever that happens.