First time overheating scare

trapcoboss

New Member
Feb 19, 2018
2
0
0
Ride
2008 335xi, 1963 Impala
i worked all night last night and I sent my gf to the tire shop to replace my fronts because I was too tired and I had to watch my kids.. anyhow she called me from the tire shop and said my car was leaking antifreeze. Apparently my radiator drain plug failed she drove it home with no coolant my 08 335xi was hot!! And so was I ! I let it cool off and replaced the drain plug (I actually had an extra) filled her back up and started it it made a horrible whistling sound and was billowing white smoke out the exhaust.. I thought for sure it was a head gasket. It was idling terrible too. Me being the hard head I am kept messing with it. I have new sparkplugs because I run 100 octane a lot and yea I race a lil bit. (Jb4 tuner) any way I changed the variable valve timing sensors because I didn’t get why it was idling like shit. And I figured it couldn’t hurt.. I drove around for awhile clearing codes and the smoking went away the idle started to clear up and now it runs fine. I’m amazed and confused at the same time. Was it hot boiling oil in the turbo lines that made that whistle? Why was I smoking like a blown head gasket? And how the hell did it just go away?
 

Rob09msport

Major
Oct 28, 2017
1,929
664
0
Monroe CT
Ride
09 335i msport le mans 18 x5
I think the sound may have been all the air venting from the coolant system and when engine gets that hot things start burning off like oil residue, carbon and gunk in intake, who knows but def count this as a win.
 

Rcboosted2007

Lieutenant
Jan 28, 2018
902
89
0
Parts unknown
Ride
07 335i
Lol

It can be a 1/2 mile run on war.

i worked all night last night and I sent my gf to the tire shop to replace my fronts because I was too tired and I had to watch my kids.. anyhow she called me from the tire shop and said my car was leaking antifreeze. Apparently my radiator drain plug failed she drove it home with no coolant my 08 335xi was hot!! And so was I ! I let it cool off and replaced the drain plug (I actually had an extra) filled her back up and started it it made a horrible whistling sound and was billowing white smoke out the exhaust.. I thought for sure it was a head gasket. It was idling terrible too. Me being the hard head I am kept messing with it. I have new sparkplugs because I run 100 octane a lot and yea I race a lil bit. (Jb4 tuner) any way I changed the variable valve timing sensors because I didn’t get why it was idling like shit. And I figured it couldn’t hurt.. I drove around for awhile clearing codes and the smoking went away the idle started to clear up and now it runs fine. I’m amazed and confused at the same time. Was it hot boiling oil in the turbo lines that made that whistle? Why was I smoking like a blown head gasket? And how the hell did it just go away?
Check out the pump bleed procedures. Cavitation will eat that pump up. Also check if you have any “speed deviation “ codes. God speed my man.
 
Last edited by a moderator:

trapcoboss

New Member
Feb 19, 2018
2
0
0
Ride
2008 335xi, 1963 Impala
I’m pretty sure I now have a crack in the vc. I started her up the next morning and it whistles like a bitch and running like shit. I’m wondering if it’s a blown head gasket or warped head. I didn’t win. I’ll see after a compression test.? And why was my post hard to read? It’s in plain english