e90 Flickering Halos?

enfiftyfour

New Member
May 24, 2023
9
0
0
Hello all, my headlights are acting dumb and I'm not too sure why.
BACKSTORY
I have an 09 e90 (LCI) that I just DCT swapped.
In the process of coding/programming all the DCT stuff, I noticed that I had a driver side fog light malfunction that would not go away. (I don't have driver or passenger fog lights, but for some reason, I never got a warning for passenger side.)
Although all fog light checks were disabled through protocol, the malfunction remained, so I went ahead and deleted fog lights completely from the VO. (BIGGEST REGRET OF MY LIFE)
SYMPTOMS
It was successful, fog light malfunction disappeared from the idrive screen. But now we have an issue, my headlights stopped working for the most part.
Low beam/high beam bulbs do not work, blinkers occasionally work, and the halos flicker.
Now here's the weird part, in ignition/accessory mode, the halos don't flicker. They stay on as they should. When engine is running, they flicker and then eventually stop turning on completely. Here's the kicker, when I apply throttle, they flicker. Once I get off throttle, they stop flickering. what..? Sounds like a voltage issue?
THINGS IVE DONE/DIAG
I've replaced the headlights with known working oem headlights, same issue.
I've checked every fuse in the fuse box as well as the big fuse and relay in DME box, whether it was relative to headlights or not, no good.
I've replaced the FRM with a known good one, same story except my halos would occasionally flicker red. (what..?)
I've flashed back to factory with my original and donor FRM which includes me re-adding the fog light coding to the VO, no good except the fog light malfunction came back and is currently still present.
I looked into the headlight harnesses despite never having an issue before this, everything checks out.
The harness is continuous getting the proper voltage where it needs to be. (I think)
Warm and cold checks have been disabled, enabled, defaulted, all the same story. Battery is registered and brand new oem, reading the proper voltage.
NOW WHAT?
Every shop/electrician that has looked at my 90 has not been able to diagnose the issue. There aren't any codes being thrown in the DME, CAS, OR FRM and I'm not sure what else to do. I'm not sure if I should waste my time taking it to the dealership because I'm not sure if they'll work on a car this modified (ST, DCT, gutted, etc). Perhaps I'll give them a call.
Sorry for the long thread but I didn't want to leave out any details. Any help is appreciated considering I've been dealing with this since April!
Thanks in advanced.
 

Krampus

Specialist
Aug 8, 2020
64
31
0
Finland
In what rev range did you measure the voltage? Measuring at idle alone does not give the whole picture.
 

MRCW

New Member
Feb 3, 2023
3
0
0
There are known issues related to the headlight switch. I had an issue with my 2013 X1 (E84) that a bad headlight switch caused the lights to flicker and blink.
Perhaps that could be an issue
 

enfiftyfour

New Member
May 24, 2023
9
0
0
SOLVED FOR ANYONE WITH A SIMILAR ISSUE!!
the lights flickering after doing coding for DCT swap was completely unrelated and merely a coincidence.
my headlights were busted after hours of diagnosing lol. as i previously mentioned, the "known good" headlights that i tested during my diag were not actually good, the bulbs were bad. i replaced my flickering headlights and installed new bulbs+ballasts and havent had issues since!
moral of the story: dont take someone elses word when they say "known good" unless you've seen it with your own eyes. had the "known good" headlights worked properly, i wouldve found my issue months ago!