E89 Z4 HPFP nightmare

sjobusen

Lurker
Aug 8, 2021
16
0
0
I have the 535 lpfp in my z4 and are monitoring my pressure. When I start my car I have 72 psi pressure, but after a few seconds it drops to 68psi at idle.
At WOT the low pressure is dropping a little more to about 62 psi.
This is with 17t turbos, e30 fuel mix.
Is there a way to raise the lpfp pressure to 72 psi all the time?
 

Neg89

Private
Jul 4, 2021
46
4
0
I have the 535 lpfp in my z4 and are monitoring my pressure. When I start my car I have 72 psi pressure, but after a few seconds it drops to 68psi at idle.
At WOT the low pressure is dropping a little more to about 62 psi.
This is with 17t turbos, e30 fuel mix.
Is there a way to raise the lpfp pressure to 72 psi all the time?
I am just thiking of my problem right now. I want to run pump fuel only on my pure stage2 cast. How do you monitor LPFP on Z4. I just bought fuel line and sensor from 335.
I have the 535 lpfp in my z4 and are monitoring my pressure. When I start my car I have 72 psi pressure, but after a few seconds it drops to 68psi at idle.
At WOT the low pressure is dropping a little more to about 62 psi.
This is with 17t turbos, e30 fuel mix.
Is there a way to raise the lpfp pressure to 72 psi all the time?
 

sjobusen

Lurker
Aug 8, 2021
16
0
0
I am just thiking of my problem right now. I want to run pump fuel only on my pure stage2 cast. How do you monitor LPFP on Z4. I just bought fuel line and sensor from 335.
I just added a old style pressure gauge with a hose into the 335 fuel line... instead of the oem sensor. Just putting the gauge at the windscreen on my wiper when I want to look at it.
 

Neg89

Private
Jul 4, 2021
46
4
0
O.I understand.IS there known e89 with added LPFP sensor that can be logged thru mhd or at least observed real time.
 

Neg89

Private
Jul 4, 2021
46
4
0
Hello. So i upgraded to pure stg2.cast turbos. waiting to get Wagner evo3comp Fmic. Tuner says this
"" normaly railpressure is no problem up to ~550-600hp if hpfp is in good condition and lpfp is upgraded.""


so i am confused ,New LPFP535pump, new hpfp,new regulator/filter, different ekpm3 =no difference in HPFP drops at midrange. Is there any gremlin,electeronic issue.?

Bau the way,do someone make the lpfp running with PROTOOLS, to epty tank. I was doing so,presure was barely better than running on plain grawity .