Dct shifter retrofit f30

ccfj1

Specialist
Jul 26, 2018
63
53
0
UK
Ride
bmw e92 n55 335i Sport manual
Ok, I have a small update.

I had no joy at all trying to get a dct shiter to work (I know i know...).

So bought a shifter from a Bmw F85 F86 x5M x6M Gear Selector #7849286 and bingo this works plug and play. As this car uses a non DCT gearbox i thought that it would work with my 8 speed auto box, and it does.

All functions work,

Reevers inc lights
Neutral inc lights
Drive, no lights when manualy selecting (by hand) into D/Smode), however lights when using the paddles. Manual shifting M1-M8 via gearknob also works 100%

fdm works (so eco, com, sport and sport+) gearbox, suspension and steering all work as should in com and sport mode.

Cluster works as in diplaying correct gear D/N/P and M1-M8, when stopping car just leave in D and switch off it will go into P mode straight away (it will also do it in N but you get the message in cluster and nav display saysing car in netural etc).

Not and any problems with the P error so far.

However, 3 things,

1: I get the gear slector error (no big deal i can code that out).
2: No light when in drive mode (manually selected).
3: no S1-S8 on clutser (only D or M1-M8).

I suspect that the "car" does not know what mode its in, com (M) or sport, so defaults to M (as displayed and gear box acts as if in man mode (not sport+).

If there was a way to code the GWS or car to "know" what mode it was the gws would display the correct lighs in D mode.

Any one have any thoughts.

Personally no lights in D while annoying, (and coding out the error) is not a bad trade off for the benift of having the M shifter...

BTW doing this retrofit in a F25 x3 335D M-sport. (I have a M cluster waiting to go in too...) but want to get the shifter working first.
 
Last edited:

Olza

Corporal
Feb 2, 2020
229
223
0
Minsk, Belarus
Ride
BMW M240 xdrive
Wait a bit. I’ll buy f80 shifter soon and try to retrofit it to mine f22.
I’m able to code 8HP calibrations now and can see differences between f85 and f22 parameters.
 

ccfj1

Specialist
Jul 26, 2018
63
53
0
UK
Ride
bmw e92 n55 335i Sport manual
Ok cool.

Just a small update after driving around for a little while.

1: shifter works for reverse, Neutral and drive. lights for R/N work 100%. works in all eco/com/sport and sport+

when in D mode, (all the way right) the lights do not work and while using manual shift (up and down by hand), the gear displays on the cluster, (and the lights lightup on shifter), the gear box however does not actually shift, when using the paddles, all perfect, and lights light up on shifter.

however, if in drive and i use the paddles then imeadiatly use the shifter (up or down), then the gearbox will shift.

I know that the x5m shifter does not have a M/S mode (just a D mode, even though its the same gearbox), then the GWS (shifter module) does not "know " what mode to be in M or S, i think its defaulting to M (but not enough to tell the system).

So, i was thinking if i can code the car to only have D mode ( and turn off/disable M/S) modes then I suspect that the GWS will start working 100%.

if anyone had the deafult coding for the 2014-2017 x5m icm and transmission coding, then I think we might be able to crack it.

any help would be great.

If my car did not have SAT (2TB), i suspect that it would have been plug and play!!
 

Olza

Corporal
Feb 2, 2020
229
223
0
Minsk, Belarus
Ride
BMW M240 xdrive
IMG_3247.jpeg

I made it. One issue is for Auto mode lights you need send special code to kombi (as in M cars). So ordinary kombi shows C instead of D. Manual works, no errors.
This is only 8HP50/75 calibration retune.

While reflashing I saw that “box” around D can flash, so my goal now is to remove it and make look more like M3/4 big mode or gear number on kombi.
 
Last edited:

ccfj1

Specialist
Jul 26, 2018
63
53
0
UK
Ride
bmw e92 n55 335i Sport manual
Nice, can you share what you hav done, for others please
 

Olza

Corporal
Feb 2, 2020
229
223
0
Minsk, Belarus
Ride
BMW M240 xdrive
Are you able to rewrite calibration data to 8hp? I use custom full flash data with XHP flash license.
 

JZEE12

Lurker
Oct 14, 2020
21
0
0
Ok cool.

Just a small update after driving around for a little while.

1: shifter works for reverse, Neutral and drive. lights for R/N work 100%. works in all eco/com/sport and sport+

when in D mode, (all the way right) the lights do not work and while using manual shift (up and down by hand), the gear displays on the cluster, (and the lights lightup on shifter), the gear box however does not actually shift, when using the paddles, all perfect, and lights light up on shifter.

however, if in drive and i use the paddles then imeadiatly use the shifter (up or down), then the gearbox will shift.

I know that the x5m shifter does not have a M/S mode (just a D mode, even though its the same gearbox), then the GWS (shifter module) does not "know " what mode to be in M or S, i think its defaulting to M (but not enough to tell the system).

So, i was thinking if i can code the car to only have D mode ( and turn off/disable M/S) modes then I suspect that the GWS will start working 100%.

if anyone had the deafult coding for the 2014-2017 x5m icm and transmission coding, then I think we might be able to crack it.

any help would be great.

If my car did not have SAT (2TB), i suspect that it would have been plug and play!!
Hey with the x5m gws does it keep you in manual mode or does it kick you out ? If you stay in gear for to long ?
 

slobo7x

New Member
Mar 29, 2023
9
1
0
Yes please post what coding/flashing you have done.
Car will not stay in manual mode because the transmission is not truly in “sport”mode, the factory shifter engages sport mode by moving the selector to the left where as M one is to the right.

We can flash tcu, if needed, but can’t mess much with gws from what I’ve seen
 

Olza

Corporal
Feb 2, 2020
229
223
0
Minsk, Belarus
Ride
BMW M240 xdrive
There are no errors, except one from gws - “no drivelogic button”. That can be fixed, too.

Now you have no sport (S) mode. You only have Auto and Manual (or temporary manual via TIP).
 

JZEE12

Lurker
Oct 14, 2020
21
0
0
There are no errors, except one from gws - “no drivelogic button”. That can be fixed, too.

Now you have no sport (S) mode. You only have Auto and Manual (or temporary manual via TIP).
Hi can you share how this was coded I’d like this to work as well I have XHP also what parameters have you changed
 

Olza

Corporal
Feb 2, 2020
229
223
0
Minsk, Belarus
Ride
BMW M240 xdrive
@JZEE12 this is for 8HP50 from my own XDF. but you can see offsets in full dump and values.

1699961103146.png

1699961151001.png

1699961196939.png


Leave 0x20684C to 00 to have return to Auto mode from temporary TIP Manual.
 

ArturDwora

New Member
Jul 3, 2023
3
0
0
Hey guys,

Olza, well done on the findings! It would be interesting if you could share how you manage to pull the coding from the gearbox and then code it via XHP.

Little update from me as to what I think will fix most issues with a different approach. Best bet in my case to solve everything is to create a module that will sit between the shifter and the can bus. This module should modify some of the data sent through the can bus to and from the shifter imitating the old shifter. Since most of the functionality works I’ll be left with the tiniest bit to do just to make the shifter fully functional like in the M cars.

I bought an F80 M3 shifter and it mostly works e.g. Reverse, Neutral, Drive (does not light up tho unless you trigger manual mode with the paddles). The DCT shifter is missing the park button which means that it does not send data via can bus to let the gearbox know the current status of the park button which I think is the culprit why you get the error message. After that you just handle changing gears (up/down) and sport mode. All this might still leave me with the issue of paddles not working in M mode but I’ll cross that bridge once I get to it and that seems to be triggered by the missing drivelogic.

If there’s an easier way I’ll definitely go with it however this seems like the simplest solution in my case.

While I’m writing this I’m also thinking this is a worth an ask. Do you guys know how to code out the warning when switching the car off in neutral?

Thanks to Angus Gratton (https://www.projectgus.com/2022/06/bmw-f-series-gear-selector-part-one-failures/) most of the decoding of the F series shifter has been done and it’ll be a lot of help.

Thanks!
 

ccfj1

Specialist
Jul 26, 2018
63
53
0
UK
Ride
bmw e92 n55 335i Sport manual
Hi All,

Merry christmas.

Just a small update.

I have a fully working gearbox emulator, (from link above) 3-4 months work even with all the help, working out the CRC was the hardest thing.

It works in all modes and all the led and unlock/park buttons work as should (non gws selector, as per link).

This is all done by reading the packet code 197, this carries all funtion requests to the gearbox.

I just emulate the correct responce and it works. I have worked out how to make and select park with a seperate button, and this aslo works, I have modded the dct speed button to do this.

I have plugged in the M-gws and this does not use the packet code 197 option, not sure why but it does not, i suspect that it uses something else (like the fds??).

I have a can anyalizer and will take some readings from the car, The m gsw i'm using (from the x5m) dos not drop me out of drive, it works as it should, it just does not display drive/sport I have worked out the 3FD code for both drive and sport, this works on the bench.

Depending on what I get from the pt-can dump, i will see whats possible, but i suspect that the minimum i will do us park button and correct led display for drive, i will also look at the sport as well.

will update when i have some more answers.

P.S, i will try and work out the correct codes to let the gearbox know the current status of the park button.
 

ccfj1

Specialist
Jul 26, 2018
63
53
0
UK
Ride
bmw e92 n55 335i Sport manual
Hey with the x5m gws does it keep you in manual mode or does it kick you out ? If you stay in gear for to long ?
stays in drive.... i have been using for a few months not and not once has it not worked....
 

wesleyredhat

New Member
Jan 19, 2024
3
0
0
Hi, I'm the same, any progress with the emulator?
 

Attachments

  • IMG_3115.jpeg
    IMG_3115.jpeg
    264.2 KB · Views: 16
  • IMG_3113.jpeg
    IMG_3113.jpeg
    284.8 KB · Views: 12

ccfj1

Specialist
Jul 26, 2018
63
53
0
UK
Ride
bmw e92 n55 335i Sport manual
Yes. Small update.

When in drive mode the 197 code is 88 which is not within the range of turning on the d/s led on the gws. I’m looking at a way to fix this so all lights on the gws work.

2nd problem is the park button when I tried to over write the code to the gws it would not play ball so will be looking more I to that.

As said above it would be nice to emulate the park button (or lack of it) status so that the error does not get thrown up (when not coded out) if anyone has any glues, post up.

3rd problem is the manual up/down shift. Personally this is not to much of a problem for me but I will keep on looking at it.

There is an also the problem of the fact that the gws has 2x pt-can bus connections so it’s a belt and braces approach to the gearbox can bus signals. I suspect that the signals must be seen on both canbuses for it to actually work. But as yet this is a guess. I will keep looking through the can bus message dumps.

As for the emulator. It’s ongoing it’s still in development mode at the moment.

I work full time so my spare time is limited.
 

wesleyredhat

New Member
Jan 19, 2024
3
0
0
I'm an xHP user on my F30. I would like to know if it is possible when the vehicle is in Sport mode for the engine to drive, if there is a possibility for the transmission to also go directly to Sport.

Is there any way that when the DME enters Sport, the EGS also enters Sport mode automatically.

If I could achieve this with xHP, it would solve my problem with gear selector
 

wesleyredhat

New Member
Jan 19, 2024
3
0
0
Yes. Small update.

When in drive mode the 197 code is 88 which is not within the range of turning on the d/s led on the gws. I’m looking at a way to fix this so all lights on the gws work.

2nd problem is the park button when I tried to over write the code to the gws it would not play ball so will be looking more I to that.

As said above it would be nice to emulate the park button (or lack of it) status so that the error does not get thrown up (when not coded out) if anyone has any glues, post up.

3rd problem is the manual up/down shift. Personally this is not to much of a problem for me but I will keep on looking at it.

There is an also the problem of the fact that the gws has 2x pt-can bus connections so it’s a belt and braces approach to the gearbox can bus signals. I suspect that the signals must be seen on both canbuses for it to actually work. But as yet this is a guess. I will keep looking through the can bus message dumps.

As for the emulator. It’s ongoing it’s still in development mode at the moment.

I work full time so my spare time is limited.
I am totally interested in the emulator, I would be very happy to have it and I would pay the price