Dct shifter retrofit f30

JZEE12

New Member
Oct 14, 2020
7
0
0
Got everything to work but can’t see d/s mode when put into drive should be a coding thing any help ?
 

JZEE12

New Member
Oct 14, 2020
7
0
0
I disabled the shifter malfunction warning so It shifts and all works fin
That certainly sounds like a coding task... I don't have an F series, but it seems odd that you aren't getting any codes for shifter?
I removed the shifter malfunction error with coding however just stuck on not seeing the d/s light up when pushing the shifter to the right to engage drive.
besides all else is fine n,r,p, and the shifter works no problem when pulling the paddles down it all illuminates as it should only d/s does not light up when in drive.
would anyone know what kind of coding needs to be done to have the shifter illuminate when going into d/s ?
 

JZEE12

New Member
Oct 14, 2020
7
0
0
Isn't that covered in the M3 DCT retrofit threads?

Coding KOMBi and such?
I’ve been searching non stop maybe you can give me a hint as to what thread your talking about ? The F series Kombi has different menus
 

aus335iguy

Major
Nov 18, 2017
1,907
647
0
Down under
Ride
335i DCT 2009
I disabled the shifter malfunction warning so It shifts and all works fin

I removed the shifter malfunction error with coding however just stuck on not seeing the d/s light up when pushing the shifter to the right to engage drive.
besides all else is fine n,r,p, and the shifter works no problem when pulling the paddles down it all illuminates as it should only d/s does not light up when in drive.
would anyone know what kind of coding needs to be done to have the shifter illuminate when going into d/s ?
Does the stock shifter have this feature? If not it might not have that circuit in the GWS.
 

JZEE12

New Member
Oct 14, 2020
7
0
0
Does the stock shifter have this feature? If not it might not have that circuit in the GWS.
The stock shifter has the m/s light however it is to the left and not to the right to push it.
normally on an Fx car the shifter should show the middle light and the d/s illuminate when in drive however mine does not.
here are some photos of the problem R,N, park all light up and when the paddle is pressed it goes into the correct d/s mode with the + and - .
But when In drive it just gives backlight but no light on the shifter to say it’s in drive.
 

Attachments

  • image.jpg
    image.jpg
    247 KB · Views: 23
  • image.jpg
    image.jpg
    260.9 KB · Views: 12
  • image.jpg
    image.jpg
    238 KB · Views: 11
  • image.jpg
    image.jpg
    237.4 KB · Views: 10
  • image.jpg
    image.jpg
    211 KB · Views: 17

aus335iguy

Major
Nov 18, 2017
1,907
647
0
Down under
Ride
335i DCT 2009
I wrote up a pin out for the old M3 knob but that shifter you have is all can bus as far as I knew.
can you explain how you got it to work with your gearbox? Is the GWS still stock with a different knob?
 

aus335iguy

Major
Nov 18, 2017
1,907
647
0
Down under
Ride
335i DCT 2009
 

JZEE12

New Member
Oct 14, 2020
7
0
0
I wrote up a pin out for the old M3 knob but that shifter you have is all can bus as far as I knew.
can you explain how you got it to work with your gearbox? Is the GWS still stock with a different knob?
Mine is completely stock I found somewhere ona forum and they got the shifter to stop giving the shifter malfunction message. It kept throwing it every time the car would come to a complete stop. So I did this as far as coding with the BimmerCode app.

  • instrument cluster (Kombi)
  • expert mode
  • 3001- CC_ID_SPERRE
  • CC_AKTIVIERUNG_7
  • Turn it to AUS and not EIN
  • Code done
 

JZEE12

New Member
Oct 14, 2020
7
0
0
As far as this diagram the F series of car has this type of shifter connector going to the gws. Could it be a coding thing or a wire thing?
It seems as if the car does not know the d/s that the m shifter has and just defaults to the backlight on the shifter. Because when pulling the paddle down the shifter reacts as it would normally if the car where in manual mode.
 

Attachments

  • F4EFC8C6-A76C-4FE7-8520-6A65D3F63B8D.jpeg
    F4EFC8C6-A76C-4FE7-8520-6A65D3F63B8D.jpeg
    480.7 KB · Views: 16
  • 497987DD-1542-4440-A268-0701814D7DEA.jpeg
    497987DD-1542-4440-A268-0701814D7DEA.jpeg
    265.6 KB · Views: 25

staffordshirebmw

New Member
Dec 24, 2020
2
0
0
The stock shifter has the m/s light however it is to the left and not to the right to push it.
normally on an Fx car the shifter should show the middle light and the d/s illuminate when in drive however mine does not.
here are some photos of the problem R,N, park all light up and when the paddle is pressed it goes into the correct d/s mode with the + and - .
But when In drive it just gives backlight but no light on the shifter to say it’s in drive.
has anyone managed to sort this issue as im having the same problem
 

JZEE12

New Member
Oct 14, 2020
7
0
0
has anyone managed to sort this issue as im having the same problem
Hi yes got to the bottom of it seems as if you need to buy a f87 m2 shifter non competition for it to work. Since the problem with the lights is not a coding thing but actually the shifter it self it does not know what drive mode. Only the m2 non comp one will work since there is no drive logic on the m2 non comp just like the f32/f30.
attached is the one I got this is the correct part number and mine works now.
 

Attachments

  • B7FBDBE0-8F7A-42E1-8665-3B966C978A9E.png
    B7FBDBE0-8F7A-42E1-8665-3B966C978A9E.png
    436.7 KB · Views: 14

staffordshirebmw

New Member
Dec 24, 2020
2
0
0
Hi yes got to the bottom of it seems as if you need to buy a f87 m2 shifter non competition for it to work. Since the problem with the lights is not a coding thing but actually the shifter it self it does not know what drive mode. Only the m2 non comp one will work since there is no drive logic on the m2 non comp just like the f32/f30.
attached is the one I got this is the correct part number and mine works now.
could you please send a video of yours all working and was there any coding needed