Cylinder 1 and 6 plugs black

pysical

Sergeant
Jun 16, 2017
471
108
0
Ride
2009 335xi E90
Replaced all plugs. 30 miles later 1 and 6 are black. Look rich black. Index 12 injectors are new. Even swapped injectors around just in case. Anyone have any other ideas on what to try? I have also played with coils.
 

Rcboosted2007

Lieutenant
Jan 28, 2018
902
90
0
Parts unknown
Ride
07 335i
Yikes
-Check those AFRs.
-Check for blow by with a compression test. - Post up some pictures of plugs for the community to help analyze.
- diagnostic info like fueling details, ex type,tune, mods, mileage,codes.
 

pysical

Sergeant
Jun 16, 2017
471
108
0
Ride
2009 335xi E90
Car has been ran a little lean before.

I did a compression test and all the cylinders came back at 165 equal. Tested multiple times on different days even.

No codes. Have PI in intake. FBO. Running E85.

Since replacing the intake and changing the PI from MMP gen 1 plate to the BMS intake I am having some rich conditions (-34%) but afrs are not going high. So not sure if that is from rich or not.

Also, i have a huge oil consumption. 1 qt in about 350 miles. I did have a rear main seal that was pushed out on the bottom that I just got fixed. No oil spots where I parked so if it was coming out there it had to blow away while driving. Removed the o2 sensors and looked into turbos and all is dry. No leaks anywhere including OFH and VC. No smoke either. No lose of power.

I swapped injector 1 with 5 and 6 with 2. The black did not follow the injectors. My last idea is to swap PI injectors and see if it is indeed a rich plug from PI.
 

Attachments

  • spark plug.jpg
    spark plug.jpg
    106.1 KB · Views: 114

ShocknAwe

Captain
Jan 24, 2018
1,489
1
736
0
Charleston, SC
Ride
N54/3 1er ///Mutt
I know you said no leaks but... No cracks in the VC? That will increase blowby and oil consumption and can cause black plugs. Dealing with that now on my car.
 

pysical

Sergeant
Jun 16, 2017
471
108
0
Ride
2009 335xi E90
I use HPI injectors.

If I have cracks they are small enough to not leak oil. Not leaking any oil up top of engine. Turbo does have a little dried up spot of oil under the front CHRA vband. Possibly just a little extra oil from install came out and dripped down.

I did get the rear main fixed and reset my counter to see how long it takes for it to drop. Won't be another week or so of me driving before I find out if that did anything though.
 

pysical

Sergeant
Jun 16, 2017
471
108
0
Ride
2009 335xi E90
Gonna swap the PI injectors around and see if 1 and 6 are just dumping fuel and making the plugs rich.
 

colinod

Private
Aug 13, 2017
48
20
0
Ride
2007 e92 335
im not knocking hpi injectors but they are refurbed and modded to hell so i'd try some more pricey pi injectors
 

pysical

Sergeant
Jun 16, 2017
471
108
0
Ride
2009 335xi E90
Just gonna update this just in case others run into same issue. Turns out cylinder is cracked. Time to get some sleeves.