Correcting the variable redline to 7k RPM in your M3 cluster

LMB335is

Sergeant
Apr 12, 2017
286
186
0
FOB FL
Ride
13 335is
I want to post this up here first before anywhere else because I'm not sure how the values are derived and to throw the guys that have already done so much to move this retrofit along a small bone. Hell, with all the smart guys in here it may already be common knowledge but I found a utility, Perfekt Toolbox, which can do custom nettodat coding for the KOMBI. I don't think I can upload a zip here but I'll post a mega link to it. There's no tutorial for it, at least not one I can find so make sure you back up everything before you start playing with it. By changing the starting position offsets and motorsteps in the tach and warning zone menus you can adjust the redline to wherever you want it. You may be able to remove the error in the speedo as well with the right adjustments. This is just a pic of what the tach menu looks like. Props to @Hpaula for giving me access to his values so that I could correct mine.
https://mega.nz/#!ndxXEbKK!abfIqRbmdSbKPnOjE4BblGZHTg-s8zZX_AMMv1SjZNs
Perfekt_BILL.jpg
 
Last edited:
  • Like
Reactions: island road

doublespaces

General of the Army
Oct 18, 2016
8,937
4,143
0
AZ
Ride
2009 E93 335i
Good one, hopefully other people doing the cluster swap will find this helpful.
 

dyezak

Major
May 4, 2017
1,768
1,515
0
Plano TX
Ride
335is
I'm not sure I understand the problem. My M3 KOMBI functions perfectly and shows a 7k RPM red line.
 

LMB335is

Sergeant
Apr 12, 2017
286
186
0
FOB FL
Ride
13 335is
I'm not sure I understand the problem. My M3 KOMBI functions perfectly and shows a 7k RPM red line.
That's interesting. In mine and a couple other instances I know of, the cluster functions fine it's just that the redline parked itself at 7.5 k. There's a thread on the one of the other forums of a guy putting the M3 cluster in his diesel and having to use custom nettodat coding to bring it down to 5k rpm. If you have a chance sometime could you pull the KOMBI up in NCS Expert and save the nettodat pop up screen? I'd be interested in comparing your values to my pre and post coded values.

On a side note though, this utility can also be used to eliminate the error in the analog speedo and adjusting the swing if you switch from a mpg gauge to oil temp.
 

NoQuarter

Major
Nov 24, 2017
1,534
954
0
Indiana, USA
Ride
Z4 35is, 535xi, X5 35i
Years ago I was working on the M-hud view in my 535. The rpm/temp display in the hud was always off for everyone that coded in the M view in their HUD

At the time, everyone was working on trying to get it to match via nettodat changes and I'm not sure but just a couple guys got it to work. However, I got mine working just via the "normal" NCSexpert type coding changes.

anyway.... this just reminded me of the same type of scenario and that in fact it may be you can fix this via NCSExpert especially since it is working for dyzak.
 

LMB335is

Sergeant
Apr 12, 2017
286
186
0
FOB FL
Ride
13 335is
Years ago I was working on the M-hud view in my 535. The rpm/temp display in the hud was always off for everyone that coded in the M view in their HUD

At the time, everyone was working on trying to get it to match via nettodat changes and I'm not sure but just a couple guys got it to work. However, I got mine working just via the "normal" NCSexpert type coding changes.

anyway.... this just reminded me of the same type of scenario and that in fact it may be you can fix this via NCSExpert especially since it is working for dyzak.

If it's in FSW_PSW coding somewhere I'd love to know the parameter(s) in our KOMBI. I fooled around with everything I thought might have something to do with it including the four parameters that need to be coded to work with the M3 GWS. Maybe it has something to do with the VO changes for whatever reason, I don't know yet because I haven't gotten that far. All I know is that by changing a few motorstep and starting offset values in this utility it automatically applies the changes to the nettodat MAN and then writes it to the ECU with one click. @Hpaula has the M3 GWS and KOMBI coded in correctly and his was still off.
 

Stokes

Corporal
Jan 26, 2018
235
125
0
Houston, TX
Ride
2011 BMW 135i
I think I'll give it a go. Thanks.
Mine settles at 7200 rpm when warmed up. I'd like to move it down to 6500 just as a reminder that no power lives up there.
 

Seb335i

Specialist
Jun 14, 2019
97
74
0
Ride
BMW 335i E93 DKG
Is there someone who know how to code the 330 km speedometer in perfekt toolbox ? I've a retrofited M3 DCT Cluster with custom gauges to match the 335i RPM and oil temp scale. Everything is ok but the speedometer need to be coded to show the right speed.
 

Attachments

  • clusterM3.jpg
    clusterM3.jpg
    247.6 KB · Views: 347

island road

Corporal
Nov 21, 2016
145
116
0
Boston
Ride
535xiT 2010 M Sport
Is there someone who know how to code the 330 km speedometer in perfekt toolbox ? I've a retrofited M3 DCT Cluster with custom gauges to match the 335i RPM and oil temp scale. Everything is ok but the speedometer need to be coded to show the right speed.

I would love to do the retro fit for my car so i have access to the oil temp but I cant stand the 9k RPM on the M5 cluster. Where did you happen to acquire the gauges?
 

Seb335i

Specialist
Jun 14, 2019
97
74
0
Ride
BMW 335i E93 DKG
  • Like
Reactions: island road

LMB335is

Sergeant
Apr 12, 2017
286
186
0
FOB FL
Ride
13 335is
If you're using the M3 cluster the speedo is already coded for 330 kph.

If you want to set the M3 tach and oil temp to match a non M tach and oil temp gauge face (stock 335i) read your stock cluster and use the stock motor steps and rpm/temp break points and write them to the cluster.
 

Seb335i

Specialist
Jun 14, 2019
97
74
0
Ride
BMW 335i E93 DKG
I answered to myself dump from an E92 M3 for both speedometer and cruise control
 

Attachments

  • cruisecontrolM3.JPG
    cruisecontrolM3.JPG
    47.8 KB · Views: 301
  • speedometerM3.JPG
    speedometerM3.JPG
    48.9 KB · Views: 293
  • Like
Reactions: seb.apprenti
Jul 30, 2018
4
3
0
Ride
N54
Anyone know perfekt toolbox settings for 1M tacho design 300km/h scale for N54, my original speedo is 280km/h(135i speedo). Thank you
 

Bobabc

New Member
May 2, 2020
1
1
0
I'm looking for the same thing as you. I installed the 200 mph speedo on my 135i, and the settings from n54exclusive gauges seems to be way off. I think the motors steps are different for a 135i vs a 335i. Hopefully someone has the answer as I've been messing with it for weeks.