Classic PCV issues

JayG335

Private
Apr 6, 2018
26
4
0
Ride
2007 335i FBO VVT stage2
Hi All,

Tried digging through PCV related posts but couldn't find an answer to this specific question.

I have a VTT headport block off kit with full external catch cans.

I recently installed a VTT oil cap breather and relocated inlets
Due to the relocated inlets I had to vent the high side to atmosphere as the VTT kit didn't not have a line that would run to the new inlets.
Anyway, ever since these mods I have been mixing oil and fuel something crazy.
Also the high side vent puffs crankcase vapors pretty heavy at idle.
I do not feel any vacuum at the oil cap. Normally should feel that light pull but not sure if that changed after headport block off.
There is actually a bit of positive pressure.
Don't have a manometer to test the exact value.

Replaced all my injectors.
Removed them and double checked they aren't leaking.
Removed my tune.
I've done 4 oil changes in 100 miles due to a strong fuel smell.
Compression is good.
Haven't done a leak down, tool is in the mail.
I know the recirc could of just been masking something bigger but the car has never mixed fuel and oil.
Doesn't really smoke while driving either.
Even after the initial installation of the head port block off and external cans.
I was running the block off kit and full external for a year with no issues.
Has anyone had this issue?
Is my pcv routing correct?
Would the oil cap breather cause this?
I've checked both check valves.
The one inline with the throttle body T ad well as the oil cap breather.
Everything seems to be working fine.
Any input is appreciated.

1000010513.jpg

Thanks
Jay
 
Last edited:

JayG335

Private
Apr 6, 2018
26
4
0
Ride
2007 335i FBO VVT stage2
As im incessantly searching forums I realize some logs would probably help. I did find another with a similar issue that ended up being B1S1 o2 sensor.
I'll get logs tomorrow to share.
 

ShocknAwe

Captain
Jan 24, 2018
1,465
1
724
0
Charleston, SC
Ride
N54/3 1er ///Mutt
Between the high side flapper delete and the catch can. I have a mishimoto valve. It doesn't matter brand as long as it matches your hose sizes, I think my low side is 3/8 and my high side is 3/4. FWIW I put a 1" hose straight on the valve cover with a tie down 90 degree to a 3/4 reducer then the check valve. No flapper delete at all.

Once you do that you'll need a vac relief of some sort and you'll be able to set your crankcase vacuum manually. For this I talked to Martymil and used his instructions to trim the VTT relief which I have plumbed to the front head inspection port.

The hard parts setup difference from yours will be the inlet, I have a CF rear inlet from Hydra which my high side runs to. So I don't know how much of your vapor issue we can get rid of since you're VTA.
 
Last edited:

Snertz

Specialist
Nov 7, 2016
63
51
0
NY
Ride
2011 1M
Your check valve between the lowside can and throttle body is installed backwards, flow should be towards the throttle body. The line the VTT tee fitting taps into is the evap line from the fuel tank hence why you smell gas. This fitting also sees boost, you're bleeding pressure into the catchcan/crankcase under boost with the way it's setup currently.
 
Last edited: