Datalog Check my log? Misfiring, limp mode

water

New Member
Jun 8, 2024
5
0
0
log here

hello, just swapped my blown engine for another one, everything works great, pulls hard in every gear, however I’m having misfiring and timing corrections in each cylinder during the pull, but fine at cruise speed.

I have oem bosch oxygen sensors less than a year old in perfect condition no burns or rips

Mods are in the notes of the log
 

TiAgAu

Corporal
Nov 18, 2018
144
60
0
Australia
Ride
08 335i
Without testing them, I don’t think they are leaking, they were good before the swap

Bank 1 is super lean 23.5 AFR stft trims aren't working either. Are these the same injectors from your old motor? Your about to wreck this one too.

So yes seems bank 1 is injectors are leaking and done.
 
  • Like
Reactions: ShocknAwe

bernardo774

Lurker
Aug 15, 2022
17
6
0
try in MHD, Back to Stock (10min flash time), leave car to sleep for 2-3min, then try install MHD V10 map again and mark AFR Oscilation under Downpipe Check.

sounds like a map bug.

For this, use a good baterry charger, 20amp or more.
 

water

New Member
Jun 8, 2024
5
0
0
Bank 1 is super lean 23.5 AFR stft trims aren't working either. Are these the same injectors from your old motor? Your about to wreck this one too.

So yes seems bank 1 is injectors are leaking and done.

How can I know if it’s just bank 1 and not bank 2 as well, I have random misfiring in every cylinder
 

BloodyZ4

Specialist
Mar 17, 2021
56
37
0
Germany
Ride
Z4 35i DCT
As the others mentioned you have leaking injectors in both banks.
AFR's should go up to 234.95 almost instantly and stay flat like below:
1718022257662.png
 

water

New Member
Jun 8, 2024
5
0
0
As the others mentioned you have leaking injectors in both banks.
AFR's should go up to 234.95 almost instantly and stay flat like below:
View attachment 95751
Do you think it’s pre ignition or combustion? I’m going to take my injectors out and test for leakage, is there a way to test them by turning them off and on with protool? Any distinct sound to look for or idle difference?
 

BloodyZ4

Specialist
Mar 17, 2021
56
37
0
Germany
Ride
Z4 35i DCT
Your injectors are definitely toast. I would put a fresh set in or wait for the PI Kit.
Take your plugs out in the morning after parking the car over night and see if they smell like gasoline and check if they are pitch black from running too rich.

Another option: you can unplug them, take them out, mount them on your rail backwards facing the intake, crank your engine and see if they spray and leave them over night with a a piece of papertower underneath and see if they leaked. See the video below.
 
  • Like
Reactions: ShocknAwe