335is ST, having weird fuel trims/timing

DCT_JAY

Specialist
Jan 17, 2019
58
13
0
23
Ride
2011 335is DCT
Howdy Guys !

So i went out and did some runs with my buddies and went from usually putting a car or two on him to losing by at least a car length. I took some logs to see what the dealio was and noticed my STFT trims are out of wack, aswell as my timing. The first two logs have the timing and STFT trim concerns i have, the second log i WAS adjusting my gain from 0 to 60 and my sense to 10 (as im trying to get it to spool quicker/make more power i guess from my understanding). I have included the last log to show how it performed the time i ran my buddy and the trims are fine as well as the timing.

I'm leaning towards maybe my mix is bad even though i measured before and mixed accordingly ? but i did also recently install Wedge's anti-lag setup and on my first revision. I sent a email out about a week ago almost but knowing Ken he is most likely just busy like a bee and will get back soon. Just wanted the community's opinion. (apologies in advance if i left out crucial details)




Build

SpeedTech Garrett Gtw3884r BB 64mm w/ 1.01 a/r @ 19-20 psi
3.5 inch Full VRSF Exhaust
Stage 2 Lpfp (Single 450) running E40
GFB 3 Boost Controller
ADV 02 sensors
7" HD intercooler
VRSF chargepipe with Tial BOV
XHP stage 3


1622552731196.png
 

Slowagon54

Corporal
Aug 21, 2020
110
44
0
LOG 0: The 3rd gear pull was ok. Trims are off a bit but not bad.. What is sure, the post shift knock on cyl 1 was serious. It was ringing like a bell thru the whole 4th gear pull thus DME was pulling timing. No timing, no power.

Same on Log 2... Cyl 5 is knocking really bad.

Some say post shift knock is no real knock, i am not sure. Wait for your tuner to reply but def. need to check the post shift´s.
 
  • Like
Reactions: DCT_JAY

DCT_JAY

Specialist
Jan 17, 2019
58
13
0
23
Ride
2011 335is DCT
LOG 0: The 3rd gear pull was ok. Trims are off a bit but not bad.. What is sure, the post shift knock on cyl 1 was serious. It was ringing like a bell thru the whole 4th gear pull thus DME was pulling timing. No timing, no power.

Same on Log 2... Cyl 5 is knocking really bad.

Some say post shift knock is no real knock, i am not sure. Wait for your tuner to reply but def. need to check the post shift´s.
he did get back to me and i feel like it runs a lot better now (i feel like it also reflects in the logs) , i did find out additionally that my IATs/ maybe other things were getting messed up due to a wire crimp being faulty (was tied into my charge air temp sensor).

1623431348967.png





I wasnt aware that it was knocking bad on cyl 1 (or at all really), could you take a look at these and let me know what you think ? Keep in mind its hot over in Texas right now so my temps are a bit crispy. My corrections seem to be alot more tame
 

Slowagon54

Corporal
Aug 21, 2020
110
44
0
On the first log you have some 12 deg of timing. On the second log (Antilag 2) your timing is gone... strange.

Knocking wise its almost perfect now.
 
  • Like
Reactions: DCT_JAY