Timing Corrections

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
Hi,

Does anyone know what can cause timing corrections on specifically cylinder 2 and 5? I know the knock sensors are near those cylinders, but this happens at least 3 out of 4 pulls. I get huge timing corrections on cylinder 2 and 5 only. I’m almost starting to think it’s false. Even with knock desensitized through MHD it does the same thing. My stock turbos maxed out didn’t have this problem. As soon as I upgraded the turbos and installed all the supporting mods this issue started. I’m tuned on full E85 + Meth 50/50 for IAT cooling and boosting about 25 psi.

Current mods:
RB 17T GF turbos
RB GF outlets
ARM relocated inlets
VRSF downpipes
VRSF street exhaust
BMP Port Injection 750cc
BMP Stage 3 low pressure pump
AEM meth kit dual BM5 nozzles (Boost Juice with controller set to 10 psi start and 20 psi full)
CTS 7” IC
BMS low side & high side catch can
BMS charge pipe with Tial BOV
XHP Stage 3 DCT flash
PR coils with NGK gapped to .020”

Maintenance:
New Index 12’s
New HPFP
New PCV flapper
NGK plugs .020”
New fuel tank vent valve
4 new Bosch oxygen sensors
Walnut blasted prior to port installation
 

Attachments

  • 67D44E93-58DB-446A-AA60-93957924A11F.png
    67D44E93-58DB-446A-AA60-93957924A11F.png
    253.1 KB · Views: 46
Last edited:

MR-KRAKA

Private
May 23, 2020
28
15
0
What are you targeting for timing/afr? What vanos settings are you using? Those are pretty high typically 2/5 will have a 3-5* correction not worth chasing
 

MR-KRAKA

Private
May 23, 2020
28
15
0
Looks like you just need to get your boost control cleaned up a little. It’s generally best to run slightly under target and having pid pulling it up. It will feel much better once you get those throttle closures cleared up too. I’m sure whoever you have handling it is working on it.

Only odd thing I see is it looks like your tuner has timing tapering down towards redline? You may also want to verify your ethanol content this time of year as well depending on your location. Though with the meth on top of it you should have more than enough octane for that timing. Those RB’s do look healthy though 50% wgdc up top at 25psi.
 
  • Like
Reactions: N54TT

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
Looks like you just need to get your boost control cleaned up a little. It’s generally best to run slightly under target and having pid pulling it up. It will feel much better once you get those throttle closures cleared up too. I’m sure whoever you have handling it is working on it.

Only odd thing I see is it looks like your tuner has timing tapering down towards redline? You may also want to verify your ethanol content this time of year as well depending on your location. Though with the meth on top of it you should have more than enough octane for that timing. Those RB’s do look healthy though 50% wgdc up top at 25psi.

Thank you. Hopefully with the final tune the corrections look normal. Tuners are always busy. I haven’t gotten a new revision for over a week now.
 

MR-KRAKA

Private
May 23, 2020
28
15
0
That looks much better… Your not going to be able to get a good read on the intercooler without disabling the meth (not recommended) Unless you have a before and after with the meth at this boost level as well. IAT is definitely in check though I’d say. You should also complete the shift to get that data as well.
 

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
That looks much better… Your not going to be able to get a good read on the intercooler without disabling the meth (not recommended) Unless you have a before and after with the meth at this boost level as well. IAT is definitely in check though I’d say. You should also complete the shift to get that data as well.
It’s still inconsistent. Some times it does it some times it doesn’t. I might just have to live with it.
 

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
Here are 2 logs from a different tuner. Rail pressure looks better and so does the STFT. I might have suspected my AIC wires weren't getting a good connection I messed around with them for now and verified they have good ground, power 12v key on engine off, and 14v key on engine running. If I really want to know if the AIC wires helped or not is just by uploading the other tuners map and see how it runs.

 

QuestFor10s

Lurker
Apr 19, 2021
13
6
0
Chicago, IL
Ride
2011 BMW 335IS DCT
After I installed my AIC I noticed that once in a while the PI wasn't spraying also. I originally used crimp style T-taps. I've since removed and soldered the wires and have not had any issues since. I would not recommend using T-taps.
 
  • Like
Reactions: N54TT

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
After I installed my AIC I noticed that once in a while the PI wasn't spraying also. I originally used crimp style T-taps. I've since removed and soldered the wires and have not had any issues since. I would not recommend using T-taps.
Did you solder on the power wire also? I'm using posi taps the port injection has been holding up fine, but I did think about soldering it just to never worry about it.
 

Steve135i

Specialist
Nov 16, 2020
51
45
0
New Jersey
Ride
08 135i e88
After I installed my AIC I noticed that once in a while the PI wasn't spraying also. I originally used crimp style T-taps. I've since removed and soldered the wires and have not had any issues since. I would not recommend using T-taps.
That's a good thing to do. I could not figure out for the life of me why my reflex wasn't connecting, and after chasing and testing every wire I found out the positap for power was rounded on the tip and only looked like it pierced the wire but didnt. I've went to soldering ever since
 
  • Like
Reactions: N54TT

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
What too
That's a good thing to do. I could not figure out for the life of me why my reflex wasn't connecting, and after chasing and testing every wire I found out the positap for power was rounded on the tip and only looked like it pierced the wire but didnt. I've went to soldering ever since
What tool are you guys using to get a clean cut on the oem harness insulation prior to soldering in the AIC wires?
 

QuestFor10s

Lurker
Apr 19, 2021
13
6
0
Chicago, IL
Ride
2011 BMW 335IS DCT
Did you solder on the power wire also? I'm using posi taps the port injection has been holding up fine, but I did think about soldering it just to never worry about it.
Yes, I soldered all 4 wires. I cut the wire, trim the insulation on both ends to allow me to slip heat shrink over the wire and then solder back together.