Serious misfire with limp mode - Help!!

RabbitOLychee

Private
May 23, 2022
36
2
0
Hey Team,

I have finally hit the bottom of the bucket, I have no idea at all of what's going on with my 335i.

I had recently got myself Index 12 injectors for my bank 1 as my previous injectors were leaking as I had taken them out and put them back in and caused the original Teflon seal to not expand anymore. After installing and coding the injectors with Bimmergeeks ProTool and double checking with ISTA the car went completely haywire by it backfiring SUPER LOUD, as if it was a gun shot, causing my 200 Cell cats to explode as I heard them shatter out of the exhaust when the bang happened.

My previous injectors were bad as well, it would almost stall at the lights and having terrible acceleration.. So getting new index 12 injectors should of solved it right? Nope!

It's only happening on bank 1 as well, I had also ruled out it being coilpacks as i swapped Cyl 4,5,6 to Cyl 1,2,3 and it's still getting Multiple Combustion Misfires, and Misfire Cylinder 1 and Misfire Cylinder 2 in MHD Read Codes.

It would even start very small backfires while it's idle..

I had noticed my Cylinder 1 spark plug was completely soaked in fuel and full black but the other plugs in bank 1 were little dark but not wet... I have no idea what's going on, if anyone can help me, it would mean the world to me!

I even swapped my old spark plugs to see if the spark plug was fired but no luck, it seems like there's no spark on Cyl 1...

I did do a log but I can not drive it again as it backfires super loud, it's locked in Limp mode, so I got the best log possible, hopefully something is readable!

 

Slowagon54

Corporal
Aug 21, 2020
168
62
0
Very strange. Your STFT are 0... which is strange. Def. something wrong with fueling, just check the AFR´s. Weird thing bank 1 is not even going up on decel, which indicates too much fuel. On the other hand its running too lean on throttle. Check your couplers on the fuel rail and injectors. Check the wiring to the injectors as well. How about the O2 sensors, did you change them as well? Give us some more information about the car. Looks like stock for now, but was it tuned previously?
 

RabbitOLychee

Private
May 23, 2022
36
2
0
Very strange. Your STFT are 0... which is strange. Def. something wrong with fueling, just check the AFR´s. Weird thing bank 1 is not even going up on decel, which indicates too much fuel. On the other hand its running too lean on throttle. Check your couplers on the fuel rail and injectors. Check the wiring to the injectors as well. How about the O2 sensors, did you change them as well? Give us some more information about the car. Looks like stock for now, but was it tuned previously?
Hey Slowagon54,

Yeah I had my bank 1 sensor 1 O2 broken going back about a month ago and replaced it. But that was all fixed and it was running perfect. But after a while, my injectors started to leak.. Just recently (2 days ago) I opted for some index 12 injectors for bank 1 so I can solve the leak problem but it just made matters worse...

I have found that my Cylinder 1 plug keeps getting full of fuel going fully black but all the others are fine! (I even used one of my old plugs and same thing happens)

The only error I get now is 2E30 - DME: Fuel Injector, cylinder 1, activation

So that would have to be a faulty injector right? I know it says injector lol but chances of a new injector being dead? Looks like there's not even a spark on cylinder 1's plug as well and fuel just pours out of my exhaust causing loud back fires...

My car's mod list is

VRSF Downpipes (V2)
VRSF Intakes
VRSF Charge Pipe
MHD Stage 2+
xHP Stage 3

Currently at the moment it's back to stock, MHD software isn't even on the car anymore... I did use the previous decouplers on my injectors as I didn't get new ones? But they seem to be fine and they are actually in pretty good shape...

Wiring to the injectors are all on and secured...

Quick question, can I quickly add my old Index 1 injector to my other 2 Index 12 injectors for worse case senario to see if it solves the problem?

Cheers! :)
 

Slowagon54

Corporal
Aug 21, 2020
168
62
0
So everything is pointing on cylinder 1. Not sure what you have done exactly, but go thru it again and see what could have gone wrong. I have heard about that people do not change injector seals with no issues. Of some i have heard that even old couplers caused missfire on a high load situation.

Sure it could be a dead new injector as well, but chances for that are quite low if you ask me. Depends on where you have bought it - lol.

Yes, you can try to go back to the old injector, but i would not do that... i ll rather try to swap inj. 1 with inj. 4 (or 5 or 6) for example and see how it does. But then i would change the inj. seals as well.
 
  • Like
Reactions: wheela

RabbitOLychee

Private
May 23, 2022
36
2
0
So everything is pointing on cylinder 1. Not sure what you have done exactly, but go thru it again and see what could have gone wrong. I have heard about that people do not change injector seals with no issues. Of some i have heard that even old couplers caused missfire on a high load situation.

Sure it could be a dead new injector as well, but chances for that are quite low if you ask me. Depends on where you have bought it - lol.

Yes, you can try to go back to the old injector, but i would not do that... i ll rather try to swap inj. 1 with inj. 4 (or 5 or 6) for example and see how it does. But then i would change the inj. seals as well.
Yeah man, looks like everything is cylinder 1.

Just last night, I discovered my plug on cylinder 2 was bent?!? Causing a consistent ark and causing it throw codes, so I replaced that asap and that went away and I figured it could of been causing the whole bank to have problems but nooopee lol Cylinder 1 is still spitting the dummy...

Yeah I bought the injector for a cheap price as I was in a hurry to get this car going again, another thing I found odd as well is, for bank 1 index 12's, all the flow rates are exactly the same? (They are completely genuine BMW injectors as well) but not sure if that matters at all?

Yeah I'll give the old ones a go, and good idea, I'll swap one of the "working" old ones and see if it causes the issue...

Cheers mate, thanks for the response! 👌
 

SlowE93

Captain
Jul 2, 2017
1,390
1
762
0
Ride
E93
Yeah man, looks like everything is cylinder 1.

Just last night, I discovered my plug on cylinder 2 was bent?!? Causing a consistent ark and causing it throw codes, so I replaced that asap and that went away and I figured it could of been causing the whole bank to have problems but nooopee lol Cylinder 1 is still spitting the dummy...

Yeah I bought the injector for a cheap price as I was in a hurry to get this car going again, another thing I found odd as well is, for bank 1 index 12's, all the flow rates are exactly the same? (They are completely genuine BMW injectors as well) but not sure if that matters at all?

Yeah I'll give the old ones a go, and good idea, I'll swap one of the "working" old ones and see if it causes the issue...

Cheers mate, thanks for the response! 👌
Genuine ?
Only thing genuine is , you bought Genuine CRAP.
Sorry to say, but as I said REMOVE immediately.
 
  • Funny
Reactions: Slowagon54

RabbitOLychee

Private
May 23, 2022
36
2
0
Genuine ?
Only thing genuine is , you bought Genuine CRAP.
Sorry to say, but as I said REMOVE immediately.
Uh no offense but what do you mean? It's injectors from a store that is near me, selling for $400.99 per injector (Index 12's).. Only ebay thing is coilpacks from GOSS which run very well in fact..
 

SlowE93

Captain
Jul 2, 2017
1,390
1
762
0
Ride
E93
Uh no offense but what do you mean? It's injectors from a store that is near me, selling for $400.99 per injector (Index 12's).. Only ebay thing is coilpacks from GOSS which run very well in fact..
That they probably bought or they themselves sell on EBAY.
NO WAY are Genuine BMW injectors all going to have the same flow rates.
3 injectors , in one purchase, with exact same flow rates does not seem odd to you ??
 

RabbitOLychee

Private
May 23, 2022
36
2
0
That they probably bought or they themselves sell on EBAY.
NO WAY are Genuine BMW injectors all going to have the same flow rates.
3 injectors , in one purchase, with exact same flow rates does not seem odd to you ??
Well I did find it odd, but I didn't know if it was a issue hence why I asked if that sounds right?
 

SlowE93

Captain
Jul 2, 2017
1,390
1
762
0
Ride
E93
Well I did find it odd, but I didn't know if it was a issue hence why I asked if that sounds right?
This is the issue that everyone who has bought index 12s on EBAY has come across.
Well, the ones who got screwed anyway.
I would remove them and not gamble by switching them around to different cylinders.
Maybe drive to that store and ask how it is possible they all have the same flow rate and also explain the issue that is being caused by them ?
 

RabbitOLychee

Private
May 23, 2022
36
2
0
This is the issue that everyone who has bought index 12s on EBAY has come across.
Well, the ones who got screwed anyway.
I would remove them and not gamble by switching them around to different cylinders.
Maybe drive to that store and ask how it is possible they all have the same flow rate and also explain the issue that is being caused by them ?
Wow yeah right... I'll bring it up with them if that's the case because if they are knock off's I will be mighty pissed off as I don't want any Ebay shit on my 335i... Specially for $410 that I paid for them for the little extra I could get them from BMW THEM SELVES lol
 
  • Like
Reactions: SlowE93

SlowE93

Captain
Jul 2, 2017
1,390
1
762
0
Ride
E93
I would throw in the best injector you have out of the old bunch, and see if it starts fine again (with new plug installed, not one drenched in gas).
If it clears up, take them all out and throw them through the store window and demand money back.
 

RabbitOLychee

Private
May 23, 2022
36
2
0
Yeah, I actually did that and found out it's one of my new index 12 injectors that have failed, I put one of my old index 1 injectors with my index 12's, in bank 1 and it's running actually not too bad, still a few misfires here but it is a bad injector anyhow...

Gonna get a replacement from them of the faulty one and mention that they are the same flow rate and basically go what is the deal with that if you guys have it written down on paper, saying it's genuine injectors... If they refuse refund and all that, I'll just take up to Fair Work as that's actually illegal.

Gonna get new plug and coilpack and hopefully a working index 12 and see how it goes... It's only a cylinder 1 misfire code that comes up time to time...


I would throw in the best injector you have out of the old bunch, and see if it starts fine again (with new plug installed, not one drenched in gas).
If it clears up, take them all out and throw them through the store window and demand money back.
 

SlowE93

Captain
Jul 2, 2017
1,390
1
762
0
Ride
E93
Yeah, I actually did that and found out it's one of my new index 12 injectors that have failed, I put one of my old index 1 injectors with my index 12's, in bank 1 and it's running actually not too bad, still a few misfires here but it is a bad injector anyhow...

Gonna get a replacement from them of the faulty one and mention that they are the same flow rate and basically go what is the deal with that if you guys have it written down on paper, saying it's genuine injectors... If they refuse refund and all that, I'll just take up to Fair Work as that's actually illegal.

Gonna get new plug and coilpack and hopefully a working index 12 and see how it goes... It's only a cylinder 1 misfire code that comes up time to time...
I would NOT get a replacement from them.
I would get my money back on ALL that was bought from them.
It will happen again AND you are paying $400.00+ for knock offs.
Lets not forget the money lost on cats and you have no idea if all that fuel has caused cylinder damage.
In the end, it is up to you.
Good luck !
 

RabbitOLychee

Private
May 23, 2022
36
2
0
I would NOT get a replacement from them.
I would get my money back on ALL that was bought from them.
It will happen again AND you are paying $400.00+ for knock offs.
Lets not forget the money lost on cats and you have no idea if all that fuel has caused cylinder damage.
In the end, it is up to you.
Good luck !
Yeah had a long think last night, I will ask for a refund on all of them.. I don't want them causing problems later on if they do keep working... I'm just gonna fork out the little extra and buy it straight from BMW, not gonna play the game of companies saying they are genuine when they are really not....
 
  • Like
Reactions: SlowE93

RabbitOLychee

Private
May 23, 2022
36
2
0
Yeah. . . Those are fake index 12s. . . Aint no way in hell all 6 injectors have the SAME flow rate. . . Shits faker tham Pam Andersons tatas.
Yep I agree, I'm gonna demand my money back.. Aint having no fake shit in my car specially when it's not running at tip top shape.
 
  • Wow
Reactions: SlowE93