Datalog Lack of power and badly mis firing/vacuum leak

RabbitOLychee

Specialist
May 23, 2022
56
2
0
Hey guys, new to this page! :)

Just recently started to have a problem with my N54 (335i e90 07) and ever since I did a pull one day, I heard a weird "SSSTSTSTSTS" sound when I hit 6k RPM, sounds like a solenoid or something getting stuck... and It only happens at high RPM during hard pulls 1st, 2nd, 3rd... It also randomly changes the car's note sometimes to the point it starts back firing super loud uncontrollably and it sounds really deep...

After a week of not knowing what it was, I had started to notice that it's mis firing upon cold start badly but after it gets warmed up, it gets way better.. During a pull now, when I go into 3rd and WOT it, it misses during the whole pull, you can even feel it mis firing or a potential vacuum leak? Even general driving you can feel it drop RPM's every time and after a pull, the car starts going nuts while idling at the lights by it mis firing..

Gets even weirder that I don't even have any codes come up for it, and I've checked through MHD, ISTA-D, even xHP just in case for a gearbox issue...

I have gotten a log for it through MHD and hopefully someone might be able to shine some light on what is going on?

Stuff that I have checked already..
- Charge pipe
- Injectors clean (1,2,3 did have a lot of carbon build up due to a blocked cat that made it run rough for ages)
- Used liquid molly to hopefully clean injectors
- Checked airflow sensor (Still connected)
- Coilpacks/Spark plugs seem to be good
- O2 Sensors recently changed bank 1 and 2.

Mods that I have on the car already
-Upgraded charge pipe
-VRSF intakes
-VRSF V2 Charge pipe
-Stage 2+ V9 98 RON
- xHP Stage 3 (Drag Mode)


Hopefully this can be resolved! (I've attached the log below, if any more information is needed, I can get it šŸ˜€ )
Cheers!

Data Zap Log - https://datazap.me/u/rabbitolychee/07-335i-n54-mis-firevacuum-leak?log=0&data=3-11-22
 
Last edited: