Sputtering After 2nd - 3rd Gear Shift

Cole92ton

New Member
Jan 13, 2021
3
0
0
Been having this issue recently. At wide open throttle, typically when shifting from 2nd to 3rd gear, my car will begin to sputter and ping, almost as if it's hitting a limiter. It's a difficult condition to describe, so I've attached a datalog. It happens more often when the engine and trans are hot or when there is a lot of added weight (i.e. passengers or full fuel tank). Running MHD Stage 1+ tune.

Datalog: https://www.spoolstreet.com/graphs/...-shift-3-18-22.15935/?series=2,19&zoom=-7,664

Things to note upon shift into 3rd gear:
- Low pressure fuel sensor readings look low, dipping to 50ish psi, can anyone confirm?
- Abnormal cylinder timing corrections across all cylinders
- Throttle position is closing while accelerator pedal is at 99.6 position
- Lambda bank 1 shoots up to around 23.5, lambda bank 2 is steady around 13

Feel free to ask any questions. TIA for any help!
 

carabuser

Lieutenant
Oct 2, 2019
549
1
410
0
UK
Ride
Z4 35i & 335i
I'd stop driving it hard until you get it sorted. Looks pretty nasty after shift.

LPFP probably needs replacing as you've already noticed. You are over boosting massively after shift even though wastegates are commanded at reasonable levels so maybe bad boost solenoids but that's certainly not the cause of your problem.

There's probably an ignition cut on cylinder 3 due to misfire causing the high AFR on bank 1. All cylinders look noisy though so while replacing your LPFP consider some new plugs and coils if the current ones are old.
 

Cole92ton

New Member
Jan 13, 2021
3
0
0
I'd stop driving it hard until you get it sorted. Looks pretty nasty after shift.

LPFP probably needs replacing as you've already noticed. You are over boosting massively after shift even though wastegates are commanded at reasonable levels so maybe bad boost solenoids but that's certainly not the cause of your problem.

There's probably an ignition cut on cylinder 3 due to misfire causing the high AFR on bank 1. All cylinders look noisy though so while replacing your LPFP consider some new plugs and coils if the current ones are old.
Thanks for your input. I've been having that over boosting issue resulting in throttle closures @ over boost quite frequently, though I've been assuming it was due to the OTS tune and or/old boost solenoids.

Just ordered a new LPFP. Will start there and then consider plugs and coils if the issues persist. The current NGK 95706 plugs gapped at 0.018" are fairly new, less than 12k miles on them. The current Delphi coils are probably about 35k miles old.