Precision turbo compressor wheel failure

trb1

Lurker
Feb 19, 2022
13
2
0
Hi all.

Just lost my second precision 6062 to compressor wheel failure. First turbo at 15k miles and most recently at around 500 miles. Has anyone had this issue before with the billet wheels falling apart?

The first turbo precision claimed foreign object damage and I bought into it because I had my filter off a few days before I lost the turbo. However, the second turbo had a brand new filter and hasn’t been off since install.

Im not buying FOI for either of them now. It looks like material defect. Just want some input before I send this in again… wishing I went with Garrett at this point.

First turbo:

sakgBJr.jpg


Second turbo:

RU2WHGX.jpg
 

SlowE93

Captain
Jul 2, 2017
1,321
1
715
0
Ride
E93
Hi all.

Just lost my second precision 6062 to compressor wheel failure. First turbo at 15k miles and most recently at around 500 miles. Has anyone had this issue before with the billet wheels falling apart?

The first turbo precision claimed foreign object damage and I bought into it because I had my filter off a few days before I lost the turbo. However, the second turbo had a brand new filter and hasn’t been off since install.

Im not buying FOI for either of them now. It looks like material defect. Just want some input before I send this in again… wishing I went with Garrett at this point.

First turbo:

View attachment 66645

Second turbo:

View attachment 66646
Damn.....that's shitty !
One of my Associates that uses single turbo may chime in soon.
 
  • Funny
Reactions: JohnDaviz

trb1

Lurker
Feb 19, 2022
13
2
0
Damn.....that's shitty !
One of my Associates that uses single turbo may chime in soon.
Tell me about it. Lost it at the track today on my second heat. First time out this year. Talk about a total buzzkill.
 

SlowE93

Captain
Jul 2, 2017
1,321
1
715
0
Ride
E93
It does appear that something may have got in there though.....you said filter was on so I will believe it to NOT be foreign object....but does look like it so GL with Precision.
 
  • Agree
Reactions: fmorelli

trb1

Lurker
Feb 19, 2022
13
2
0
It does appear that something may have got in there though.....you said filter was on so I will believe it to NOT be foreign object....but does look like it so GL with Precision.
I agree. My thing is, both of them have had a blade snap off. The foreign object that damaged the rest of the wheel was the damn compressor blade.

Also, I boroscoped my intercooler after the first failure and only found the single compressor blade.
 
  • Informative
Reactions: SlowE93

RuskiRacer

Captain
Jul 17, 2019
1,110
675
0
Ride
2009 e93 335i
I like my precision turbos and never have had any compressor wheel issues. Do you run a filter or turbo screen?
 

wheela

Sergeant
Jun 4, 2021
347
196
0
Twin Cities, MN
Ride
2015 e84 X1 35i Msport
Is your filter mounted directly to your compressor housing inlet, or are you running some kind of intake?
 

trb1

Lurker
Feb 19, 2022
13
2
0
I sent pictures to precision and their consensus is that it was either a bent shaft, unbalanced cartridge, side load, or the compressor housing came loose (spoiler: it didn’t).

Guess I’ll see what they have to say when the turbo gets delivered tomorrow. I was only running 15 psi. Side load doesn’t make sense with the wastegate pressure.
 

RuskiRacer

Captain
Jul 17, 2019
1,110
675
0
Ride
2009 e93 335i
I sent pictures to precision and their consensus is that it was either a bent shaft, unbalanced cartridge, side load, or the compressor housing came loose (spoiler: it didn’t).

Guess I’ll see what they have to say when the turbo gets delivered tomorrow. I was only running 15 psi. Side load doesn’t make sense with the wastegate pressure.
Seems like some manufacturer defects that you unfortunately ended up with. My buddy is running a 6466 on his built motor car and the compressor is a bit beat up and still makes good boost and doesn't grenade.
 

iminhell1

Sergeant
Jun 17, 2018
405
190
0
Do bear in mind that the BOV and WG spring pressures should be similar or tuned similar. If the gate is closed you can still overspeed the wheels and damage them. The excess pressure is just vented. The turbo isn't actually slowing down.
Verify the gate and how it's tuned. If you're simply relying on spring pressure (no Hobbs) then I'd recommend going to a lighter spring and investing in a good boost controller.

I've heard many stories about wheel failures. The ones that aren't foreign objects are almost always due to speed or surge. Low boost isn't common, and shouldn't be, for any damage. So that's why I'm thinking the gate is coming into play here.
 

trb1

Lurker
Feb 19, 2022
13
2
0
Do bear in mind that the BOV and WG spring pressures should be similar or tuned similar. If the gate is closed you can still overspeed the wheels and damage them. The excess pressure is just vented. The turbo isn't actually slowing down.
Verify the gate and how it's tuned. If you're simply relying on spring pressure (no Hobbs) then I'd recommend going to a lighter spring and investing in a good boost controller.

I've heard many stories about wheel failures. The ones that aren't foreign objects are almost always due to speed or surge. Low boost isn't common, and shouldn't be, for any damage. So that's why I'm thinking the gate is coming into play here.
40mm turbosmart wastegates. Spring pressure in the wastegate is 14 psi. Bov is 11 psi. I use a mac valve as a boost controller. I was just running a low boost map
 

RuskiRacer

Captain
Jul 17, 2019
1,110
675
0
Ride
2009 e93 335i
40mm turbosmart wastegates. Spring pressure in the wastegate is 14 psi. Bov is 11 psi. I use a mac valve as a boost controller. I was just running a low boost map
Pretty common setup. Should not be an issue with your spring pressure or setup. Could be just bad luck. What bov are you running ? Precisions big downfall is probably being prone to damage from surge
 

trb1

Lurker
Feb 19, 2022
13
2
0
Pretty common setup. Should not be an issue with your spring pressure or setup. Could be just bad luck. What bov are you running ? Precisions big downfall is probably being prone to damage from surge
Running a tial q. I honestly don’t know what I could have done to prevent surge at such a low pressure. I’ve taken every precaution to avoid issues like this