MHD Wifi orange e-series adapter disconnects regularly

sb335xiE92

New Member
Feb 19, 2018
5
1
0
Ride
2008 BMW 335xi E92 Sport
I've been using the adapter with Samsung S7 Android v8.0 for gauge monitoring. Works great until it doesn't. Wifi disconnects after a few minutes, everytime. Reconnect, works for a few minutes, then disconnects again>

Thoughts?

2008BMW335xiE92Sport.jpg
 

JBacon335

Corporal
Nov 7, 2016
218
95
0
38
Toms River, NJ
Ride
07 335i Sedan, 1988 Mustang GT
I've had mine drop out a few times too. I'm thinking while stopped or driving I may have been close to a network my phone tried to switch to
 

Milan

Sergeant
Dec 24, 2016
410
228
0
jebi se
Ride
your mom
My iphone and my android tablet will no longer stay connected to mine. Basically a paperweight now
 

KevinC39

Corporal
Jun 27, 2017
227
116
0
Ride
335i
I've had zero issues with mine. Pixel 1 or Pixel 3a. Both work fine. I'm using the N55e app though so maybe it's something specific to the N54 app and not actually a hardware thing? I'd think if that was the case though we'd see a lot more people complaining
 

Dusty

Lurker
Aug 25, 2018
10
1
0
Ride
335i
I have same issue on my huawei p20 pro! Does in plane Mode too. I have noticed it only happens when i enter some place where is alot of WiFi spots avaible.
 

steve30

Lurker
Sep 26, 2019
15
3
0
Ride
E36 M3, E90 335 ST
I'm having an issue with mine only when connecting to the monitoring tab. It reads DME codes and resets adaptations fine, just takes a few minutes to connect to the monitor tab. It used to connect instantly..
 

TSilver335i

Specialist
Nov 18, 2018
66
30
0
Australia
Ride
08 335i
Anyone of you secure the network connection? By adding password rather leaving it an open network? Could possibly cause issues? Still good to do imo.

Read this
 
Last edited:

jzx_andy

Lurker
May 22, 2019
24
28
0
Perth, Western Australia
Ride
2008 E92 335i 6MT
I also have this issue with my orange E series adapter and don't believe it has anything to do with the device I want to connect it to. Wifi connection randomly drops out as if the wifi controller on the adapter loses power or something for a brief moment and needs a reset, but the adapter itself still has one of the lights on, so it's not like there's a poor connection between the adapter and obd2.

Seems to occur most often once the car is moving.

Tried a number of different android devices (old and new, regular phone and dedicated logging/coding device), flight mode on and off, bluetooth on/off etc. Bit disappointing, I might have to get in touch with BMS/MHD about sorting out a replacement unit.

EDIT: also changed the password, no dice :(
 
Last edited:
  • Like
Reactions: TSilver335i

sparkyblue

New Member
Feb 4, 2018
8
2
0
Same thing here, and I've set a password on the Wi-Fi network.

I've tried an iPhone 11 Pro, Nexus 6, Galaxy S8, Galaxy Note8.

I'm able to get it to connect and view live Data Logging, however after a few minutes the gauges freeze.

I don't think the MHD WiFi <-> ODBII is loose. Nor do I think its an issue with the iPhone/Androids, as I have zero issues when connected via DCAN/KCAN+USB OTG on any of the 3 Androids.

Any insight here MHD team?
 

NewYorkSoto

New Member
Jul 5, 2020
1
0
0
Orange adapter loose and falls
I have to hold it in place to get power on it and had to push it in and hold it in place to use it- has anyone else had this prob, is it Perhaps a defective one I might had received? 🤔
 

Rik

Lurker
Sep 11, 2020
13
1
0
Just bought one last week. Exactly the same problem for N55e. Wifi drops, flash fails, makes car inoperable and I spend a stressful hour or so trying to get re-connected and then re-flash. Same for reading codes and monitoring - Wifi drops out. Parked on the drive and just reading DME codes it seems more reliable, but also i'm stood outside the car with the phone. I don't have another Android device to try. I wonder if its related to being too close or interference from car? I have just emailed MHD to see what they advise but i dare not try another flash to even tweak options, so kind of makes it an expensive one off thing. I never wanted the WiFi for this very reason but you cant buy a Genuine MHD wired cable anymore.
 

Rik

Lurker
Sep 11, 2020
13
1
0
I found plenty of posts on another forum's with similar problems. Only one had a solution - which was a replacement adaptor from MHD.
 

Rik

Lurker
Sep 11, 2020
13
1
0
tried every setting on my phone, but no use. However i did just go plug the adapter in via a 5ft obd extension cable and i was able to notice, with no car trim in the way, that it wasn't going all the way in using "normal" force. I had to push it really hard to get it to seat all the way in - and hey presto worked first time!. So i tried it directly back into car port pushing and wriggling it really it hard, and it finally felt like it went all the way home. And so far it works! And in my E82 it means the OBD trim cover now fits back on over the adapter.
So perhaps there are a batch of orange adapters that the plastic moulding is rather too tight. Anyway worth a try? but please dont use a hammer and break it or your car port.
 

9krpmrx8

Sergeant
Nov 5, 2016
459
244
0
San Antonio, Texas
I have been having the same issue and was talking (sent in debugging files as well) to MHD about but have not heard anything back lately. It happens with my orange adapter that I have had since they first released it and it happens on my dedicated Lenovo tablet, my S20 Ultra 5G, and on my backup Fire HD 7 and all of these devices have been used for MHD for a while without issue so it's not the Android device. MHD says it is happening because the devices are trying to connect to other wifi devices but my tablets are not set up to connect to any wifi networks automatically and I only use them for the car.

When mine freezes it is not the device, I just hit the back button and then start monitoring again and it works fine.



My guess is that it is an issue with the Orange MHD adapter itself, I'll likely get another one and see if it fixes the issue. It's pretty annoying because it seems to freeze when I run into someone in Mexico and do a pull and then after I realize it was frozen and did not log.
 

Rik

Lurker
Sep 11, 2020
13
1
0
I tried again today after my success last night. I had driven the car but not touched the adapter since last night when it worked. Cant get it to connect at all - really frustrating. I did get a reply from MHD, very quickly to be fair, but they said the same, its trying to connect to another Wifi point and go use it in another place. Strangely my mains charger for the car battery doesn't have a mile or so long cable so that doesn't appear to be great advice. And in any case i have tried in about 20 different places including in the middle of no-where with no other WiFi signals around. Phone is in Flight mode so no other connections except Wifi possible. The orange adapter cost me ÂŁ70 here in UK so really disappointed it appears to be very poor. The bluetooth ÂŁ5 ebay special i use with TorquePro app on multiple cars and android devices works perfectly.
Going to return it but the UK supplier doesn't have another in stock. Anyone use a Bimmergeek or Thor adapter with MHD app - would they work?
 

Milan

Sergeant
Dec 24, 2016
410
228
0
jebi se
Ride
your mom
MHD adapter is a POS. Like standard for this community they will probably deny it for 2 years before they change it.

I’ve tried everything on here too, doesn’t matter if it’s my phone or tablet it’s the same shit.

Bimmergeeks cable never lets me down
 
  • Sad
Reactions: derekgates