Inconsistent Rail Pressure with Port Injection

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
Hey Folks,

I been trying to track down this issue for over 3 months. I'm tired of checking the wires and messing around with them. My Rail Pressure is always inconsistent and causes some major misfires at times when it really dips down hard. Every time I re-upload the AIC map everything seems to work fine and days later this same problem continues. I'm almost never enjoying my car because I'm scared of some sort of lean condition if the rail pressure isn't where it needs to be with 25+ psi of boost. Any suggestions?

Mods:
RB GF turbos
BMP Port Injection with Stage 3 LPFP
AIC-1 (Would this a good time to switch to the Motiv Reflex Plus?)
All the bolts on possible
Full E85

Recent Maintenance: Index 12's, HPFP, new valve cover, NGK plugs with PR coil plugs, and 4 Bosch Oxygen Sensors
 

Attachments

  • 1.jpg
    1.jpg
    54.8 KB · Views: 44
  • 2.jpg
    2.jpg
    48.6 KB · Views: 37
  • 3.jpg
    3.jpg
    50.9 KB · Views: 35
  • 4.jpg
    4.jpg
    53 KB · Views: 39
Last edited:

Dumaurier7

Sergeant
May 19, 2020
354
118
0
Based on recent experience I can advise you to look at your LPFP, did you confirm both are running at high boost?
 

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
Based on recent experience I can advise you to look at your LPFP, did you confirm both are running at high boost?

My LP reading is around 65-85 psi in the logs so I'm assuming the 2nd pump is turning on.
 

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
If you look at your logs closely, are both your pumps dipping at the same time ?

No the low pressure is staying above 75+ psi when the HPFP is dipping. I will post up the actual data zap logs in a bit.
 

Dumaurier7

Sergeant
May 19, 2020
354
118
0
With 2X450's running at idle my fuel pressure is around 85 psi under 10 psi boost it ranges between 96 an 105 psi.
 

Dumaurier7

Sergeant
May 19, 2020
354
118
0
Understandable, but the 2nd pump doesn’t work until the hobb switch is activated from boost reference.
When the DME ramps them up under boost its between 95 and 105+.
 

Attachments

  • 2022-01-07 12_14_59 000021571DAA01 Marcel_93oct_EWG_ST_N20_RFLX-PI_8AT_Rev1.2.mhd.csv
    11.9 KB · Views: 11
  • Like
Reactions: N54TT

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
When the DME ramps them up under boost its between 95 and 105+.

I could be wrong, but with 80-85 psi of low fuel pressure I can’t imagine the rail pressure crashing hard especially on the log that’s shoots below 1000 psi.

Are you running the Motiv reflex?
 

Torgus

Colonel
Nov 6, 2016
2,284
1,825
0
Boston
Ride
ACF 6466 E92 + METH
I doubt this will fix it but did you reset your HP fuel system adaptations?

With new Injectors/HPFP/ and plenty of LPFP pressure I would not expect any rail pressure drops. Especially as plenty of fuel should be supplied via the injectors.

Weird reflashing the AIC with the same map would fix things for a day but then it comes back...
 
  • Like
Reactions: N54TT

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
I doubt this will fix it but did you reset your HP fuel system adaptations?

With new Injectors/HPFP/ and plenty of LPFP pressure I would not expect any rail pressure drops.

Yes sir done it plenty of times. I contacted Precision Raceworks to review everything so I’m hoping I have a faulty AIC controller or something within that range.
 

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
Precision Raceworks said based on their experience and looking at my logs it’s most likely a faulty HPFP even though it’s new. I’ll send it back to FCP Euro and reinstall my old one which was working perfectly fine.
 

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
Jesus man I paid $749 for the HPFP on October of 2021 and now it's listed for $838 not including a core charge lol luckily they will be refunding me on this purchase with the life time warranty :fearscream: Well boys hopefully this fixes my issue!
 
  • Like
Reactions: Torgus

Torgus

Colonel
Nov 6, 2016
2,284
1,825
0
Boston
Ride
ACF 6466 E92 + METH
Jesus man I paid $749 for the HPFP on October of 2021 and now it's listed for $838 not including a core charge lol luckily they will be refunding me on this purchase with the life time warranty :fearscream: Well boys hopefully this fixes my issue!

What is up with BMW and their DI fuel parts for the N54?

2k for new index 12 injectors <--I bought mine at $750 wtf has changed to make them cost $1250 more now?
$850 for a HPFP and why do they need a core anyways? It's genuine BMW part. BMW does not sell remanufactured HPFPs. Weird.

Almost 3k on the DI side of the engine IF you DIY it yourself. Insane.
 
  • Like
Reactions: N54TT

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
What is up with BMW and their DI fuel parts for the N54?

2k for new index 12 injectors <--I bought mine at $750 wtf has changed to make them cost $1250 more now?
$850 for a HPFP and why do they need a core anyways? It's genuine BMW part. BMW does not sell remanufactured HPFPs. Weird.

Almost 3k on the DI side of the engine IF you DIY it yourself. Insane.

They're taking full advantage of the system right now with everything being marked up and BMW knows the fuel system is a common failure so its just a great way for them to make money from guys like us modding the crap out of it. FCP probably wants the core because they end up selling it to third party companies that "remanufacture" the HPFP and sell it for half the cost of the OEM. Honestly though imagine I never purchased the HPFP from FCP Euro and had to eat it by spending another $1000.... God Bless FCP Euro. The only thing I hadn't purchased from them were my Index 12 injectors because I couldn't justify paying $2000. I ended up purchasing the injectors from Bavarian Magazine for $239 a piece and apparently they offer a Life Time Warranty as long as you show proof of the injector(s) giving you issues. The only down side was the back-order and 3-4 week wait which I didn't mind since I was in the process of swapping out my turbos and installing all the bolt-ons.

 

N54TT

Corporal
Jul 21, 2020
136
41
0
Ride
2013 335is
Hi guys,

Thanks for all the help. Since getting rid of my junk AIC controller and switching over to the Motiv Reflex+ all my problems went away. Even after installing a new high pressure fuel pump Preicsion Raceworks suggested it didn't resolve the issue.
 

Dumaurier7

Sergeant
May 19, 2020
354
118
0
The problem would have been caused by the AIC because it batch fires the injectors, the longer and faster the injector opening the more the oscillations, as you stated this problem is solved by the Reflex because it sequentially fires the injectors.
 
  • Like
Reactions: turbohugh